braintree

Braintree Payments

  • Popularity Score 1372 Popularity Score

    Popularity ScoreReferrals to Site/Downloads

    0 0 1+ 1+ 250+ 250+ 1000+ 1000+ 10000+ 10000+

Boost sales, lower risk, and save $$ with credit card processing from Braintree and Magento. Updated version!
Compatible with:
This extension is currently unavailable on Magento Connect. Please contact the developer.

You will be re-directed to the developer's website to complete your purchase.

You must be registered and logged in to get extension key.
In order to get this extension, you must be logged in to the Magento Community. Click here to login or register.

Magento Connect 2.0

Magento Connect 2.0

FREE
Previous Next
Overview

Braintree Payments

Braintree Payments

This updated Braintree extension connects your Magento store to the growing leader in global payments. Braintree helps increase sales, reduce risk, and deliver a better customer experience. In addition to accepting credit/debit cards, this extension also supports PayPal Express Checkout which is another payment option in Braintree. Merchants can now go to their Braintree account and see all transactions (cards and PayPal).

Magento ECG Reviewed

Because we wanted the best possible extension - we had the Magento Enterprise Consulting Group (ECG) do a formal review and rigorous testing across many different Magento versions (see below). They reviewed the code for coding standards and best practices. The main benefit for this level of review is to produce a well behaved extension that will minimize the potential for conflict with other extensions and customizations.

While this doesn’t guarantee our extension will work with every extension or customization - it does reduce the chance of conflicts. If you find a conflict, it’s likely to be caused by another installed extension or customization that doesn't follow these guidelines and standards.

Extension Features

This extension uses the latest Braintree v.zero SDK for the best possible experience.

Global coverage
- Accept payments in 130+ currencies
- Available for merchants based in 46 countries (and growing)
- No single-transaction limits

Credit/debit card tokenization for security (Braintree vault)
- Saved cards for simple future checkouts.
- Customers can add, edit, and delete
- Credit card type auto-detected on storefront

Reduce the risk of fraud
- Braintree’s Risk Threshold settings
- Kount's industry leading fraud detection tools at no extra charge
- Supports 3D Secure

Plus
- Receive payout in 2 business days for most transactions
- Simple, transparent pricing
- Award-winning white-glove phone support at no extra cost

Magento ECG Tested Versions
- Community Edition: 1.7.0.2; 1.8.0.0; 1.9.1.0
- Enterprise Edition: 1.12.0.2; 1.13.1.0; 1.14.1.0
- PHP: 5.3; 5.4; 5.5; 5.6
- Tested compatibility with One Step Checkout by One Step Checkout
- Tested compatibility with One Page Checkout by IWD
- Tested compatibility with One Step Checkout by Unicode

Online Guides

- Overview
- Extension Installation
- Braintree Configuration in Magento

Note: There is additional documentation as part of the installation package.

Support

At Braintree we have dedicated Account Teams to proactively flag—and help solve—potential issues early. No robots, just friendly folks answering your calls or emails. Deployment experts are on hand to help with more complex, technical questions.

US Sales: +1.877.511.5036
US Support: +1.877.434.2894
Worldwide Email Support: support@braintreepayments.com

M1 Extension Versions

Now supports v.zero, 3D Secure, and PayPal through Braintree

2015-09-21 19:30:45
  • Version number: 2.0.0
  • Stability: Stable
  • Compatibility: 1.7, 1.8, 1.8.1, 1.9, 1.9.1, 1.9.2, 1.12, 1.13, 1.13.1, 1.14, 1.14.1, 1.14.2
You must be registered and logged in to get extension key.

Magento Connect 2.0

Magento Connect 2.0

This extension now uses the latest Braintree v.zero SDK for the best possible experience and adds PayPal Express Checkout and 3D Secure directly through Braintree. It also enables PayPal One Touch and In-Context.

It supports Community Editions 1.7.0.2; 1.8.0.0; 1.9.1.0, Enterprise Edition: 1.12.0.2; 1.13.1.0; 1.14.1.0, PHP: 5.3; 5.4; 5.5; 5.6 and is compatible with popular checkout extensions.
Reviews

About the Developer

This extension was developed by and is supported by braintree

Rated 5 out of 5 by 1 reviewer.
Rated 5 out of 5 by Good plugin Good and simple plugin to process payments! Recommended December 4, 2015
  • 2016-02-07 T08:53:50.615-06:00
  • bvseo_lps, prod_bvrr, vn_prr_5.6
  • cp-1, bvpage1
  • co_hasreviews, tv_1, tr_1
  • loc_en_US, sid_23988, prod, sort_default
1-1 of 1
Q&A
(21 Questions : 12 Answers)

Product Q&A

Ask your questions. Share your answers.

 
 
« Back
 
 
Sort by
Avatar Image Url:: http://www.magentocommerce.com/images/avatars/uploads/avatar_27588589
Customer avatar
by
dkobia
-
1 year, 6 months ago
+1point
1out of 1found this question helpful.
Was this helpful?Yes1No0

Answers

Avatar Image Url:: http://www.magentocommerce.com/images/avatars/uploads/avatar_262991
Customer avatar
Answer: 
To add to my previous answer, I saw in the package file that Connect won't let you install this if you're running 5.4. 5.4 is not officially supported by Magento yet but there's a patch out there to enable it. So while 5.4 isn't officially supported for the extension, at a glance I don't see anything in the code that would keep it from working on 5.4. You'd just need to use a tool like http://freegento.com/ddl-magento-extension.php to create an installer package for install outside of Connect. And then of course, this setup wouldn't be officially supported.
by
Rocket Web
-
1 year, 6 months ago
-3points
0out of 3found this answer helpful.
Was this helpful?Yes0No3

Avatar Image Url:: http://www.magentocommerce.com/images/avatars/uploads/avatar_262991
Customer avatar
Answer: 
Here's an example demo store with php 5.3.10 and version 1.0 of the extension installed:

http://braintree.sv1.magetesting.com/UgCHw9043/

I didn't have any problems installing or using any feature of this extension with this php version. Looking at the code, I don't see any reason why this wouldn't work with php 5.4 either.

Check your web server logs and Magento log files at [MAGENTO_ROOT]/var/log/ for potential errors with your store. Also make sure compilation is off before installing, flush your javascript cache after installing if you have js files combined into one and if you get a 404 error when visiting the extension in the admin just log out and log back into the admin. I bet you're experiencing some issue like this or that's related to something else broken in your store. I can't see how a php version greater than 5.3.1 would cause problems. If your developer can look at your log files they should be able to quickly figure out what the problem is with your store.
by
Rocket Web
-
1 year, 6 months ago
-2points
1out of 4found this answer helpful.
Was this helpful?Yes1No3

Customer avatar
Answer: 
Version 1.0.03 was recently introduced which features support for PHP 5.2.1 -> 5.5.22
by
Seba G Gonnelli
-
10 months ago
-1point
0out of 1found this answer helpful.
Was this helpful?Yes0No1
Avatar Image Url:: http://www.magentocommerce.com/images/avatars/uploads/avatar_27251542
Customer avatar
We have been using magento 1.7.2.
Whiile we try to take order in the admin end using braintree, order has been successful.There is no issue.

In magento admin end "System->Configuration->Developer->javascript settings". set "Merge JavaScript Files" to "Yes".After changing this settings, We cannot take order in the admin end using braintree, there have some error in the firebug "ReferenceError: Braintree is not defined".

Kindly help to us.
by
mkprabu123
-
1 year, 6 months ago
0points
0out of 0found this question helpful.
Was this helpful?Yes0No0

Answers

Avatar Image Url:: http://www.magentocommerce.com/images/avatars/uploads/avatar_26059242
Customer avatar
Answer: 
We believe the issue here is that the Braintree JavaScript files are external to Magento Core JS files, so when the Merge function is turned on, the Braintree files are not actually being merged. We do not recommend enabling this feature when using the Braintree Payments extension.
by
braintree
-
1 year, 6 months ago
0points
0out of 0found this answer helpful.
Was this helpful?Yes0No0

Avatar Image Url:: http://www.magentocommerce.com/images/avatars/uploads/avatar_262991
Customer avatar
Answer: 
This extension works well with merged JavaScript and CSS. Installing an extension will not automatically flush your JavaScript cache if you already have all your JS merged into one file. It's a good practice to not do this automatically but that means when you install an extension, if there are JS files, you need to remember to manually flush the cache to get an extension to work properly.

Go to System -> Cache Management and click the Flush JavaScript/CSS Cache button and you should be all set.

For reference, here's a 1.7.0.2 demo store with the extension installed and javascript merging enabled: http://braintree.sv1.magetesting.com/UgCHw9043/
by
Rocket Web
-
1 year, 6 months ago
0points
0out of 0found this answer helpful.
Was this helpful?Yes0No0
 
1 answer

PHP 5.4

Avatar Image Url:: http://www.magentocommerce.com/images/avatars/uploads/avatar_27605642
Customer avatar
So I've got the latest version of Magento 1.9 which I believe supports php 5.4?

Have tried to install this app and it doesn't work. Have tried suggestions in the other answer to no avail.
by
tongnk
-
1 year, 6 months ago
+2points
2out of 2found this question helpful.
Was this helpful?Yes2No0

Answers

Customer avatar
Answer: 
Version 1.0.03 was recently introduced which features support for PHP 5.2.1 -> 5.5.22
by
Seba G Gonnelli
-
10 months ago
0points
0out of 0found this answer helpful.
Was this helpful?Yes0No0
Avatar Image Url:: http://www.magentocommerce.com/images/avatars/uploads/avatar_27351343
Customer avatar
running on Magento ce 1.9

Have installed the extension successfully - but when i go to

configuration > Sales > Payment Services

I get these errors

Fatal error: Class 'Braintree_Payments_Helper_Data' not found in /home/caraudio/public_html/app/Mage.php on line 547
Fatal error: Class 'Mage' not found in /home/caraudio/public_html/includes/src/Mage_Core_functions.php on line 244
Fatal error: Class 'Mage' not found in /home/caraudio/public_html/includes/src/Mage_Core_Model_Resource_Session.php on line 108
by
DanielCode
-
1 year, 5 months ago
0points
0out of 0found this question helpful.
Was this helpful?Yes0No0

Answers

Avatar Image Url:: http://www.magentocommerce.com/images/avatars/uploads/avatar_26059242
Customer avatar
Answer: 
This error tells us the extension was not fully installed or perhaps compilation was not turned off before installation.

We have gone through rigorous testing on all supported Magento versions and are confident this will work on any store that has been coded according to Magento standards.

Feel free to send a support request to solutions@braintreepayments.com with your Magento connection details and we'll be happy to help you install this extension.
by
braintree
-
1 year, 5 months ago
0points
0out of 0found this answer helpful.
Was this helpful?Yes0No0
Avatar Image Url:: http://www.magentocommerce.com/images/avatars/uploads/avatar_27631107
Customer avatar
by
Leon_K
-
1 year, 4 months ago
+6points
6out of 6found this question helpful.
Was this helpful?Yes6No0

Answers

Customer avatar
Answer: 
Version 1.0.03 was recently introduced which features support for PHP 5.2.1 -> 5.5.22
by
Seba G Gonnelli
-
10 months ago
0points
0out of 0found this answer helpful.
Was this helpful?Yes0No0
 
1 answer

php 5 support?

Avatar Image Url:: http://www.magentocommerce.com/images/avatars/uploads/avatar_27484640
Customer avatar
when?
tnx
by
nunziothemast
-
1 year, 4 months ago
+3points
3out of 3found this question helpful.
Was this helpful?Yes3No0

Answers

Customer avatar
Answer: 
Version 1.0.03 was recently introduced which features support for PHP 5.2.1 -> 5.5.22
by
Seba G Gonnelli
-
10 months ago
0points
0out of 0found this answer helpful.
Was this helpful?Yes0No0
 
1 answer

PHP5 error

Avatar Image Url:: http://www.magentocommerce.com/images/avatars/uploads/avatar_27035356
Customer avatar
CONNECT ERROR: Package community/Braintree_Payments 1.0.02: requires PHP version >= 5.2.1 and <= 5.4.32 current is: 5.5.9-1ubuntu4.4

Any idea of when this will be supported?
by
asulikeit
-
1 year, 3 months ago
+2points
2out of 2found this question helpful.
Was this helpful?Yes2No0

Answers

Customer avatar
Answer: 
Version 1.0.03 was recently introduced which features support for PHP 5.2.1 -> 5.5.22
by
Seba G Gonnelli
-
10 months ago
0points
0out of 0found this answer helpful.
Was this helpful?Yes0No0
 
1 answer

5.4.32 Support

Avatar Image Url:: http://www.magentocommerce.com/images/avatars/uploads/avatar_27700782
Customer avatar
Also looking for support- for 5.4.32?!
by
Cmebusiness
-
1 year, 1 month ago
0points
0out of 0found this question helpful.
Was this helpful?Yes0No0

Answers

Customer avatar
Answer: 
Version 1.0.03 was recently introduced which features support for PHP 5.2.1 -> 5.5.22
by
Seba G Gonnelli
-
10 months ago
+1point
1out of 1found this answer helpful.
Was this helpful?Yes1No0
Avatar Image Url:: http://www.magentocommerce.com/magento-connect/media/avatars/avatar_231635.jpg
Customer avatar
I have installed this module but I cannot find where I can enable "Saved Credit Card" functionality. Please advise.
by
Ehsan K
-
1 month, 4 weeks ago
0points
0out of 0found this question helpful.
Was this helpful?Yes0No0

Answers

Avatar Image Url:: https://www.magentocommerce.com/magento-connect/skin/frontend/enterprise/connect/images/pictures/developer-avatar.jpg
Customer avatar
Answer: 
In your configuration, under "Credit Card Payments", you'll find an option called "Use Vault". Enabling that will switch on the saved credit card functionality.
by
avoges
-
1 month, 3 weeks ago
+1point
1out of 1found this answer helpful.
Was this helpful?Yes1No0
Avatar Image Url:: http://www.magentocommerce.com/images/avatars/uploads/avatar_27179141
Customer avatar
This is a must for disabling the Braintree payment method for Zero Value checkouts.

Thanks
by
williamie
-
1 year, 2 months ago
0points
0out of 0found this question helpful.
Was this helpful?Yes0No0
  • 2016-02-07 T08:55:24.925-06:00
  • bvseo_lps, prod_bvqa, vn_prr_5.6
  • cp-1, bvpage1
  • co_hasquestionsanswers
  • loc_en_US, sid_23988, prod, sort_default
2 next>>
  • 2016-02-07 T08:55:24.928-06:00
  • bvseo_lps, prod_bvqa, vn_prr_5.6
  • cp-1, bvpage1
  • co_hasquestionsanswers
  • loc_en_US, sid_23988, prod, sort_default
2 next>>
Get Help

Support for This Extension

The best place to start if you need help with a specific extension is to contact the developer. All Magento developers have both a contact email and a support email listed.

Magento Platform Support

If you need support for a Magento platform, there are different options for support depending on which Magento platform you are using. Below are links for specific platforms.

In order to upload extension, you must be logged in to the Magento Community. Click here to login or register.

Close

Register

* Required Fields

Close window

Forgot Your Password?

Please enter your email below and we'll send you a new password.

* Required Fields

Close window

Login

To upload extension you must be logged in.

* Required Fields

Close window

You are using an outdated browser

We built Magento Connect using the latest techniques and technologies.
This makes Magento Connect faster and easier to use.
Unfortunately, your browser doesn't support those technologies.
Use the links below to download a new browser or upgrade your existing browser.