TechPostcodeNl

Postcode.nl postcode complementation and validation

  • Popularity Score 1662 Popularity Score

    Popularity ScoreReferrals to Site/Downloads

    0 0 1+ 1+ 250+ 250+ 1000+ 1000+ 10000+ 10000+

Complement and validate Dutch addresses at Checkout with the free postcode Magento plugin from Postcode.nl.
Compatible with:
This extension is currently unavailable on Magento Connect. Please contact the developer.

You will be re-directed to the developer's website to complete your purchase.

You must be registered and logged in to get extension key.
In order to get this extension, you must be logged in to the Magento Community. Click here to login or register.
In order to get this extension, you must have active Magento Go Store. Click here to create Go store.
You must choose from Magento Connect Version 1.5.1.0 or 2.0.
Learn more

Magento Connect 1.0 change

FREE
Previous Next
Overview

Postcode.nl postcode complementation and validation

Complement and validate Dutch addresses at Checkout with the free postcode Magento plugin from Postcode.nl. The customer only has to provide postcode and house number and the complete address will shown in the checkout process.

  • Prevent address errors
  • Reduce costs from undelivered mail and packages
  • Offer extra service for your customers with easy address entry
  • Improve sale conversion

  • The extension is activated whenever the Netherlands is the current country, or when the user selects the Netherlands. When another country is selected, the regular address fields are shown. The postcode Magento extension from Postcode.nl is free of charge, but a Fair Use Policy is enforced. The use of the Postcode.nl Magento extension is subject to our Terms and Conditions.

    Get your free Postcode.nl login information here: Postcode.nl API registration

    Do you want help improve or extend this extension? Take a look at our GitHub page.
    Stand-alone 'zip' downloads of this extension are also available via GitHub, using the Zip download functionality. (latest version: 1.1.1.0)

    Magento Version Compatiblity

    The most recent 1.1.x.x branch of our extension supports Magento CE v1.6 to v1.8, running on PHP 5.4 and up. (PHP 5.2 and 5.3 only have provisional support - please consider upgrading your PHP, for security & stability, and patch your Magento version, if needed)
    The 1.0.x.x versions of our extension support Magento v1.4 - 1.7, see The release notes page for these versions.

    Checkout extension compatibility

    This extension has been confirmed to work with the following checkout extensions:
  • OneStepCheckout(.com)

  • The following extensions have provisional support:
  • GoMage LightCheckout
  • Fire Checkout 1.5 & 2.0
  • FME One Step Checkout
  • Quick One Page Checkout
  • MageStore One Step Checkout
  • IWD Free One Page / Step Checkout
  • Apptha One Step Checkout
  • Ecommerce Three-Step Checkout
  • Grafisch Direct One step checkout
  • EcommerceTeam Easy Checkout 2.0
  • Aitoc One Step Checkout Manager
  • AheadWorks One Step Checkout
  • J2T OneCheckout
  • MagentoTemplate OnePage Magento Checkout
  • MageWorld One Step Checkout Pro
  • MAGExtended MasterCheckout

  • If you would like us to support another checkout extension you use, please let us know in a review, a private message, or send an email to info "at" postcode.nl!
    Release Notes

    Minor fixes and features

    2014-06-18 13:12:11
    • Version number: 1.1.1.0
    • Stability: Stable
    • Compatibility: 1.6, 1.6.1, 1.6.2.0, 1.7, 1.8, 1.8.1, 1.9
    You must be registered and logged in to get extension key.

    Magento Connect 2.0

    Magento Connect 2.0

    Fixes:
    - Support more MageStore OneStepCheckout versions
    - Support newest IWD One Step Checkout version
    - Corrected some checkout extension detection
    - Editing roles/rights in admin would fail
    Added provisional support for the following checkout modules:
    - MAGExtentended MasterCheckout
    Features:
    - If error message mentions 'use manual', manual checkbox is toggled automatically
    - Tweaked compatibility with Magento 1.9

    New features, more support

    2014-03-07 10:25:04
    • Version number: 1.1.0.0
    • Stability: Stable
    • Compatibility: 1.6, 1.6.1, 1.6.2.0, 1.7, 1.8, 1.8.1
    You must be registered and logged in to get extension key.

    Magento Connect 2.0

    Magento Connect 2.0

    - Compatibility changes for Magento CE 1.8.0.0+
    - Compatibility with newer version of currently supported checkout extensions
    - An interaction bug during checkout in Internet Explorer 9
    Added provisional support for the following checkout modules:
    - Aitoc One Step Checkout Manager
    - AheadWorks One Step Checkout
    - J2T OneCheckout
    - MagentoTemplate OnePage Magento Checkout
    - MageWorld One Step Checkout Pro
    Features:
    - Option to disallow post office box (postbus) addresses
    - Option to disable checks in the admin

    Restrictions:
    - Only support for Magento CE v1.6 and up

    Compatiblity & Bugfixes

    2013-05-14 09:57:22
    • Version number: 1.0.8.0
    • Stability: Stable
    • Compatibility: 1.4, 1.4.1.1, 1.4.2, 1.5, 1.6, 1.6.1, 1.6.2.0, 1.7
    You must be registered and logged in to get extension key.
    You must choose from Magento Connect Version 1.5.1.0 or 2.0.
    Learn more

    Magento Connect 1.0 change

    Fixes:
    - Prevent error when changing admin roles
    Changes:
    - Added provisional support for Fire Checkout 1.5
    - Added provisional support for EcommerceTeam Easy Checkout 2.0
    - Validation texts are hidden when the country is not the Netherlands

    Minor feature release

    2013-03-21 15:14:35
    • Version number: 1.0.7.0
    • Stability: Stable
    • Compatibility: 1.4, 1.4.1.1, 1.4.2, 1.5, 1.6, 1.6.1, 1.6.2.0, 1.7
    You must be registered and logged in to get extension key.
    You must choose from Magento Connect Version 1.5.1.0 or 2.0.
    Learn more

    Magento Connect 1.0 change

    - Improved 'Never hide country selector' option to also work for regular checkouts
    - Added provisional support for GrafischDirect One Step Checkout
    - Improved address housenumber addition user input matching
    - More Magento coding-standards compliant

    Bugfix release

    2013-03-07 15:05:23
    • Version number: 1.0.6.5
    • Stability: Stable
    • Compatibility: 1.4, 1.4.1.1, 1.4.2, 1.5, 1.6, 1.6.1, 1.6.2.0, 1.7
    You must be registered and logged in to get extension key.
    You must choose from Magento Connect Version 1.5.1.0 or 2.0.
    Learn more

    Magento Connect 1.0 change

    - Fix an issue with the regular expressions updated in the previous version
    1 2 3 4
    Reviews

    About the Developer

    This extension was developed by and is supported by TechPostcodeNl

    Postcode.nl postcode complementation and validation 2.8 5 7 7
    Works straight out of the box I see some negative feedback, but no issues here. Don't know if it's because of the version (1.9.0.1), or the onstepcheckout.com version (latest) I'm using, but everything works just fine without any hassle. Very useful and fully implemented + tested within 15 minutes. July 16, 2014
    No docs for onestepcheckout checked postcode.nl for this extension. It should support onesetpcheckout. Problem is there is no documentation on how this can be supported. when installed it breaks my onestepcheckout template, so I disabled this. on postcode.nl it mentions you can get installation help for 36 euro standard amgento checkout and 125 euro for onestepcheckout. So basically in order to get this extension to work using onestep checkout you need to pay 125 euro. Since there is no documentation how to get this to work, I would suggest to change the status of this extension from free to paid. December 23, 2013
    Doesnt work with IWD One Page Checkout It says it works with IWD Free One Page Checkout but I can't seem to get it to work. Ended up deactivating the module to get checkout running again. November 6, 2013
    404 Error I get an 404 error when i click on system -> configuration -> Postcode.nl API Magento versie 1.7.0.2 May 2, 2013
    Mooie extensie Perfecte extensie en helemaal gratis! Adviseer deze extensie aan iedereen. March 5, 2013
    Werkt perfect in 1.7 February 8, 2013
    Still files seem to be missing in the 1.0.6.1 version: http://pastebin.com/awBNtPMB January 9, 2013
    1-7 of 7
    Q&A
    (8 Questions : 8 Answers)

    Product Q&A

    Ask your questions. Share your answers.

     
     
    « Back
     
     
    Sort by
    Avatar Image Url:: http://www.magentocommerce.com/images/avatars/uploads/avatar_26632420
    Customer avatar
    I get an error when I want to add a user role to my backend. I'm on 1.0.6.5

    The error is:
    Fatal error: Class 'Mage_PostcodeNl_Api_Helper_Data' not found in /app/Mage.php on line 546
    by
    evelien
    -
    1 year, 5 months ago
    0points
    0out of 0found this question helpful.
    Was this helpful?Yes0No0

    Answers

    Avatar Image Url:: http://www.magentocommerce.com/images/avatars/uploads/avatar_26497243
    Customer avatar
    Answer: 
    This error is resolved in latest version 1.0.8.0.

    Also, if you want resolve this error in your current version of this extension, just replace this code in config.xml of this extension:

    <helpers>
    <postcodenl_api>
    <class>PostcodeNl_Api_Helper</class>
    </postcodenl_api>
    </helpers>

    with

    <helpers>
    <postcodenl_api>
    <class>PostcodeNl_Api_Helper</class>
    </postcodenl_api>
    <PostcodeNl_Api>
    <class>PostcodeNl_Api_Helper</class>
    </PostcodeNl_Api>
    </helpers>
    by
    nimitshah
    -
    1 year, 2 months ago
    +1point
    1out of 1found this answer helpful.
    Was this helpful?Yes1No0

    Avatar Image Url:: http://www.magentocommerce.com/images/avatars/uploads/avatar_26504471
    Customer avatar
    Answer: 
    Hi evelien,
    This is resolved in the latest version (1.0.8.0).
    by
    TechPostcodeNl
    -
    1 year, 3 months ago
    0points
    0out of 0found this answer helpful.
    Was this helpful?Yes0No0
    Avatar Image Url:: http://www.magentocommerce.com/images/avatars/uploads/avatar_313575
    Customer avatar
    When I'll do a REST request to the API it will automatically use the HTTP protocol what results in the following error - SSL certificate problem: unable to get local issuer certificate
    by
    suneco
    -
    3 months, 4 weeks ago
    0points
    0out of 0found this question helpful.
    Was this helpful?Yes0No0

    Answers

    Avatar Image Url:: http://www.magentocommerce.com/images/avatars/uploads/avatar_313575
    Customer avatar
    Answer: 
    I switched from my local development environment to a test environment where a normal domain(not a virtual host) is running and everything worked fine.
    by
    suneco
    -
    3 months, 4 weeks ago
    +1point
    1out of 1found this answer helpful.
    Was this helpful?Yes1No0

    Avatar Image Url:: http://www.magentocommerce.com/images/avatars/uploads/avatar_26504471
    Customer avatar
    Answer: 
    A more extended answer for those encountering similar problems: since this extension connects via https to the postcode.nl servers, the webserver running the magento store needs an up-to-date SSL Central Authority certificate (CA cert) configured. This usually is the case, but some older systems might not have this configured properly. Contact your server administrator, and/or read this documentation: http://curl.haxx.se/docs/sslcerts.html
    by
    TechPostcodeNl
    -
    2 months, 2 weeks ago
    0points
    0out of 0found this answer helpful.
    Was this helpful?Yes0No0
    Avatar Image Url:: http://www.magentocommerce.com/images/avatars/uploads/avatar_26703687
    Customer avatar
    Wie weet of deze plugin ook werkt als je ook afterpay gebruikt? Ik weet dat die ook een adres check doen en dat dat niet altijd samen werkt. Iemand ervaring?
    by
    Eva88
    -
    1 year, 6 months ago
    +1point
    1out of 1found this question helpful.
    Was this helpful?Yes1No0

    Answers

    Avatar Image Url:: http://www.magentocommerce.com/images/avatars/uploads/avatar_26504471
    Customer avatar
    Answer: 
    Beste Eva,

    Helaas is deze extensie op dit moment (versie 1.0.6.5) niet compatibel met de Afterpay extensie.
    We onderzoeken dit voor een toekomstige versie.
    by
    TechPostcodeNl
    -
    1 year, 5 months ago
    0points
    0out of 0found this answer helpful.
    Was this helpful?Yes0No0
    Avatar Image Url:: http://www.magentocommerce.com/images/avatars/uploads/avatar_184827
    Customer avatar
    (Kun je bijvoorbeeld de plugin per shop en enkel voor Nederland aanzetten?)
    by
    webmastermagento
    -
    1 year, 4 months ago
    0points
    0out of 0found this question helpful.
    Was this helpful?Yes0No0

    Answers

    Avatar Image Url:: http://www.magentocommerce.com/images/avatars/uploads/avatar_26504471
    Customer avatar
    Answer: 
    Ja, je kan in de Magento admin per shop verschillende systeem instellingen invoeren. Dus dan kan je bij de Nederlands shop de Postcode.nl API 'Enabled?' optie aanzetten, en bij een Engelse shop diezelfde optie uitzetten.

    Let wel dat de verrijkings velden sowieso niet getoond worden als het factuur/verstuur land niet Nederland is.
    by
    TechPostcodeNl
    -
    1 year, 3 months ago
    0points
    0out of 0found this answer helpful.
    Was this helpful?Yes0No0
    Avatar Image Url:: http://www.magentocommerce.com/images/avatars/uploads/avatar_27089512
    Customer avatar
    Hi
    after intstalling the plugin I get an 404 error in my system -> conf -> Postcode.nl API.

    Can anybody help me because I would use this plugin.
    by
    ajprins
    -
    1 year ago
    0points
    0out of 0found this question helpful.
    Was this helpful?Yes0No0

    Answers

    Avatar Image Url:: http://www.magentocommerce.com/images/avatars/uploads/avatar_26504471
    Customer avatar
    Answer: 
    Hi ajprins,

    Magento caches some access rights in sessions - this issue is most likely fixed by logging out with your admin user, and then logging in again.
    by
    TechPostcodeNl
    -
    1 year ago
    0points
    0out of 0found this answer helpful.
    Was this helpful?Yes0No0
    Avatar Image Url:: http://www.magentocommerce.com/images/avatars/uploads/avatar_26497243
    Customer avatar
    Hi,

    When I try to create new order from backend, then first time the auto-validation of postcode and housenumber fields are not activated. The new order creation page has address part normal. But when I refresh the page, the postcode and house number validation fields get activated.
    I want the extension to be working on the first time also. Please give me a fix for this bug.

    Please help me out.

    Regards,
    Nimit Shah
    by
    nimitshah
    -
    10 months ago
    0points
    0out of 0found this question helpful.
    Was this helpful?Yes0No0

    Answers

    Avatar Image Url:: http://www.magentocommerce.com/images/avatars/uploads/avatar_26504471
    Customer avatar
    Answer: 
    Hi Nimit,

    Thank you for your feedback, we will investigate your issue. If you have any additional information, please contact us at tech<at>postcode.nl.

    Kind regards,
    Postcode.nl Tech Support
    by
    TechPostcodeNl
    -
    10 months ago
    0points
    0out of 0found this answer helpful.
    Was this helpful?Yes0No0
    Avatar Image Url:: http://www.magentocommerce.com/images/avatars/uploads/avatar_78168
    Customer avatar
    I see some remarks that this works with different onestepcheckouts.

    On magento there is 1 original onestepcheckout, is this supported.
    by
    bobmats
    -
    8 months ago
    0points
    0out of 0found this question helpful.
    Was this helpful?Yes0No0
    Avatar Image Url:: http://www.magentocommerce.com/images/avatars/uploads/avatar_184827
    Customer avatar
    by
    webmastermagento
    -
    1 year, 4 months ago
    0points
    0out of 0found this question helpful.
    Was this helpful?Yes0No0
    1 of 1
    1 of 1
    Get Help

    Support for This Extension

    The best place to start if you need help with a specific extension is to contact the developer. All Magento developers have both a contact email and a support email listed.

    Magento Platform Support

    If you need support for a Magento platform, there are different options for support depending on which Magento platform you are using. Below are links for specific platforms.

    In order to upload extension, you must be logged in to the Magento Community. Click here to login or register.

    Close

    Register

    * Required Fields

    Close window

    Forgot Your Password?

    Please enter your email below and we'll send you a new password.

    * Required Fields

    Close window

    Login

    To upload extension you must be logged in.

    * Required Fields

    Close window

    You are using an outdated browser

    We built Magento Connect using the latest techniques and technologies.
    This makes Magento Connect faster and easier to use.
    Unfortunately, your browser doesn't support those technologies.
    Use the links below to download a new browser or upgrade your existing browser.