Magento

Cybersource Extension

  • Popularity Score 2526 Popularity Score

    Popularity ScoreReferrals to Site/Downloads

    0 0 1+ 1+ 250+ 250+ 1000+ 1000+ 10000+ 10000+

24/7 credit and debit card payment processing in over 150 currencies
Compatible with:
This extension is currently unavailable on Magento Connect. Please contact the developer.

You will be re-directed to the developer's website to complete your purchase.

You must be registered and logged in to get extension key.
In order to get this extension, you must be logged in to the Magento Community. Click here to login or register.
In order to get this extension, you must have active Magento Go Store. Click here to create Go store.
You must choose from Magento Connect Version 1.5.1.0 or 2.0.
Learn more

Magento Connect 1.0 change

FREE
Previous Next
Overview

Cybersource Extension

CyberSource ensures secure and reliable credit and debit processing in multiple currencies. This extension allows developers to integrate Magento eCommerce stores with this powerful portal.

  • 150+ worldwide currencies accepted
  • Rapid real-time processing speed
  • Supports a wide range of universal and regional cards
  • Provides payment gateway integration using SOAP toolkit APT
  • Transactions processed 24/7 regardless of volume growth or peaks in order volume

  • Please note: To achieve PCI compliance using Cybersource Extension, your whole Magento setup needs to be assessed. For easier PCI compliance, we recommend using Magento Enterprise Edition which contains PA-DSS certified payment integration with Cybersource or Magento Go, a PCI compliant shopping cart that includes Cybersource integration.

    Release Notes

    Cybersource payment gateway integration

    2008-04-16 06:33:26
    • Version number: 1.0.0
    • Stability: Beta
    • Compatibility: 1.1, 1.2, 1.6, 1.11
    You must be registered and logged in to get extension key.
    You must choose from Magento Connect Version 1.5.1.0 or 2.0.
    Learn more

    Magento Connect 1.0 change

    This extension provides Cybersource payment gateway integration with SOAP toolkit API. It requires PHP SOAP extension to be installed.
    Reviews

    About the Developer

    This extension was developed by and is supported by Magento

    Cybersource Extension 1 5 10 10
    Does not run as described Be very careful with this extension, as it requires ioncube. Ioncube should not be run in a production environment, especially with Magento, as it will slow down your site and there will be a very significant performance hit. Because it requires ioncube, the extension is not extendable. Worthless. November 17, 2014
    Website do not load Website do not run in web after installing this extension. I'm using Magento ver. 1.7.0.2 March 22, 2013
    If you upgraded to Magento 1.7 and get a popup message "undefined" when trying to complete a purchase using this extension, I found this post helpful. A slight modification to one of the Cybersource files is needed to be compatible with SOAP Client on PHP 5.3. http://stackoverflow.com/questions/6219239/soap-error-when-trying-to-use-the-cybersource-module-within-magento Hope this helps everyone....no wonder I wasn't getting any sales. :( October 23, 2012
    One issue, when there is a ZERO payment somehow it logs the card type as VISA, before upgrade.. could be magento or this extension I upgrade both.. it would have a blank value. Can anyone tell me if it is related to this extension or not? February 26, 2012
    Been using this flawlessly for the past few months. Just recently, we started getting SOAP errors when processing orders through Cybersource. The errors: Payment transaction failed. Reason SOAP-ERROR: Parsing WSDL: Couldn't load from 'https://ics2ws.ic3.com/commerce/1.x/transactionProcessor/CyberSourceTransaction_1.26.wsdl' : failed to load external entity "https://ics2ws.ic3.com/commerce/1.x/transactionProcessor/CyberSourceTransaction_1.26.wsdl" February 1, 2012
    We get the following error in Downloader console: Exception during cache and session cleaning And after cleaning cache we get fatal error in setup.php January 13, 2012
    Other are recommending a manual install of this extension, but for the life of me I can't find anywhere to download the package. I just attempted a Connect installation of this on a pretty vanilla 1.5.1 install and it didn't do what I've seen other extension installations do. It didn't take the store out of maintenance mode after install, and browsing to the frontend or backend spits out error messages. Once again, thanks Magento for providing adequate documentation. *sigh* September 12, 2011
    I can verify that this module can be used on nearly all versions of Magento, I'm currently using it on a clients store, 1.5.1.0. But manual installs are a must. Not only that, but you'll have to excise every last piece of it in order to upgrade Magento. I've already had to do it 4 times now. Truly a pain! What really bugs me about this module is that it wasn't developed by Cybersource, its actually written by Magento Core Staff, and they're failing to upgrade a module that sees a great deal of use. But ok, Authorize.net is written into Magento core. Its one in the same company.... I don't get that. Magento Staff, Please Update Your Module!!!!! 2.5 years without an update is a bit excessive, don't you think? May 4, 2011
    I just confirmed and installed it in latest stable version of magento 1.4.2 - and its working great. You need to manually install this one - I did mine using FTP :) I used this link as a reference http://www.aschroder.com/2010/05/installing-a-magento-extension-manually-via-ftp-or-ssh/ February 9, 2011
    Well, We implemented Magento BECAUSE there is a cybersource extension, then come to learn it's not up to date.... not good. ....Anyone know of a third party extension developer we can go to? July 13, 2010
    1-10 of 10
    Q&A
    (4 Questions : 0 Answers)

    Product Q&A

    Ask your questions. Share your answers.

     
     
    « Back
     
     
    Sort by
    Avatar Image Url:: http://www.magentocommerce.com/images/avatars/uploads/avatar_26228553
    Customer avatar
    may be error around these liles..in file...\app\code\local\Mage\Cybersource\Model\Soap.php

    try {
    $result = $soapClient->runTransaction($this->_request);

    if ($result->reasonCode==self::RESPONSE_CODE_SUCCESS) {
    /*
    for multiple capture we need to use the latest capture transaction id
    */
    $payment->setLastTransId($result->requestID)
    ->setLastCybersourceToken($result->requestToken)
    ->setCcTransId($result->requestID)
    ->setTransactionId($result->requestID)
    ->setIsTransactionClosed(0)
    ->setCybersourceToken($result->requestToken)
    ;
    } else {
    $error = Mage::helper('cybersource')->__('There is an error in processing the payment. Please try again or contact us.');
    }
    } catch (Exception $e) {
    Mage::throwException(
    Mage::helper('cybersource')->__('Gateway request error: %s', $e->getMessage())
    );
    }

    please suggest....
    by
    ankit_dadhich
    -
    1 year, 9 months ago
    0points
    0out of 0found this question helpful.
    Was this helpful?Yes0No0
    Avatar Image Url:: http://www.magentocommerce.com/images/avatars/uploads/avatar_25845847
    Customer avatar
    Does it support Enterprise 1.12? What is the difference between this ext and the out-of-box Cybersource (SOAP Toolkit) in 1.12.
    by
    silkdev
    -
    1 year, 8 months ago
    +1point
    1out of 1found this question helpful.
    Was this helpful?Yes1No0
     
    0 answers

    3D Secure

    Avatar Image Url:: http://www.magentocommerce.com/images/avatars/uploads/avatar_113825
    Customer avatar
    I need 3D Secure
    by
    mshaheen1982
    -
    1 year, 6 months ago
    0points
    0out of 0found this question helpful.
    Was this helpful?Yes0No0
    Avatar Image Url:: http://www.magentocommerce.com/images/avatars/uploads/avatar_27512528
    Customer avatar
    Hi, I installed cybersource extension and added the access and serial key into the code. Now currency and orderPage_signaturePublic is invalid. How can I proceed furhter? What have I done wrong? Any help would be appreciated
    by
    RafidS
    -
    6 months ago
    0points
    0out of 0found this question helpful.
    Was this helpful?Yes0No0
    1 of 1
    1 of 1
    Get Help

    Support for This Extension

    The best place to start if you need help with a specific extension is to contact the developer. All Magento developers have both a contact email and a support email listed.

    Magento Platform Support

    If you need support for a Magento platform, there are different options for support depending on which Magento platform you are using. Below are links for specific platforms.

    In order to upload extension, you must be logged in to the Magento Community. Click here to login or register.

    Close

    Register

    * Required Fields

    Close window

    Forgot Your Password?

    Please enter your email below and we'll send you a new password.

    * Required Fields

    Close window

    Login

    To upload extension you must be logged in.

    * Required Fields

    Close window

    You are using an outdated browser

    We built Magento Connect using the latest techniques and technologies.
    This makes Magento Connect faster and easier to use.
    Unfortunately, your browser doesn't support those technologies.
    Use the links below to download a new browser or upgrade your existing browser.