Posting in the Magento forums has been disabled pending the implementation of a new and improved forum solution which should better serve the community.

For new questions please post at magento.stackexchange.com, the community-run support site for the Magento community. We will be providing updates on the new forum solution soon. For questions or concerns please email community@magento.com.

Magento Forum

My catalog images look like someone pooped on them
 
the311guy
Sr. Member
 
Avatar
Total Posts:  120
Joined:  2007-10-18
 

My catalog browse images look gross and compressed.  Especially the ones that are solid colors like red.  Looks like a jungle of deforested jpeg compression.  I’ve tried to remove all instances of images auto-resizing, but they still look ugly.

Here is the code im using to display an image.  If anyone knows any way I can made it not look like poop, please let me know:

<img src="<?php echo $this->helper('catalog/image')->init($_product, 'small_image');?>” alt="<?php echo $this->htmlEscape($_product->getName()) ?>” />

thanks
smile

 
Magento Community Magento Community
Magento Community
Magento Community
 
dan_w
Sr. Member
 
Total Posts:  290
Joined:  2008-01-04
 

Check out this thread to have image resize scale to original proportions:
http://www.magentocommerce.com/boards/viewthread/5502/

You may want to also look at this thread for changing compression level in GD2:
http://www.magentocommerce.com/boards/viewthread/6158/

Making those changes should help with image appearance.

 
Magento Community Magento Community
Magento Community
Magento Community
 
SpringMountain
Jr. Member
 
Avatar
Total Posts:  20
Joined:  2008-04-19
Napa Valley, CA
 

I cannot see your images so I am not exactly sure what is happening.

I use photoshop to handle my compression (save for web and devices, compression varies based on image but i try to keep all main images under 200k). I also don’t let magento handle the conversion between main, small, and thumbnail, only small to thumbnail. I upload images via csv, not the magento interface (a whole other thread) and it works swimmingly (i.e. no poop in the pool).

You can also disable jpeg compression on magento’s end:
http://www.magentocommerce.com/boards/viewthread/6158/

But I have yet to have to do this as my images are just fine as they are now. You can see them at:

http://www.springmountaindesigns.com/hogfrollow

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top