Posting in the Magento forums has been disabled pending the implementation of a new and improved forum solution which should better serve the community.

For new questions please post at magento.stackexchange.com, the community-run support site for the Magento community. We will be providing updates on the new forum solution soon. For questions or concerns please email community@magento.com.

Magento Forum

PHP Extension “pdo_mysql” must be loaded
 
klaudia
Jr. Member
 
Total Posts:  5
Joined:  2008-06-08
 

Hallo an alle Forenmitglieder,

ich bin neu hier und sitze gerade über der Installation von Magento. Ich möchte den Shop gerne lokal installieren um das Ganze mal zu testen. System: XP-SP2 und XAMPP. Bis zu der Fehlermeldung “PHP Extension “pdo_mysql” must be loaded” hab ich mich ganz gut durchkämpfen können - aber jetzt gehts leider nicht mehr weiter. Würde mich über Tipps freuen, da ich keine DB-Spezialistin bin.

Danke schonmal im voraus - Gruß Klaudia

 
Magento Community Magento Community
Magento Community
Magento Community
 
klaudia
Jr. Member
 
Total Posts:  5
Joined:  2008-06-08
 

so, habe eine relativ einfach Lösung für lokale Installation unter XP-SP2 gefunden:

xampp-win32-1.6.6a-installer installieren (installiert apache und mysql) mit php 4.x

php-5.2.6-Win32 downloaden und einfach in xampp/php/php4 entpacken (nix vorher löschen!!)
- alle Probleme mit fehlenden php-extensions sind weg!!!!

Sehe endlich den Admin-Backend - juchhu

Gruß Klaudia

 
Magento Community Magento Community
Magento Community
Magento Community
 
Helmuth
Jr. Member
 
Total Posts:  6
Joined:  2008-06-20
 

Hallo,

läuft mit dem xampp für Windows wirklich alles? Kann ich mir nicht vorstellen, es fehlen einige Dinge, die unter Win nicht möglich sind, z.B. cURL und mode_rewrite läuft unter Windows nicht wirklich.

xampp 1.6.6a kommt mit php 5.2.5 und PHP 4.4.8, lässt sich einfach umschalten, im xampp ordner mit “php_switch.bat”. Nach der Installation läuft schon PHP 5, irgend was nach installieren ist nicht nötig.

Wollte gerade mit dem Win-xampp Magento installieren, hatte sofort eine Fehlermeldung bei der Installation: cURL fehlt, erst installieren. xampp für Linux wird vermutlich perfekt funktionieren, kann ich aber erst heute abend mit Magento testen.

Gruss
Helmuth

 
Magento Community Magento Community
Magento Community
Magento Community
 
Rico_Neitzel
Moderator
 
Avatar
Total Posts:  857
Joined:  2007-09-05
Würzburg, Germany
 

Hallo Helmuth,

mod_rewrite funktioniert perfekt!!?

Und CURL: solange die Extension aktiviert ist, sollte das auch laufen!

Viele Grüße
Rico

 
Magento Community Magento Community
Magento Community
Magento Community
 
Helmuth
Jr. Member
 
Total Posts:  6
Joined:  2008-06-20
 

Hallo Rico,

hier hört die Installation mit xampp für Windows 1.6.6a auf:

PHP Extension “mcrypt” must be loaded
PHP Extension “curl” must be loaded

Das mit mod_rewrite und Windows habe ich vor längerer Zeit aufgegeben. Hat immer so getan als wenn es geht, hat aber nicht. Unter Linux kein Problem. Vielleicht funktioniert das jetzt auch, werde es mal wieder testen.

Gruss Helmuth

 
Magento Community Magento Community
Magento Community
Magento Community
 
Rico_Neitzel
Moderator
 
Avatar
Total Posts:  857
Joined:  2007-09-05
Würzburg, Germany
 

php.ini suchen, dort nach Zeile

# loadmodule=mcrypt.so
(oder so ähnlich) suchen und die # weg machen, gleiches für curl. dann php.ini speichern und sicherheitshalber xampp neustarten.

LG rico

 
Magento Community Magento Community
Magento Community
Magento Community
 
Helmuth
Jr. Member
 
Total Posts:  6
Joined:  2008-06-20
 

Hallo Rico,

die php_curl.dll und die php_mcrypt.dll sind tatsächlich “im Lieferumfang” von xampp. Der richtige Eintrag in der xampp\apache\bin\php.ini (die php.ini gibt es mehrmals, aber nur diese ist richtig):

extension=php_curl.dll
extension=php_mcrypt.dll

vor den Zeilen das “;” entfernen und xampp neu starten, das ist ein “Muss” und nicht nur sicherheitshalber.

Eigentlich wollte ich Magento unter Windows gar nicht testen, aber jetzt ist der Ehrgeiz geweckt.

Man schreibt sich wieder,

Gruss Helmuth

 
Magento Community Magento Community
Magento Community
Magento Community
 
Helmuth
Jr. Member
 
Total Posts:  6
Joined:  2008-06-20
 

Hallo,

ich kann bestätigen, dass Magento auf xampp 1.6.5 Beta mit W2K und Vista läuft.
Dazu:

curl und mcrypt In der php.ini wie vorher beschrieben aktivieren und in der xampp/apache/conf/httpd.conf die Raute am Anfang dieser Zeile wegmachen:
#LoadModule rewrite_module modules/mod_rewrite.so
und xampp neu starten

sonst nach Anleitung Magento installiert.

Gruss
Helmuth

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top