Posting in the Magento forums has been disabled pending the implementation of a new and improved forum solution which should better serve the community.

For new questions please post at magento.stackexchange.com, the community-run support site for the Magento community. We will be providing updates on the new forum solution soon. For questions or concerns please email community@magento.com.

Magento Forum

Page 1 of 2
Problems with ‘Mage_Eav_Exception’
 
Niklas Stephenson
Member
 
Total Posts:  62
Joined:  2007-08-31
Mejlgade 51A, Århus C
 

I have just installed magento on a MT grid server, i am getting this error: http://s23773.gridserver.com/ how do i fix this?

 
Magento Community Magento Community
Magento Community
Magento Community
 
idodstudios
Jr. Member
 
Total Posts:  3
Joined:  2007-08-31
 

I’m having the same problem.

 
Magento Community Magento Community
Magento Community
Magento Community
 
Skew
Member
 
Total Posts:  31
Joined:  2007-08-31
Phoenix
 

Same here.

 
Magento Community Magento Community
Magento Community
Magento Community
 
Coffee
Jr. Member
 
Total Posts:  4
Joined:  2007-09-01
 

Using MT Grid Server and having the same problem. My version of MySQL is 4.1.11. Magento lists MySQL 4.1.20 or newer as a requirement. Maybe this is causing the problems. System Requirements are here: http://www.magentocommerce.com/system-requirements

 
Magento Community Magento Community
Magento Community
Magento Community
 
Skew
Member
 
Total Posts:  31
Joined:  2007-08-31
Phoenix
 
Coffee - 01 September 2007 03:58 PM

Using MT Grid Server and having the same problem. My version of MySQL is 4.1.11. Magento lists MySQL 4.1.20 or newer as a requirement. Maybe this is causing the problems. System Requirements are here: http://www.magentocommerce.com/system-requirements

This seems to be the problem. I installed it on a VPS account and on a local Linux box… both worked fine, and the only difference between them and the MT GS account is that they’re using MySQL 4.1.2x

 
Magento Community Magento Community
Magento Community
Magento Community
 
Coffee
Jr. Member
 
Total Posts:  4
Joined:  2007-09-01
 

I submitted a support ticket with MT asking if MySQL can be upgraded to 4.1.20 on my GS. I’ll post their response once I get it. I hope they can. There are probably quite a few GS users who’d like to use Magento.

 
Magento Community Magento Community
Magento Community
Magento Community
 
H.Pylori
Jr. Member
 
Total Posts:  2
Joined:  2007-08-31
 

I am using MySQL version 5.0.45 and receiving the same error.

 
Magento Community Magento Community
Magento Community
Magento Community
 
Niklas Stephenson
Member
 
Total Posts:  62
Joined:  2007-08-31
Mejlgade 51A, Århus C
 

I got it to work by shifting host to servage.

 
Magento Community Magento Community
Magento Community
Magento Community
 
Coffee
Jr. Member
 
Total Posts:  4
Joined:  2007-09-01
 

“I got it to work by shifting host to servage.”

Not sure I understand what you mean… Did you upgrade your GS to a DV? Or did you get it to work on the GS?

 
Magento Community Magento Community
Magento Community
Magento Community
 
1legspider
Jr. Member
 
Total Posts:  8
Joined:  2007-08-31
 

Getting same Error messages as above with WAMP installed on a local server (XP).

Apache version :Apache/2.2.4 (Win32)

PHP version :5.2.1 Loaded extensions :
bcmath, calendar, com_dotnet, ctype, session, filter, ftp, hash, iconv, json, odbc, pcre, Reflection, date, libxml, standard, tokenizer, zlib, SimpleXML, dom, SPL, wddx, xml, xmlreader, xmlwriter, apache2handler, mbstring, curl, gd, gettext, mcrypt, mcrypt_filter, mhash, mysql, mysqli, openssl, PDO, pdo_sqlite, pdo_mysql, SQLite

MySQL version :5.0.27-community-nt

Had earlier installation problems and have followed these notes to get this far:

http://www.magentocommerce.com/wiki/Installing-on-Windows-with-XAMPP-and-WAMP/

Any help with this please?

 
Magento Community Magento Community
Magento Community
Magento Community
 
Niklas Stephenson
Member
 
Total Posts:  62
Joined:  2007-08-31
Mejlgade 51A, Århus C
 
Coffee - 02 September 2007 05:32 AM

“I got it to work by shifting host to servage.”

Not sure I understand what you mean… Did you upgrade your GS to a DV? Or did you get it to work on the GS?

I am using an other host, servage.net

 
Magento Community Magento Community
Magento Community
Magento Community
 
Coffee
Jr. Member
 
Total Posts:  4
Joined:  2007-09-01
 

Here’s the response from MT:

At this time there is not a set date to upgrade the (gs) to a newer version of mysql. I can’t say for certain that those errors are relevant to the version it is trying to use, but it is safe to say that if it requires 4.1.2 that it most likely will encounter problems when trying to run. Our (dv) service uses the the MySQL 4.1.2 that you are requesting. You can also upgrade it if you wish, because you will have root access and the ability to install what ever is compatible with your OS.
You can read about our (dv) here-
http://www.mediatemple.net/webhosting/dv/

We also provide a one click installation of ZenCart in the account center under One Click Applications.

No joy for MT GS.

 
Magento Community Magento Community
Magento Community
Magento Community
 
lotusseedsD
Mentor
 
Avatar
Total Posts:  1144
Joined:  2007-08-31
 

Hi Coffee, if you are not thinking to move away from mt, before considering to switch, perhaps try to find if one of your clients (if you are a web developer/designer) allows you to set up a database (have to be mysql 4.1.2) from his/her server - this is my temporarily workround for testing Magento. I am on gs too and right now is using a client’s database connecting to my mt’s site.

tgp

 
Magento Community Magento Community
Magento Community
Magento Community
 
sdsurf
Jr. Member
 
Total Posts:  6
Joined:  2007-09-08
 

Is this seriously what is causing this? The PHP version being a bit behind what is required by Magento? Bummer. I’m on an MT Grid Server as well… looks like Magento isn’t going to work for me - bummer. I was really hoping to be able to evaluate this ecommerce package as an option for a huge ecommerce site I’m working on. Hosting the DB on another server is not an acceptable solution for me. Too bad - looks to be a good ecomm system.

If anyone finds that the issue is something else, and that there is in fact a fix for this and Magento can be gotten to work on MT GS, please let me know!

Thanks,

Josh

 
Magento Community Magento Community
Magento Community
Magento Community
 
Scott
Guru
 
Avatar
Total Posts:  333
Joined:  2007-08-31
Northwest Ohio
 

Heh, I’m getting invalid foreign key. Same deal though. I though. I guess I can use an offsite server. Has anyone tried with a MySQL Container? Is it running a newer version of MySQL?

 
Magento Community Magento Community
Magento Community
Magento Community
 
sdsurf
Jr. Member
 
Total Posts:  6
Joined:  2007-09-08
 

Looks like the MySQL Container idea (while a good thought) is not gonna work either. Quote from their FAQ:

“What version of MySQL does the GridContainer come with?
All MySQL GridContainers include MySQL Server version 4.1.11.”

Bummer.

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top
Page 1 of 2