Magento Forum

Problème 1and1 serveur dédié clé en main
 
yougos
Jr. Member
 
Total Posts:  2
Joined:  2008-06-06
 

bonjour a tous

Nouveau venu dans le monde de magento, je rencontre quelques problèmes lors de l’installation. J’ai hâte de pouvoir tester la bête.

J’ai suivi toute les instructions pour permettre une bonne installation mais là je cale.

Voici les informations de ma configuration :

Hébergeur 1and1
php4
mysql4

Lors de l’installation je rencontre ce problème :

Error in file: “/www/htdocs/w009ed3a/www/app/code/core/Mage/Customer/sql/customer_setup/mysql4-install-0.8.0.php” - Wrong entity ID

J’ai bien modifié le .htaccess de manière a utiliser le cgi que j’ai au préalable transférer sur le serveur.

Comme je comprend le message il s’agit en fait d’une erreur de donnée.

Le problème vient certainement de là. Dans la procédure d’installation il est indiqué qu’il faut importer le “sample data” avant l’installation de magento sur le serveur.

Le problème c’est que cette importation de données ne fonctionne pas car je n’ai pas la bonne version de mysql. Actuellement j’ai la 4.

Il est possible de passer vers la version 5 mais pas sur un serveur dédié. Sur un hébergement mutualisé c’est possible. C’est à ne rien y comprendre chez 1and1.

Auriez vous une solution à ce problème ?

@bientôt tout le monde

yougos

 
Magento Community Magento Community
Magento Community
Magento Community
 
Otaugames
Sr. Member
 
Total Posts:  101
Joined:  2007-10-07
Troyes, France
 

Salut,

Sur la page ”System Requirements” tu verras qu’il est indiqué qu’il faut au moins PHP 5.2.0, et tu dis avoir PHP 4. Le problème vient peut-être de là ?

Concernant la mise à jour de PHP et MySQL sur ton dédié, c’est tout à fait possible mais c’est à toi de le faire. C’est justement l’avantage d’un dédié : tu en est totalement maitre et tu peux installer dessus les versions que tu veux librement.

 
Magento Community Magento Community
Magento Community
Magento Community
 
emy
Jr. Member
 
Avatar
Total Posts:  18
Joined:  2008-06-07
 

Bonjour,

J’ai eu le même problème avec un serveur 1&1;clé en main, apparemment il n’a y pas moyen.

Essaye d’appeler le service technique.

 
Magento Community Magento Community
Magento Community
Magento Community
 
JLHC
Mentor
 
Avatar
Total Posts:  1287
Joined:  2008-05-09
Tampa, FL
 

Your system which is PHP4 is not compatible with Magento Commerce.
You will need to upgrade it to PHP5 or move on to a host which has PHP5 and are fully compatible with Magento Commerce.

Votre système est PHP4 qui n’est pas compatible avec Magento commerce.
Vous devez mettre à jour pour PHP5 ou passer à un hôte qui a PHP5 et sont entièrement compatibles avec Magento commerce.

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top