Posting in the Magento forums has been disabled pending the implementation of a new and improved forum solution which should better serve the community.

For new questions please post at magento.stackexchange.com, the community-run support site for the Magento community. We will be providing updates on the new forum solution soon. For questions or concerns please email community@magento.com.

Magento Forum

Page 2 of 3
Warning: popen() has been disabled
 
cablegunmaster
Jr. Member
 
Total Posts:  7
Joined:  2009-09-09
 

I hope magento is going to use another function as popen cause. popen is disable by allot of hosts this causing the downloads/ extensions hard to download.

is there any other way to implement this function? like using another function as Popen();?
This is a hard bug for our company to be using magento on the current webhost. Cause the webhost doessnt allow it due to security issues.

Please Magento developers ,

There must be some other way to get the downloads / Extensions.

EDIT and Solved =)

Directadmin Solution:

I changed the php.ini on my Controlpanel my Hosting service says we dont do it for you. We dont allow it . Just telling me to shit my pants for using that function.  Luckily my Cpanel has absolute power over php.ini =) so I changed it ^^

Solution:
If youre using Directadmin go to -> Admin level -> File editor -> Php.ini
Search for the following line which contains the word “ disable_functions “ Delete Popen and Pclose from the line
Save the file!

After this do a reboot of the server.
on Directadmin this goes as following: -> instead of File editor now pick “ System monitor “ and fill in the password to reboot =)

Happy magento is happy ^^.

 
Magento Community Magento Community
Magento Community
Magento Community
 
rbl
Jr. Member
 
Total Posts:  1
Joined:  2008-05-25
 
tSpid3r - 13 August 2009 12:17 PM

This is just to confirm that copying the “php.ini” file in the “downloader” folder has solved my problem:
“popen() disabled...”

Same here! Thanks for the tip!

Ricardo

 
Magento Community Magento Community
Magento Community
Magento Community
 
PedroTeixeira
Sr. Member
 
Avatar
Total Posts:  136
Joined:  2008-05-28
Berlin, Germany
 

This is just to confirm that copying the “php.ini” file in the “downloader” folder has solved my problem:
“popen() disabled...”

Works for me too.

Thanks!

 
Magento Community Magento Community
Magento Community
Magento Community
 
ypeo
Jr. Member
 
Total Posts:  2
Joined:  2010-02-11
 

Hello, i don’t have php.ini on magento 1.4 version. I have php.ini.sample, i rename it into php.ini and php5.ini i copyed the file on downloader folder but the same error… Can someone post the content of the php.ini file? Thanks in advance.

 
Magento Community Magento Community
Magento Community
Magento Community
 
PedroTeixeira
Sr. Member
 
Avatar
Total Posts:  136
Joined:  2008-05-28
Berlin, Germany
 

ypeo,

This is my php.ini and this works for me.

This is not the Magento php.ini.

Good luck!

File Attachments
php.zip  (File Size: 14KB - Downloads: 418)
 
Magento Community Magento Community
Magento Community
Magento Community
 
ypeo
Jr. Member
 
Total Posts:  2
Joined:  2010-02-11
 

@ Pedro - thanks a lot bro. But still not working… I copied the php.ini from you into root of magento folder and in downloader folder… the same errors. The only diference is when i change from Settings to Custom (0777 permisions) the error is other: “Invalid package identifier provided: Warning: mkdir() [function.mkdir]: File exists in /home/ype/public_html/gold/downloader/pearlib/php/System.php on line 280”. If i’m not be able to resolve this @#$t till tomorrow i’m gonna go to other oscommerce platform… Magento is complex, beautiful… but not working for me. Thank’s again.

 
Magento Community Magento Community
Magento Community
Magento Community
 
PedroTeixeira
Sr. Member
 
Avatar
Total Posts:  136
Joined:  2008-05-28
Berlin, Germany
 

Ok Ypeo, good luck!

 
Magento Community Magento Community
Magento Community
Magento Community
 
ozzie
Jr. Member
 
Total Posts:  9
Joined:  2008-05-18
 

Thankyou Pedro.. I copied your php.ini file and saved it in my downloader file and finally I could download extensions! Kudos to you, Pedro

 
Magento Community Magento Community
Magento Community
Magento Community
 
WebhostUK LTD
Sr. Member
 
Avatar
Total Posts:  163
Joined:  2009-08-27
UK
 

Hello,

Yes the issue can main occur due to php.ini setting.

Just need to change it to get it working.

 
Magento Community Magento Community
Magento Community
Magento Community
 
Purece Nicolae Daniel
Jr. Member
 
Total Posts:  6
Joined:  2009-02-06
 

I’ve copied php.ini in Public_html / Downloader.
This works for me.

Thank you all!

 
Magento Community Magento Community
Magento Community
Magento Community
 
Infernos
Jr. Member
 
Total Posts:  4
Joined:  2010-05-04
 

I had the same problem of popen not being open. I got my host to open popen but it still wouldn’t work. I eventually put the php.ini file in each of the downloader sub folders. I don’t know which one fixed it, but it worked after.

 
Magento Community Magento Community
Magento Community
Magento Community
 
RSCreativeArts
Jr. Member
 
Total Posts:  3
Joined:  2010-05-10
 

Mate you are a champion, your php.ini in my downloader file worked perfectly for me too!

 
Magento Community Magento Community
Magento Community
Magento Community
 
albwibowo
Jr. Member
 
Total Posts:  1
Joined:  2010-05-09
 

Very hard using Magento ... always get error, always ask to hosting support for help. This Shop CMS good but for install and use to hard cause so many not allowed in hosting server. This only some input from me

 
Magento Community Magento Community
Magento Community
Magento Community
 
James.Xu
Jr. Member
 
Total Posts:  3
Joined:  2010-05-13
 

it still doesn’t work. I copy php.ini to downloader directory, it say 500 Error.... Anyone helps me?

 
Magento Community Magento Community
Magento Community
Magento Community
 
Magento_Ireland
Jr. Member
 
Avatar
Total Posts:  29
Joined:  2010-03-15
 

@James.Xu

Try uploading your php.ini file with only the popen code as below. There may be extra information in your php.ini causing the error?

popen=1
 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top
Page 2 of 3