Posting in the Magento forums has been disabled pending the implementation of a new and improved forum solution which should better serve the community.

For new questions please post at magento.stackexchange.com, the community-run support site for the Magento community. We will be providing updates on the new forum solution soon. For questions or concerns please email community@magento.com.

Magento Forum

Contact Form action sending user to a page that displays a table of store order (minus the order info)
 
thadknowsweb
Jr. Member
 
Total Posts:  4
Joined:  2009-12-15
 

I’ve got my Contact Form directing to http://drummersservice.com/contacts/index/post after submission, I believe this was working correctly before but now I am getting directed to a rather weird page (see attached screenshot). Has anyone else run into this? I am running Magento version 1.3.2.1

Thanks

Image Attachments
Screen shot 2010-03-09 at 2.30.52 PM.png
 
Magento Community Magento Community
Magento Community
Magento Community
 
Cubix WS
Guru
 
Avatar
Total Posts:  318
Joined:  2009-07-01
LondON, United Kingdom
 

The URL for post submission is correct. Seems like by mistake you have messed up the core file. Check the function postAction() in the file:

app/code/core/Mage/Contacts/controllers/IndexController.php

After all the processing, towards the end there should be:

$this->_redirect('*/*/');

Otherwise upload the IndexController.php over here and I will try and sort this out for you.

 
Magento Community Magento Community
Magento Community
Magento Community
 
thadknowsweb
Jr. Member
 
Total Posts:  4
Joined:  2009-12-15
 

Thanks for the response Cubix,

I checked my controller file and the line you mention seems to be correct. I’ve attached a copy of my file for you to look at.

Thanks again

Edit: I should also note that I tried to install the ‘Fontis Recaptcha’ module. It didn’t seem to be working so I disabled it. I’m wondering if the module overwrote something in my IndexController.php file.

File Attachments
IndexController.php  (File Size: 5KB - Downloads: 38)
 
Magento Community Magento Community
Magento Community
Magento Community
 
Cubix WS
Guru
 
Avatar
Total Posts:  318
Joined:  2009-07-01
LondON, United Kingdom
 

Yes your file seems perfect.. Uninstall the Recaptcha module and then try again..

 
Magento Community Magento Community
Magento Community
Magento Community
 
thadknowsweb
Jr. Member
 
Total Posts:  4
Joined:  2009-12-15
 

Thanks for all of your help Cubix. I have solved my problem.

The issue was that even though I had disabled and uninstalled the Recaptcha module, there were still remnants of it’s existence in my install. I removed all files related to the module and solved the problem. There was also another problem causing the form not to work. Turns out, the client or other employee working on the site had changed some settings in the admin.

Thanks again

 
Magento Community Magento Community
Magento Community
Magento Community
 
Cubix WS
Guru
 
Avatar
Total Posts:  318
Joined:  2009-07-01
LondON, United Kingdom
 

Great to see its solved! ... If you need any other help the community is always there smile

Cheers

- Harshit

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top