Posting in the Magento forums has been disabled pending the implementation of a new and improved forum solution which should better serve the community.

For new questions please post at magento.stackexchange.com, the community-run support site for the Magento community. We will be providing updates on the new forum solution soon. For questions or concerns please email community@magento.com.

Magento Forum

Need to Confirm’ (create account option) not working? 
 
lotusseedsD
Mentor
 
Avatar
Total Posts:  1144
Joined:  2007-08-31
 

I have the ‘Need to Confirm’ set to YES already and had refresh/disable caches many time, but the system still logged me in as soon as I created a new account.

Anybody got this working ?

Thanks!

 
Magento Community Magento Community
Magento Community
Magento Community
 
RichardX
Jr. Member
 
Total Posts:  17
Joined:  2008-06-02
 

I am having problems with this too - no matter what I set it on customers are automatically given an account.
Any one have any experience of this?

 
Magento Community Magento Community
Magento Community
Magento Community
 
lotusseedsD
Mentor
 
Avatar
Total Posts:  1144
Joined:  2007-08-31
 

yeah, it’s still not fixed in v1.1 beta.

I finally filed a bug report. Curious nobody ever reported this problem except me, and now you smile

 
Magento Community Magento Community
Magento Community
Magento Community
 
RichardX
Jr. Member
 
Total Posts:  17
Joined:  2008-06-02
 

That’s a shame - it’s the key thing our client needs to be able to do.
Hopefully it will get bumped up the fix list.

 
Magento Community Magento Community
Magento Community
Magento Community
 
Michael_1
Enthusiast
 
Total Posts:  826
Joined:  2007-08-31
 

This functionality is working in 1.1 Stable released on Thursday.

 
Magento Community Magento Community
Magento Community
Magento Community
 
bignm
Jr. Member
 
Avatar
Total Posts:  19
Joined:  2008-07-28
Texas
 

Hi guys,

I have just upgraded to v1.1.6 and the same problem seems to be happening (again?).

In “System > Configuration > Customers > Customer Configuration > Create New Account Options” dialog I have the “Require Emails Confirmation” set to yes at the “default” and “website” levels.

For some reason, I cannot get Magento to send a confirmation email when a customer creates a new account in the Frontend website pages.  It just automatically sends them into their account page with a green “Thank you for registering with English” prompt.

This is a major bug, as it doesn’t allow website owners to email verify their customers, allowing ANYBODY to register using ANY email address they want to…

Anybody got any ideas?  I am reporting this as a Magento bug.

Tom

 
Magento Community Magento Community
Magento Community
Magento Community
 
bignm
Jr. Member
 
Avatar
Total Posts:  19
Joined:  2008-07-28
Texas
 

Hi guys,

After several hours of debugging, I finally “found” the problem…

If a customer comes to your website, then clicks the “Log In” link, then the “Create an Account” button under the “New Customers” box, Magento will require validation if the customer checks the “Sign Up for Newsletter” checkbox.  However, if the same checkbox is not checked, then the new customer will NOT be required to validate their email address.

So there you go… further details on the “bug”.  Now I will try to find a fix for it.  However, I will let the crack Magento team fix it for everybody else so my hacking doesn’t mess up something else.

Tom

 
Magento Community Magento Community
Magento Community
Magento Community
 
ericscott
Member
 
Total Posts:  57
Joined:  2008-05-14
 

did anything come of this? to my knowledge, it’s still the same. i’m kind of frustrated.

 
Magento Community Magento Community
Magento Community
Magento Community
 
lisali
Enthusiast
 
Avatar
Total Posts:  889
Joined:  2008-04-28
London, UK
 

Has this been fixed now? The Newsletter issue remains - no need to confirm NEW email subscribers if the customer is logged in....

 
Magento Community Magento Community
Magento Community
Magento Community
 
quanza
Sr. Member
 
Avatar
Total Posts:  97
Joined:  2008-12-02
Tokyo, Japan
 

what’s more, the “Thank you for registering with English” is because the store name is “English”.  But if you also want language switching, it also uses the store name.  That’s a lame bug.

 
Magento Community Magento Community
Magento Community
Magento Community
 
quikprint
Jr. Member
 
Total Posts:  14
Joined:  2009-02-02
 

Has anyone a fix for when it says thank you for registering with English?  Is there a way to change the store name to something else? I had a poke about in the app/locale directory.. I found in “Mage_Customer.csv” the sentence “Thank you for registering with...” although even though I changed it its still not working.  It still says english!

Its really fustrating trying to find out how to fix stuff like this! really appreciate anyones help!  Thanks grin

 
Magento Community Magento Community
Magento Community
Magento Community
 
lisali
Enthusiast
 
Avatar
Total Posts:  889
Joined:  2008-04-28
London, UK
 

Hi,

Have you tried “translate inline”? Then refresh cache.
Good luck!

 
Magento Community Magento Community
Magento Community
Magento Community
 
quikprint
Jr. Member
 
Total Posts:  14
Joined:  2009-02-02
 

Worked a treat! thanks lisali!  Thats another little hidden magento gem that I didnt even know existed!

 
Magento Community Magento Community
Magento Community
Magento Community
 
weltenbuerger
Jr. Member
 
Total Posts:  17
Joined:  2008-12-05
 

... Hi im having the “Thank your for regestering with English” issue too ... where do i change the inline ? as mentioned above ?

thx

 
Magento Community Magento Community
Magento Community
Magento Community
 
lisali
Enthusiast
 
Avatar
Total Posts:  889
Joined:  2008-04-28
London, UK
 

Hi,

You need to turn inline translation ON in

Configuration>>Advanced>>Developer>>Translate Inline>>Enabled for Frontend

Turn it on, browse your FRONT-end, ie what the user sees, change what you want, go back to admin, turn it OFF then refresh cache. Done!

Please note that ANYONE will be able to edit everything while it’s on so you may want to protect your site either via .htaccess or the “offline maintenance” extension.

Good luck!

 
Magento Community Magento Community
Magento Community
Magento Community
 
sean US
Member
 
Total Posts:  58
Joined:  2008-10-01
 

I have a problem with the redirect. I am using 1.4.0.1. After the customer logs in, he gets redirected to the dashboard even though the setting in the back end says:
Redirect Customer to Account Dashboard after Logging in: “No”
how can i fix this situation, its very urgent.

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top