Magento Forum

   
Page 1 of 2
FIX: “ Url not accessible “ for DreamHost and others using custom php.ini
 
Siddharth Menon
Jr. Member
 
Avatar
Total Posts:  20
Joined:  2007-08-31
Mumbai
 

If you are not able to continue the installation and get stuck at “ Url not accessible “ then follow this simple guide it will help you out.

As from what I have learned this happens basically when url get function is turned off. We need to turn it back on using custom php.ini

PART A : For those who are hosting on wamp or any other simple hosting.

Locate your php.ini, for wamp got to “ c:\wamp\Apache2\bin “ for any other hosting check with your host.
Open your php.ini and search for “ allow_url_fopen “

Change

allow_url_fopen = off

to

allow_url_fopen = on

That’s it everything should be working

PART B : Exclusive for DreamHost hoster

1. We need to get our original php.ini files to do this we must have shell access.
2. Make a cgi-bin folder inside the root folder of your web.
3. Using shell access execute the following cmd to copy original php.ini file to new cgi-bin folder

cp /dh/cgi-system/php5.cgi /home/username /yourwebsite.com/cgi-bin/php.cgi
cp 
/etc/php5/cgi/php.ini /home/username /yourwebsite.com/cgi-bin/php.ini
4. Go to the new cgi-bin folder and download php.ini using ftp
5. Edit the new php.ini

Search for “ allow_url_fopen “

Change

allow_url_fopen = off

to

allow_url_fopen = on

6. Upload the new php.ini file
7. Also create a .htaccess file copy paste the following, then save it in root folder or the folder where magento* is located.

AddHandler php-cgi .php
Action php
-cgi /cgi-bin/php.cgi

Note: .htaccess & cgi-bin folder should both exist in same folder level does’t matter if both are inside magento’s folder. In that case the custom php.ini will only effect scripts that are executed below magento folder.

8. Now very imp change the chmod for all
.htaccess
cgi-bin
php.cgi
php.ini

to mim 755

9. To test it completely if everything is fine create a php file and upload it to root folder. Copy paste the following script.

Thanks A.Piotrowski

<?php
$url 
'http://localhost:80/magento/';
$checkRes file_get_contents($url);
echo 
$checkRes;
?>

Now when you open it it should open your magento installation if it does then everything is fine.

8. For those who don’t have https cert please keep the following parameter in secure host.
Port : 80
Protocol : http

Also DreamHost users please read this wiki, its the same thing what I have mentioned above CLICK HERE

 
Magento Community Magento Community
Magento Community
Magento Community
 
iblastoff
Sr. Member
 
Total Posts:  252
Joined:  2007-08-31
 

im running wamp and have allow_url_fopen already on (as i need it for several other php applications on my computer). magento still doesn’t work. ahh well hoping to test later versions.

 
Magento Community Magento Community
Magento Community
Magento Community
 
Siddharth Menon
Jr. Member
 
Avatar
Total Posts:  20
Joined:  2007-08-31
Mumbai
 

Are you getting the same error ? Url not accessable ?

 
Magento Community Magento Community
Magento Community
Magento Community
 
_
Sr. Member
 
Total Posts:  152
Joined:  2007-08-31
 

Great job Siddhart smile Put this into Wiki . This will help many users.

 
Magento Community Magento Community
Magento Community
Magento Community
 
pauljosephson
Member
 
Total Posts:  37
Joined:  2007-08-31
 

I too get the same url not accessible.  allow_url_fopen is already set to true so this is not the problem

 
Magento Community Magento Community
Magento Community
Magento Community
 
bobede
Jr. Member
 
Total Posts:  1
Joined:  2007-09-07
 

I get the same error when trying to continue from page 2 of the install. I checked phpinfo and allow_url_fopen is on. I’m testing with XAMPP on a Vista platform.

 
Magento Community Magento Community
Magento Community
Magento Community
 
kaydeezy
Jr. Member
 
Total Posts:  19
Joined:  2007-09-04
 

Great job! I have been looking for a fix for this for days now! Thank you sooo much!

 
Magento Community Magento Community
Magento Community
Magento Community
 
kaydeezy
Jr. Member
 
Total Posts:  19
Joined:  2007-09-04
 

Did this, still doesnt work.

 
Magento Community Magento Community
Magento Community
Magento Community
 
kaydeezy
Jr. Member
 
Total Posts:  19
Joined:  2007-09-04
 

<s>Now I am getting the 404 error on the install directory like so many others were getting after I followed these steps.</s>

Fixed this.

 
Magento Community Magento Community
Magento Community
Magento Community
 
sdsurf
Jr. Member
 
Total Posts:  6
Joined:  2007-09-08
 
kaydeezy - 07 September 2007 10:36 AM

Great job! I have been looking for a fix for this for days now! Thank you sooo much!

So… this is still not working for me. I’d like to think I’m pretty savvy at this sort of thing, having been a web developer for 10 years. That said… can’t get this working. I mean, the software looks great and all, but if it won’t install… not sure what to say.

Here’s my setup:

Grid Server (GS) account on Media Temple
allow_url_fopen is ON
allow_url_include is OFF
magic_quotes are ON (not sure if this is how it should be for Magento to work, but I have a hard time believing this is the root cause of the “:80” issue)
mod_rewrite is enabled, obviously
My system meets all the technical requirements listed on the Magento site as far as PHP options, MySQL version, etc.

contents of the .htaccess file at the root of my installation are as follows:

AddHandler php5-script .php
RewriteEngine on
RewriteCond $1 !^(index\.php|media|skin|js|robots\.txt)
RewriteRule ^(.*)$ /index.php/$1 [L]

I’m still getting the error message on page 2 of the install wizard:
“Url “http://shop.yourdomain.com:80/” is not accessible”, yet cut/paste of this url into the address bar redirects back to the base of the install wizard.

Any hints that anyone can provide would be greatly appreciated. I’m about out of patience with this thing and I’ll be moving on to another commerce solution if I can’t get this to work.

Thanks in advance,

Josh

 
Magento Community Magento Community
Magento Community
Magento Community
 
Jemact
Jr. Member
 
Avatar
Total Posts:  8
Joined:  2007-08-31
 

One question and sorry for my english

if i replace localhost for mgnt.es for example port 80 and secure http and continue i haven´t error Url not accessible and after i search the text mgnt in archives and BD for replace for localhost again and i don´t see.

Where keep magento this info?

Greetings

 
Magento Community Magento Community
Magento Community
Magento Community
 
Jemact
Jr. Member
 
Avatar
Total Posts:  8
Joined:  2007-08-31
 

Solution for error Url “http://localhost:80/” is not accessible
edit php.ini and change put

memory_limit = 20M

Greetings

 
Magento Community Magento Community
Magento Community
Magento Community
 
Richard F.
Jr. Member
 
Total Posts:  23
Joined:  2007-09-02
 

With Dreamhost (on a virtual Private Server), at step 3, I am getting this in Terminal (on Mac OS X): cp: /dh/cgi-system/php5.cgi: No such file or directory

Any idea why?

 
Magento Community Magento Community
Magento Community
Magento Community
 
srdk
Jr. Member
 
Total Posts:  4
Joined:  2007-08-31
 
sdsurf - 08 September 2007 09:07 AM


I’m still getting the error message on page 2 of the install wizard:
“Url “http://shop.yourdomain.com:80/” is not accessible”, yet cut/paste of this url into the address bar redirects back to the base of the install wizard.

Any hints that anyone can provide would be greatly appreciated. I’m about out of patience with this thing and I’ll be moving on to another commerce solution if I can’t get this to work.

Thanks in advance,

Josh

Same pb here.

with a little debug, i get:

exception ‘Zend_Http_Exception’ with message ‘Error parsing body - doesn’t seem to be a chunked message’ in /var/www/***/magento/lib/Zend/Http/Response.php:552 Stack trace: #0

It seem _checkUrl return a unchunked body with a chunked transfer-encoding header.

I use lighttpd 1.4.13

 
Magento Community Magento Community
Magento Community
Magento Community
 
Michael
Enthusiast
 
Total Posts:  826
Joined:  2007-08-31
 
srdk - 14 November 2007 06:58 AM

Same pb here.

with a little debug, i get:

exception ‘Zend_Http_Exception’ with message ‘Error parsing body - doesn’t seem to be a chunked message’ in /var/www/***/magento/lib/Zend/Http/Response.php:552 Stack trace: #0

It seem _checkUrl return a unchunked body with a chunked transfer-encoding header.

Hi srdk,

What URL did you get this error on - secure or unsecure ?
What do you see in browser when go to URLs http://your.domain/magento_path/install/wizard/checkHost , https://your.domain/magento_path/install/wizard/checkSecureHost and http://your.domain/magento_path/install/wizard/checkSecureHost?

 
Magento Community Magento Community
Magento Community
Magento Community
 
meeeearcus
Member
 
Total Posts:  57
Joined:  2008-07-01
 

wow. I’m having issues today, not only did I double post, I replied to the wrong topic.

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
    Back to top
Page 1 of 2