Posting in the Magento forums has been disabled pending the implementation of a new and improved forum solution which should better serve the community.

For new questions please post at magento.stackexchange.com, the community-run support site for the Magento community. We will be providing updates on the new forum solution soon. For questions or concerns please email community@magento.com.

Magento Forum

My Account points to wrong link (404 error) but 404 page has correct link? 
 
clownfishshack
Jr. Member
 
Total Posts:  1
Joined:  2014-03-15
 

Hi all,

I’m working on my new ecommerce site - http://www.myclownfishshack.com - and am having a hard time figuring out why the “My Account” link on the top of the page is giving me a 404 error “Whoops, our bad...”.

However what’s strange is the “My Account” link on the bottom of the 404 “Whoops, our bad...” page has the CORRECT link to “My Account” page.

Bad link: http://www.theclownfishshack.com/http:/index/www.theclownfishshack.com/customer/account/

Correct link: http://www.theclownfishshack.com/customer/account/

The bad link seems to be some sort of coding error. My developer has fallen off the face of the earth, and I’m stuck. Any/all help would be much appreciated.

Thanks!

 
Magento Community Magento Community
Magento Community
Magento Community
 
CommerceBees
Jr. Member
 
Avatar
Total Posts:  18
Joined:  2014-01-30
Schaumburg, IL
 

Hi clownfishshack,

From your root folder access /app/design/frontend/default/Your_theme_Name/layout to find the file named customer.xml in that search for the following content

<default>
        <!-- 
Mage_Customer -->
        <
reference name=\"top.links\">
            <
action method=\"addLink\" translate=\"label title\" module=\"customer\"><label>My Account</label><url helper=\"customer/getAccountUrl\"/><title>My Account</title><prepare/><urlParams/><position>10</position></action>
        </
reference>
    </default>

in the above content if the url helper is assigned to customer/getAccountUrl

<url helper=\"customer/getAccountUrl\"/>


you would get the correct link to My Account .

Hope This would help you

Thanks
CommerceBees

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top