Posting in the Magento forums has been disabled pending the implementation of a new and improved forum solution which should better serve the community.

For new questions please post at magento.stackexchange.com, the community-run support site for the Magento community. We will be providing updates on the new forum solution soon. For questions or concerns please email community@magento.com.

Magento Forum

reinstall magento
 
jorries
Member
 
Avatar
Total Posts:  56
Joined:  2007-10-07
 

My country list went empty
Would like to reinstall

How does it check if its reintalled? /install isent working anymore

thanks in advanche
this shopping system is a dream to come true

 
Magento Community Magento Community
Magento Community
Magento Community
 
Moshe
Magento Team
 
Avatar
Total Posts:  1770
Joined:  2007-08-07
Los Angeles
 

If you like your database to be reinstalled, drop all the tables in it. On next page reload it will be reinstalled.

If you want to go through install wizard again, delete app/etc/local.xml file and reload any magento page, it will be redirected to /install.
Going through install wizard will not reinstall the database files.

 
Magento Community Magento Community
Magento Community
Magento Community
 
jorries
Member
 
Avatar
Total Posts:  56
Joined:  2007-10-07
 

thanks, thats clear!

 
Magento Community Magento Community
Magento Community
Magento Community
 
redhotrobbie
Jr. Member
 
Total Posts:  27
Joined:  2008-10-27
 

app/etc/local.xml
Oh Etc is the name of the file not an abbreviation

 
Magento Community Magento Community
Magento Community
Magento Community
 
Adam BCN
Jr. Member
 
Total Posts:  2
Joined:  2009-02-27
 

If you get a ‘redirect loop’ error after deleting app/etc/local.xml, you will need to clear your cookies.

 
Magento Community Magento Community
Magento Community
Magento Community
 
Branko56
Jr. Member
 
Total Posts:  14
Joined:  2008-12-11
 

I had a similar issue with the site redirecting to install after it had been installed and running successfully for a while. Turns out the permissions had been set to 777 on the root magento directory which magento did not like.

Not sure why this was the case but changing the permissions back seemed to fix the issue.

 
Magento Community Magento Community
Magento Community
Magento Community
 
spamherelots
Jr. Member
 
Total Posts:  20
Joined:  2009-08-14
 

If you’ve dropped all DB tables and get an error report on reloading the admin page, it helps to delete all files under var/cache/mage--* - that worked for me. After that, all tables were re-created.

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top