Magento Forum

   
Bestehende Installation auf anderen Server - Warning: simplexml_load_string() [SOLVED]
 
Lenny2
Sr. Member
 
Total Posts:  171
Joined:  2008-05-21
München
 

So, nun ist es 0:37 und ich bin am Ende.

Ich habe eine funktionsfähige Magento-Installation unter XAMPP - alles Bestens.

Nun möchte ich diese Magento-Installation auf einen 1und1 Webserver kopieren. Also sämtliche Files per FTP auf den Server - Datenbank importiert und die local.xml unter app/etc mit den neuen sql zugangsparametern gefüllt. Jetzt noch die Verzeichnisrechte (CMOD 777 auf var, var/.htaccess, media und app/etc) und die .htaccess im root auf die 1und1 einstellungen sowie RewriteBase / gesetzt.

Wenn ich jetzt die installation aufrufe, bekomme ich folgende Fehlermeldung:
There has been an error processing your request.Warning: simplexml_load_string() [function.simplexml-load-string]: Entity: line 40: parser error : Opening and ending tag mismatch: password line 39 and dbname in /homepages/17/d215778145/htdocs/magento/lib/Varien/Simplexml/Config.php on line 494

Trace:
#0 /homepages/17/d215778145/htdocs/magento/app/code/core/Mage/Core/Model/Config.php(617): mageCoreErrorHandler(8, ‘Trying to get p...’, ‘/homepages/17/d...’, 617, Array)
#1 /homepages/17/d215778145/htdocs/magento/app/code/core/Mage/Core/Model/Config.php(678): Mage_Core_Model_Config->getGroupedClassName(’model’, ‘core/url’)
#2 /homepages/17/d215778145/htdocs/magento/app/code/core/Mage/Core/Model/Config.php(695): Mage_Core_Model_Config->getModelClassName(’core/url’)
#3 /homepages/17/d215778145/htdocs/magento/app/Mage.php(294): Mage_Core_Model_Config->getModelInstance(’core/url’, Array)
#4 /homepages/17/d215778145/htdocs/magento/app/Mage.php(225): Mage::getModel(’core/url’)
#5 /homepages/17/d215778145/htdocs/magento/app/Mage.php(445): Mage::getUrl(’install’)
#6 /homepages/17/d215778145/htdocs/magento/index.php(40): Mage::run()
#7 {main}

Gibt es irgendwelche Vorschläge? Muss mann vielleicht noch in anderen Files etwas ändern?
Habe leider keine Info gefunden, wie man bestehende Installationen übernimmt…

Danke für die Hilfe!

 
Magento Community Magento Community
Magento Community
Magento Community
 
Rico_Neitzel
Moderator
 
Avatar
Total Posts:  857
Joined:  2007-09-05
Würzburg, Germany
 

lol bei mir ist es 0:55 :D zeittunnel??? :D

also - du hast einen syntaxfehler in deiner xml-datei bei der zeile mit dem passwort… hast du vielleicht ein schließendes tag vergessen oder ein zeichen zu viel??? es ist auf jeden Fall ein Tippfehler: Entity: line 40:
schau mal zeile 40 an
irgendwas mit password in zeile 39

LG rico

 
Magento Community Magento Community
Magento Community
Magento Community
 
Lenny2
Sr. Member
 
Total Posts:  171
Joined:  2008-05-21
München
 

Hi Rico,
super - genau das war es .... ich sollte so spät doch nicht mehr an configs rumbasteln wink
Gibts bzgl. deutscher Übersetzung schon was Neues von Varien? Wäre schön, wenn wir hier bald die 100% erreichen könnten....
Gruß
Frank

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
    Back to top