Magento Forum

   
Problem opening installation wizard on Ubuntu Server 7.04 with Magento 0.6.12840
 
Anand
Jr. Member
 
Total Posts:  23
Joined:  2007-08-31
 

I have installed everything that is recommended in the system requirements.
When running the installation wizard in the browser I receive a “Page Not Found” error:
http://192.168.1.31/magento/install/

I also have mod_rewrite installed and loaded (using the command sudo a2enmod rewrite).
I have read and tried dozens of posts with solutions, but without success.

The most solutions say you have to edit your httpd.conf. I use Apache2, so I assume to edit apache2.conf (on Ubuntu in /etc/apache2/apache2.conf)
Then it’s said to add something like this:

<Directory /var/www/magento/>
        
Order Allow,Deny
        Allow from all
        Options Indexes FollowSymLinks
        AllowOverride All
    
</Directory>

I have added this to the end of my apache2.conf file.
Restarted apache, but still without success.
I hope someone can help me.

 
Magento Community Magento Community
Magento Community
Magento Community
 
smoked_cl
Jr. Member
 
Total Posts:  5
Joined:  2007-09-29
Chile
 

It would be stupid to think but ..

have you tried http://192.168.1.31/install/ ?

sorry in advance

 
Magento Community Magento Community
Magento Community
Magento Community
 
Anand
Jr. Member
 
Total Posts:  23
Joined:  2007-08-31
 

No, I haven’t tried it, because I have extracted Magento to a subdirectory, not in the root.
It’s in /var/www/magento/ not in /var/www/.

 
Magento Community Magento Community
Magento Community
Magento Community
 
Anand
Jr. Member
 
Total Posts:  23
Joined:  2007-08-31
 

It worked! I haven’t installed it yet, but the installation wizard works.
I found the solution in the Ubuntu Forum.

Go to /etc/apache2/sites-available and edit the file default.
Then change:

<Directory /var/www/>
                
Options Indexes FollowSymLinks MultiViews
                AllowOverride None
                Order allow
,deny
                allow from all
                
# This directive allows us to have apache2's default start page
                # in /apache2-default/, but still have / go to the right place
                # Commented out for Ubuntu
                #RedirectMatch ^/$ /apache2-default/
        
</Directory>

into this

<Directory /var/www/>
                
Options Indexes FollowSymLinks MultiViews
                AllowOverride All
                Order allow
,deny
                allow from all
                
# This directive allows us to have apache2's default start page
                # in /apache2-default/, but still have / go to the right place
                # Commented out for Ubuntu
                #RedirectMatch ^/$ /apache2-default/
        
</Directory>

The only change is from “AllowOverride None” into “AllowOverride All”.

Then restart Apache: sudo /etc/init.d/apache2 restart
Now open the installation wizard in your browser.

I now get the error message “PHP Extension “curl” must be loaded”. I’m going to search for this in the Magento forum.

 
Magento Community Magento Community
Magento Community
Magento Community
 
Anand
Jr. Member
 
Total Posts:  23
Joined:  2007-08-31
 

I solved the problem with error message“PHP Extension “curl” must be loaded” when I’m in the installation wizard.
Run the following command with Debian or Ubuntu Server:

sudo apt-get install php5-curl

 
Magento Community Magento Community
Magento Community
Magento Community
 
Anand
Jr. Member
 
Total Posts:  23
Joined:  2007-08-31
 

I successfully have installed Magento in a Virtual Machine with Ubuntu Server 7.04.
I’ve created a post in News and Announcements with a download link (torrent file).

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
    Back to top