Magento Forum

error during upgrate 1.5.1 to 1.8
 
bremy
Jr. Member
 
Total Posts:  5
Joined:  2013-09-22
 

Hello,
I try to upgrade my store. The old version is 1.4.0.1. I upgrade to 1.4.2 and 1.5.1, but I have an error when I upgrade to 1.8.1.
I upgrade with magento connect. It\’s OK. But when I go to the backoffice, i havec this message :

a:5:{i:0;s:267:\"Error in file: \"/var/www/magento/app/code/core/Mage/Customer/sql/customer_setup/mysql4-upgrade-1.5.9.9-1.6.0.0.php\" - SQLSTATE[42000]: Syntax error or access violation: 1075 Incorrect table definition; there can be only one auto column and it must be defined as a key\";i:1;s:916:\"#0 /var/www/magento/app/code/core/Mage/Core/Model/Resource/Setup.php(645): Mage::exception(\’Mage_Core\’, \’Error in file: ...\’)
#1 /var/www/magento/app/code/core/Mage/Core/Model/Resource/Setup.php(437): Mage_Core_Model_Resource_Setup->_modifyResourceDb(\’upgrade\’, \’1.4.0.0.14\’, \’1.6.2.0.3\’)
#2 /var/www/magento/app/code/core/Mage/Core/Model/Resource/Setup.php(320): Mage_Core_Model_Resource_Setup->_upgradeResourceDb(\’1.4.0.0.14\’, \’1.6.2.0.3\’)
#3 /var/www/magento/app/code/core/Mage/Core/Model/Resource/Setup.php(235): Mage_Core_Model_Resource_Setup->applyUpdates()
#4 /var/www/magento/app/code/core/Mage/Core/Model/App.php(417): Mage_Core_Model_Resource_Setup::applyAllUpdates()
#5 /var/www/magento/app/code/core/Mage/Core/Model/App.php(343): Mage_Core_Model_App->_initModules()
#6 /var/www/magento/app/Mage.php(684): Mage_Core_Model_App->run(Array)
#7 /var/www/magento/index.php(87): Mage::run(\’\’, \’store\’)
#8 {main}\”;s:3:\"url\”;s:24:\"/magento/index.php/admin\”;s:11:\"script_name\”;s:18:\"/magento/index.php\”;s:4:\"skin\”;s:7:\"default\";}

I really appreciate any help you can provide

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top