Posting in the Magento forums has been disabled pending the implementation of a new and improved forum solution which should better serve the community.

For new questions please post at magento.stackexchange.com, the community-run support site for the Magento community. We will be providing updates on the new forum solution soon. For questions or concerns please email community@magento.com.

Magento Forum

Page 1 of 2
Backend is fine. Frontend gives 404 for all pages except mainpage
 
Tillebeck
Jr. Member
 
Total Posts:  24
Joined:  2008-03-03
 

Hi. I have done a testinstall of the Magento ver. 1.0.19870
My backend works fine, i can add categories, products etc.

But the frontend fails. Only the landing pag eis fine, the rest returns 404 error messages.

Fine, and I can login:
http://opengate.dk/w_magento/magento/index.php/admin

Fine, but no cat/prod are showing and no matter which link I press I get an 404…
http://opengate.dk/w_magento/magento/

I did try the:
Mage::run(); to Mage::run(’default’);
as suggested in the forum. But for me that did not help.

I run the cgi-php5.
Any ideas?…

BR. Anders

 
Magento Community Magento Community
Magento Community
Magento Community
 
Eric Tan
Jr. Member
 
Total Posts:  2
Joined:  2008-05-25
 

have anyone found the solution?

Take a closer look at the frontend links - ‘index.php’ is missing!!!!

http://<your domain>/magento/wishlist/ is supposed to be http://<your domain>/magento/index.php/wishlist/

how to fix this?

 
Magento Community Magento Community
Magento Community
Magento Community
 
Crucial
Enthusiast
 
Avatar
Total Posts:  770
Joined:  2007-11-07
Phoenix, AZ
 

Do you have URL rewrites enabled in the backend of Magento? And what do you have for the unsecure/secure base store url/link values?

You can find all of this in System > Configuration > General > Web.

If you have mod_rewrite on your server, then set Use Web Server Rewrites to Yes. Otherwise leave it as No.

For the Unsecure section, make sure the values are:

Base URLhttp://opengate.dk/w_magento/magento/
Base Link URL{{unsecure_base_url}}
Base Skin URL
{{unsecure_base_url}}skin/
Base Media URL{{unsecure_base_url}}media/
Base JavaScript URL{{unsecure_base_url}}js/

And for the Secure section, for now just leave it the same as above:

Base URLhttp://opengate.dk/w_magento/magento/
Base Link URL{{secure_base_url}}
Base Skin URL
{{secure_base_url}}skin/
Base Media URL{{secure_base_url}}media/
Base JavaScript URL{{secure_base_url}}js/
 
Magento Community Magento Community
Magento Community
Magento Community
 
Eric Tan
Jr. Member
 
Total Posts:  2
Joined:  2008-05-25
 

Fixed after I changed Web Server Rewrites to No. The index.php reappears as part of the links.

How do you know that mod_rewrite is working properly. My infophp() page said so that it’s loaded.

Or did I not configure my .htaccess correctly? I tried to overwrite it with .htaccess.sample but doesn’t help at all.

Thanks!!!

 
Magento Community Magento Community
Magento Community
Magento Community
 
Tillebeck
Jr. Member
 
Total Posts:  24
Joined:  2008-03-03
 

Hmmm.... I gave up and deleted all to make a fresh start…

But now I get this during the isntallation.
Url “http://opengate.dk/w_magento/magento/” is not accessible

Gone from bad to worse. I will try to sort it out and then make an installation without mod_rewrite active.

 
Magento Community Magento Community
Magento Community
Magento Community
 
Tillebeck
Jr. Member
 
Total Posts:  24
Joined:  2008-03-03
 

SOLUTION
Well, not a solution, but a fix of some sort anyway.

The magento-1.0.19870.1.tar.gz returns the error with “url is not accessible”
The magento-1.0.19870.tar.gz seems to work fine

 
Magento Community Magento Community
Magento Community
Magento Community
 
Tillebeck
Jr. Member
 
Total Posts:  24
Joined:  2008-03-03
 

Crucial -> Thanks for your tips. I tried to change the deafult urls but ended up breaking the installation. Since I could not find a file or DB entry to modify I ended up doing a reinstall… again…

---------------------------
I did a complete reinstall using the magento-1.0.19870.tar.gz.
I am online again but with a new issue this time.

Backend is fine as usual.

As something new all links works fine in the frontend exept:
http://opengate.dk/w_magento/magento (this is fine)
http://opengate.dk/w_magento/magento/ (this is fine)
http://opengate.dk/w_magento/magento/index.php (this is fine)

But this in the autogenerated link from the “Magento Demo Store” gif the link is with a trailing slash:
http://opengate.dk/w_magento/magento/index.php/ (this results in “No input file specified")

How do I chagnge the default url to one of the three working links listed above?`

BR. Anders

 
Magento Community Magento Community
Magento Community
Magento Community
 
Crucial
Enthusiast
 
Avatar
Total Posts:  770
Joined:  2007-11-07
Phoenix, AZ
 

Well for future reference, those variables are stored in the core_config_data table. Just sort the table by path and go the last page. You’ll see the following:

web/secure/base_url
web
/unsecure/base_url

You can also turn off URL rewrites and SSL in there (0=false; 1=true):

web/seo/use_rewrites 
web
/secure/use_in_adminhtml
web
/secure/use_in_frontend
 
Magento Community Magento Community
Magento Community
Magento Community
 
TheHuntingDynasty
Jr. Member
 
Total Posts:  25
Joined:  2008-06-27
 

Crucial - you rock.

I’ve been tearing my hair out with this install. Your Web Server Rewrites to ‘no’ fixed saved me!

Ta

 
Magento Community Magento Community
Magento Community
Magento Community
 
nirva
Jr. Member
 
Total Posts:  1
Joined:  2008-04-08
 

Same here… Web Server Rewrites to ‘no’ and category links are back on track.

Thanks for the tip

 
Magento Community Magento Community
Magento Community
Magento Community
 
AndresSKL
Jr. Member
 
Avatar
Total Posts:  15
Joined:  2008-02-15
Mar del Plata, Argentina
 

Hi!
i’ve got this problem (v1.1.3), where link http://www.maczentrum.com.ar/store/index.php/ (with the final slash) does NOT work and throws the “No input file specified.” error or directly a 404.

I’ve tried configuring in the backend with Web Server Rewrites turned on and off:
- If NO, the magento logo goes to the index.php/ and gives that mentioned error;
- if YES, the logo goes to /store/ and home page is visible, BUT NOT the links to the products…

Frankly, I don’t know what to do. I’ve read about the .htaccess, but i don’t know how to configure it… also, i think that it’s not in the server (invisible files on).

Any help is much appreciated!

 
Magento Community Magento Community
Magento Community
Magento Community
 
AndresSKL
Jr. Member
 
Avatar
Total Posts:  15
Joined:  2008-02-15
Mar del Plata, Argentina
 
Crucial - 26 May 2008 09:07 AM

Well for future reference, those variables are stored in the core_config_data table. Just sort the table by path and go the last page. You’ll see the following:

web/secure/base_url
web
/unsecure/base_url

You can also turn off URL rewrites and SSL in there (0=false; 1=true):

web/seo/use_rewrites 
web
/secure/use_in_adminhtml
web
/secure/use_in_frontend

Hi! I’m sorry, but i dont understand WHERE do you change or HOW do you change this to make it work… I’ve found that table in phpMyAdmin, but i’m afraid i’m not able to modify it… or how to modify it. (im n00b with this, please understand wink )

Thanks!

 
Magento Community Magento Community
Magento Community
Magento Community
 
lika
Jr. Member
 
Total Posts:  5
Joined:  2009-01-15
 
Andrés Skliarevsky - 22 August 2008 06:19 AM


Hi! I’m sorry, but i dont understand WHERE do you change or HOW do you change this to make it work… I’ve found that table in phpMyAdmin, but i’m afraid i’m not able to modify it… or how to modify it. (im n00b with this, please understand wink )

Thanks!

Click on the ‘pencil’ icon, and you can edit.

 
Magento Community Magento Community
Magento Community
Magento Community
 
Michal
Jr. Member
 
Avatar
Total Posts:  10
Joined:  2007-11-20
 

Hi everybody, I have similar issue, the only help for me was turning off the cache totaly (not refresh) and voila! Everything got back to normal.

Just remember to set up cache back to on, after successful Magento state, the URL rewrite was not the faulty one in this case for me.

Michal

 
Magento Community Magento Community
Magento Community
Magento Community
 
ryan777
Jr. Member
 
Total Posts:  30
Joined:  2011-02-21
 

Also make sure that if you move your site, your .htaccess file goes with it if you are using URL Rewrites. I just battled with these same problems for over an hour, only just realizing that for whatever reason the .htaccess from the old location didn’t make it into the zip file when moving it!

 
Magento Community Magento Community
Magento Community
Magento Community
 
fm2t
Jr. Member
 
Total Posts:  1
Joined:  2012-01-18
 

Crucial,
You’re awesome!
That is all.

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top
Page 1 of 2