Posting in the Magento forums has been disabled pending the implementation of a new and improved forum solution which should better serve the community.

For new questions please post at magento.stackexchange.com, the community-run support site for the Magento community. We will be providing updates on the new forum solution soon. For questions or concerns please email community@magento.com.

Magento Forum

Page 1 of 2
Illegal scheme supplied, only alphanumeric characters are permitted
 
ShannonCole
Jr. Member
 
Total Posts:  5
Joined:  2008-05-23
 

I’m trying to install magento and getting the following error when trying to input the database information.

Illegal scheme supplied, only alphanumeric characters are permitted

My host is 1and1 which the database host, username, database name, and password are automatically generated.  The information provided by 1and1 does not include any special or weird characters.. just letters, numbers, and periods)

Anyone have an idea on what’s wrong?

~Shannon

 
Magento Community Magento Community
Magento Community
Magento Community
 
Aliblei
Jr. Member
 
Total Posts:  3
Joined:  2008-05-06
 

may you tell me how you fix the BASE URL Problem, if you had.

i put in:
http://myURL.de/magento
he shows me an invalid URL

now with:
homepages/28/d1XX31XXXX/magento

he shows me the same problem, Illegal Scheme etc....

Password: you can fix it in 1&1;control center. on MySQL Database Settings.  on 1und1.com

greetz

 
Magento Community Magento Community
Magento Community
Magento Community
 
ShannonCole
Jr. Member
 
Total Posts:  5
Joined:  2008-05-23
 

I don’t know if I fixed it yet because I can’t get passed this page. smile

If I take out the http:// from the url it seems to work.

~Shannon

 
Magento Community Magento Community
Magento Community
Magento Community
 
Aliblei
Jr. Member
 
Total Posts:  3
Joined:  2008-05-06
 

tryed.
but nothing works.
still same error.

i dont know why he shows me this error:
“Illegal scheme supplied, only alphanumeric characters are permitted”

host:  dbXXXX.1und1.de
dbname:  dbXXXXXXXX
username:  dboXXXXXXXXX
PW:  XXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXX

Table Prefix: magento

X Stands for numbers.

Base URL:  homepages/28/d1XX31XXXX/magento (doesn’t work)
mydomain.de/magento/ (doesn’t work)
http://www.mydomain.de/magento/ (doesn’t work)
http://mydomain.de/magento/ (doesn’t work)
http://www.mydomain.de/magento/ (doesn’t work)
I use more than one domain in one package.
But mydomain1/domain2root/magento (doesn’t work)

SSL off, mod_rewrite off.

everytime the same error.
can somebody help me?

using this .htaccess:

AddType x-mapp-php5 .php
AddHandler x-mapp-php5 .php

DirectoryIndex index.php

RewriteEngine on
RewriteBase /
RewriteCond %{REQUEST_URI} !^/media/
RewriteCond %{REQUEST_URI} !^/skin/
RewriteCond %{REQUEST_URI} !^/js/
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteCond %{REQUEST_FILENAME} !-l
RewriteRule .* index.php

 
Magento Community Magento Community
Magento Community
Magento Community
 
ShannonCole
Jr. Member
 
Total Posts:  5
Joined:  2008-05-23
 

I finally got Magento installed… There must be something wrong with the newest version because I was able to do a google search for magento-1.0.zip and install this version without a hitch.

~Shannon

 
Magento Community Magento Community
Magento Community
Magento Community
 
Josue4ever
Sr. Member
 
Avatar
Total Posts:  138
Joined:  2007-10-03
Mexico DF
 

Do you know what are the “new” files in this version? I think only reemplacing files can do an installation and the can use the downloader. Thanks

 
Magento Community Magento Community
Magento Community
Magento Community
 
Aliblei
Jr. Member
 
Total Posts:  3
Joined:  2008-05-06
 

i’ll try 1.0, hope it works after that.
but what the error stands for?
no field is marked for this error?

is it a problem with the dots in DB host or is it an general error
for: “It doesn’t work on your server”

i would try out the CGI installation but, i dont have root access to cgi_bin.
This is one of the requirements.

can u help me.

 
Magento Community Magento Community
Magento Community
Magento Community
 
tekt
Jr. Member
 
Total Posts:  23
Joined:  2008-05-26
 

I’m experiencing the same problem with the error “Illegal scheme supplied, only alphanumeric characters are permitted”

 
Magento Community Magento Community
Magento Community
Magento Community
 
MreSailor
Jr. Member
 
Total Posts:  1
Joined:  2008-05-30
 

I’ve got a client that ‘REAAALLY’ wants us to evaluate this over OSC but it’s already been a nightmare with the dependencies and now this bug.  You really should test this stuff before you post it, both LAMP and WAMP.

 
Magento Community Magento Community
Magento Community
Magento Community
 
stewartc
Jr. Member
 
Avatar
Total Posts:  23
Joined:  2008-01-09
Durham,.uk / Hamburg, .de
 

If you opened up the Magento archive locally and then ftp’d up to your server, make sure you also copied the .htaccess file in your site root as well as these are often hidden by windows explorer or your FTP client.

Been a long time since I used a windoze computer but I’m sure there’s a way to show all files in windows explorer,

A trick I used once before was to call my local file dot_htaccess.txt so it was visible then once I’d uploaded it with my ftp software I right clicked on the remote version and renamed it .htaccess.

 
Magento Community Magento Community
Magento Community
Magento Community
 
LordFoobar
Jr. Member
 
Avatar
Total Posts:  3
Joined:  2012-04-06
 

Has this been addressed already? Really, with a brand new fresh install of Magento 1.6.2, getting this error on the very first page access (right after it says “You’re All Set!") is really annoying and unprofessional.

I have also encountered other “issues” during the install process (notably choosing the default locale) which does not give this project much credits, in my opinion.

Can someone actually give an explanation about how to resolve this issue, or anything?

** Edit **

Why is this code

$uri Zend_Uri::factory($secureBaseUrl);
sending
$secureBaseUrl '{{base_url}}'
?

** Update **

I cleared the folder /session and the error went away (this should definitely be checked!). Although, now I try to login using Chrome and it says that I have to enable Cookies? Well, they are enabled, what now?

** Update 2 **

Well, I have been testing the 1.6.2 on localhost and, apparantly, Cookies don’t work so well unless I setup a virtual local host (which I did not bother to do). So, I just went and edited Mage_Core_Model_Session_Abstract_Varien and changed line 104 like so :

if ($cookieParams['domain'!== 'localhost'{
   call_user_func_array
('session_set_cookie_params'$cookieParams);
}

It may not be pretty, but it works. If all this can be of any use to anyone....

 
Magento Community Magento Community
Magento Community
Magento Community
 
Jewelryee
Jr. Member
 
Total Posts:  2
Joined:  2012-04-18
 

in this view, magento very unprofessionally, for all new installation people, they need it simply and not so many bugs

 
Magento Community Magento Community
Magento Community
Magento Community
 
Jewelryee
Jr. Member
 
Total Posts:  2
Joined:  2012-04-18
 

Seems Magento do not support Xampp latest version.

 
Magento Community Magento Community
Magento Community
Magento Community
 
tacito_viero
Jr. Member
 
Total Posts:  2
Joined:  2012-04-18
 

Got this one too, after installing an extension via MConnect 2.0

<i>Illegal scheme supplied, only alphanumeric characters are permitted</i>

http://www.magentocommerce.com/magento-connect/enhanced-admin-product-grid.html

I’ve already validated this extension since it’s working in another magento install.

I don’t know how it’s happening after the extension installation (all the pages print the same stacktrace):

<i>Zend_Uri::factory(’{{base_url}}’)<i/>

I’ll try the solution above.

 
Magento Community Magento Community
Magento Community
Magento Community
 
joeymad
Jr. Member
 
Total Posts:  10
Joined:  2011-06-24
 

Apparently this was a bug in 1.6.1 and 1.6.2, didn’t get fixed until 1.7

If you are still on 1.6.1 or 1.6.2 and you’re getting Zend_Uri::factory(’{{base_url}}’), here is a fix:

http://www.danneh.org/2011/11/bug-magento-1-6-1-0-affecting-development-sites-base_url/

If there is a problem loading that page (seems their webserver is having issues… maybe DNS issues, not sure) copy the url, put it into a google search, and view the cached version of the page. OR, try to download the fix file using this link.

Text from website:

Put the tarball in the Magento webroot and extract. After you install this extension, you’ll need to empty the cache manually (if it was enabled). I assume if you’re reading this, then your Magento installation is broken. To do this, simply remove the contents of var/cache in Magento’s webroot.
When you re-visit your Magento’s front or backend, the problem should vanish.
BTS_1610Fix.tar.gz (md5: 8316468f4e179cf2f512edaaf62a12db)
Updated 9th January 2012: It apparent that, attempting to login before applying this update with {{base_url}} set screws up the admin login cookies somehow. When you apply this patch, you’ll probably need to empty out your chosen browser’s cookie jar before attempting to login. You can tell if you need to or not by trying to login, and Magento coming back to you with a login screen, with no failed login message.
Updated 12th January 2012: Magento 1.6.2.0 was released today. I can confirm that this problem still exists and has not yet been fixed (despite what the developers have written on one of the bug reports).
Updated 25th April 2012: I can confirm that this problem has been resolved in the latest 1.7.0.0 version, released 24th April 2012.

Read more at http://www.danneh.org/2011/11/bug-magento-1-6-1-0-affecting-development-sites-base_url/#ixzz1tAUtpDdA

 
Magento Community Magento Community
Magento Community
Magento Community
 
tacito_viero
Jr. Member
 
Total Posts:  2
Joined:  2012-04-18
 

Thank you @joeymad, it actually solved the {{base_url}} problem!

Although my local installation isn’t working yet (The infamous MySql 2002 socket error) smile

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top
Page 1 of 2