Magento Forum

   
Path must be writable….I know but I did that and I still get this message!? 
 
scottmb23
Jr. Member
 
Total Posts:  5
Joined:  2007-10-01
Vancouver, BC, Canada
 

Hey All,

First off, apologies if this has come up before, I did try to search for an answer before posting what might be a simple problem.  I followed the Installation instructions to the letter only to find out my server didn’t have the right PHP version, my hosting company installed the ‘fastcgi version of php 5.2’ on my site and I was able to access the install.  Only, even after modifiying all the right folders with ‘Write’ permission in Cute FTP I cannot get past this error:

Path “/home/hsphere/local/home/scottmb23/styleheist.com/magento/media/catalog/category/a/p/apparel_landing.jpg” must be writable

Any suggestions fellow Open Sourcers?

Also, I am in Canada, why can’t I chose this as a locale during setup??? Eh? wink

 
Magento Community Magento Community
Magento Community
Magento Community
 
Moshe
Magento Team
 
Avatar
Total Posts:  1770
Joined:  2007-08-07
Los Angeles
 

if you can shell access do:

chmod 777 -/home/hsphere/local/home/scottmb23/styleheist.com/magento/media/
If not try to find Recursive option in your FTP client for changing the permissions..

 
Magento Community Magento Community
Magento Community
Magento Community
 
scottmb23
Jr. Member
 
Total Posts:  5
Joined:  2007-10-01
Vancouver, BC, Canada
 

Um...Shell access, not sure? My hosting company does have a control panel for my domain which I am trying to find more info on....And you lost me at Recursive..lol..

 
Magento Community Magento Community
Magento Community
Magento Community
 
scottmb23
Jr. Member
 
Total Posts:  5
Joined:  2007-10-01
Vancouver, BC, Canada
 

After browsing my Hosting control panel I was able to find shell access buried in the depths and after some time of modifying I believe I have changed all permissions only to be faced with a new error:

PHP Extension “pdo_mysql” must be loaded

 
Magento Community Magento Community
Magento Community
Magento Community
 
Lone
Jr. Member
 
Avatar
Total Posts:  8
Joined:  2007-10-04
Toowoomba, Australia
 

As per the System Requirements

PHP 5.2.0 or newer, with the following extensions/addons:

* PDO/MySQL
* MySQLi
* mcrypt
* mhash
* simplexml
* DOM

Best way to check all of these is to make a new file called info.php and enter the following code into it:

<? phpinfo(); ?>

This will output your current PHP server setup, then just do a search for the terms above within the setup details, if they don’t exist then you will need to ask your host provider to install them for you - most of them are usually installed with PHP 5

Also regarding the permissions setting problem for future times you can set the permission in SmartFTP by right-clicking the directory that needs to be set and goto ‘Properties / CHMOD’ then type ‘777’ into the permissions box and then tick the ‘Apply changes to this folder, subfolders and files.’

 
Magento Community Magento Community
Magento Community
Magento Community
 
Brian Depew
Jr. Member
 
Total Posts:  8
Joined:  2008-02-15
 

I need help, I am getting a similiar error, but I cant change it, here is the install error “Path “/var/www/vhosts/suppliessaver.com/httpdocs/var/session/sess_j6dfllhtl4ghqj74ddirqojtv5” must be writable” I have changed the VAR folder to 777 but I cant change the the file it is wanting me to change.....the error i get is “550 sess_j6dfllhtl4ghqj74ddirqojtv5: Operation not permitted”
i have tried shell too and get same issue.

what do i do?

thanks

Brian

 
Magento Community Magento Community
Magento Community
Magento Community
 
a.doum
Jr. Member
 
Total Posts:  1
Joined:  2007-10-11
 

Hi,

Turn the safe mode off and it will be ok.
Yesterday i made my first magento installation, i had the same message, it was because safe mode was on…

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
    Back to top