Posting in the Magento forums has been disabled pending the implementation of a new and improved forum solution which should better serve the community.

For new questions please post at magento.stackexchange.com, the community-run support site for the Magento community. We will be providing updates on the new forum solution soon. For questions or concerns please email community@magento.com.

Magento Forum

Page 1 of 2
Contact Page Not Working - “Unable to submit your request. Please, try again later”
 
sterg17
Sr. Member
 
Total Posts:  94
Joined:  2009-11-06
 

Im using Magento 1.4 and I cannot submit my contact form.  I created the site on a subdomain and then moved it to my regular domain. 

The contact form didnt work on either, and gave me the same message:

“Unable to submit your request. Please, try again later”

1. Anyone know why ? Its not my mail servers as I am getting order emails.

2. Anyone know what else I can do to investigate this?? Where the error is coming from?

 
Magento Community Magento Community
Magento Community
Magento Community
 
beos2008
Jr. Member
 
Total Posts:  1
Joined:  2009-07-12
 

Same problem here. Magento 1.4.0.1 using blank theme.

Have google and found two way to fix this problem, but both fail for me.

1. Make sure you have <input type="text" name="hideit" id="hideit" value="” style="display:none !important;” /> in your form.phtml
*** A fresh 1.4.0.1 install will alway have this already

2. comment out

if (Zend_Validate::is(trim($post[’hideit’]), ‘NotEmpty’)) {
$error = true;
}

inside app/code/core/Mage/contacts/controllers/indexController.php
*** Have done this , but same problem.

Anyway to fix this?

 
Magento Community Magento Community
Magento Community
Magento Community
 
DCAlmeida
Sr. Member
 
Avatar
Total Posts:  164
Joined:  2008-12-28
PRT
 

Be sure that you edit right form.phtml!
And yes, the first solution works.

Put <input type="text" name="hideit" id="hideit" value="” style="display:none !important;” /> inside your form tags. Is simples and it works, I have to made this to all of my Magento´s.

 
Magento Community Magento Community
Magento Community
Magento Community
 
Justin Atack
Member
 
Avatar
Total Posts:  42
Joined:  2009-01-03
Sydney, Australia
 

I can confirm the first fix mention is what fixed my contact page problem.

Even though I use 1.4.0.1 the problem was my theme was overriding the form.phtml file with its own version, which didn’t have the new line in it.

If you are using a theme written for an older version of magento then please check there first.

app/design/frontend/default/YOURTEMPLATE/template/contacts/form.phtml

I hope this helps someone else

 
Magento Community Magento Community
Magento Community
Magento Community
 
brightsun
Member
 
Total Posts:  35
Joined:  2008-09-08
 

Yes this worked for me too.

Here is where I added the line exactly inside the file: app/design/frontend/default/YOURTHEME/template/contacts/form.phtml

<div class="buttons-set">
        <
class="required"><?php echo Mage::helper('contacts')->__('* Required Fields'?></p>
        <
input type="text" name="hideit" id="hideit" value="" style="display:none !important;" />
        <
button type="submit" title="<?php echo Mage::helper('contacts')->__('Submit') ?>" class="button"><span><span><?php echo Mage::helper('contacts')->__('Submit'?></span></span></button>
    </
div>

Thanks to everyone. smile

 
Magento Community Magento Community
Magento Community
Magento Community
 
brightsun
Member
 
Total Posts:  35
Joined:  2008-09-08
 

delete duplicate

 
Magento Community Magento Community
Magento Community
Magento Community
 
xaviersir
Jr. Member
 
Total Posts:  2
Joined:  2009-07-08
 

Thanks guys. The solution works!

 
Magento Community Magento Community
Magento Community
Magento Community
 
jg314
Jr. Member
 
Total Posts:  17
Joined:  2010-05-04
 

Thank you.  This fixed the problem in no time.

 
Magento Community Magento Community
Magento Community
Magento Community
 
hm894
Jr. Member
 
Total Posts:  17
Joined:  2009-06-19
 

Ah, finally a fix that works!  Thank you for posting this!

 
Magento Community Magento Community
Magento Community
Magento Community
 
MageOxy
Jr. Member
 
Avatar
Total Posts:  26
Joined:  2010-02-28
 

I changed that code in 1.3.4 and working fine, I did not check recently but today I noticed its not working at all! not sure how many inquiries I have lost!

 
Magento Community Magento Community
Magento Community
Magento Community
 
hjj2010
Jr. Member
 
Total Posts:  4
Joined:  2010-01-04
 

Yes,i done it, and after test send email it show \\\"Your inquiry was submitted and will be responded to as soon as possible. Thank you for contacting us.\\\”
but i can\\\’t get this inqure email, what is the problem????????????????????

 
Magento Community Magento Community
Magento Community
Magento Community
 
lokeshmagento
Jr. Member
 
Total Posts:  2
Joined:  2010-10-31
India
 

dont worry i will tell its solution in few days...........take care LOL

 
Magento Community Magento Community
Magento Community
Magento Community
 
Senator
Member
 
Avatar
Total Posts:  37
Joined:  2008-12-16
 

Not to be a buzzkill, but like the original poster I haven’t had success with these fixes.  My contact templates already have the line in them, and I still get the same error.

Is anybody else in the same boat?  Having my contact-us page disabled is killing me.

 
Magento Community Magento Community
Magento Community
Magento Community
 
dotprkirk
Member
 
Total Posts:  50
Joined:  2008-04-22
 

^^ same thing, running 1.4.1.1 - the proper files exist, the right code is in place, still I get nothing. Been searching for hours for a fix.

 
Magento Community Magento Community
Magento Community
Magento Community
 
nlee
Jr. Member
 
Avatar
Total Posts:  14
Joined:  2009-01-28
France
 

Same here ! Using Mag 1.4.1 with the Classic theme by Templates Master and the ASchroder SMTP Pro Email. It was working fine until I installed SMTP Pro Email.

So, I’ve tried what all of you guys said. The only form.phtml I have is in the app/design/frontend/base/default/template/contacts folder, and it already contains this line.

So I really don’t know what to do.... I can still remove SMTP Pro Email but I need it for my transactions emails not to arrive in the spam section of my customers’ inbox

Too bad :/

EDIT : I’ve tried desinstalling SMTP Pro Email and now it works (disabling it is not enough) - so in my case, it really is a problem with SMTP Pro Email - or my theme, or both

 
Magento Community Magento Community
Magento Community
Magento Community
 
dvreeke
Jr. Member
 
Total Posts:  6
Joined:  2009-07-15
 

Found the solution to this problem.

- First try to correct the \’hideit\’ code in the form.phtml and IndexController.php files (see previous posts).
- Adjust the backoffice settings to use the right template and settings (see previous posts).
- Try to upload all the default email templates as mentioned in previous posts.

Still not working? Don\’t worry, it is probably your Template.php file in code/core/magento/core/model/email/template.php

Update this file (or the one in your local-dir) and everything probably works fine!

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top
Page 1 of 2