Posting in the Magento forums has been disabled pending the implementation of a new and improved forum solution which should better serve the community.

For new questions please post at magento.stackexchange.com, the community-run support site for the Magento community. We will be providing updates on the new forum solution soon. For questions or concerns please email community@magento.com.

Magento Forum

No Links and No Pages other than the Home Page Work
 
avintel
Sr. Member
 
Total Posts:  147
Joined:  2008-05-15
Southern California
 

I am soooo unbelievably lost.  Nothing works except the admin side of my cart.  i have equipment and categories installed. but nothing seems to work.  please help.

website is:

http://www.avintel.com/audiovideo

 
Magento Community Magento Community
Magento Community
Magento Community
 
Yoke Lee
Sr. Member
 
Avatar
Total Posts:  80
Joined:  2008-05-08
China - Singapore
 

I’m sorry , can you just post the screenshot here? your url took so long to open.
and please specify your problem so everyone here get a brighter picture.

Thanks.

 
Magento Community Magento Community
Magento Community
Magento Community
 
pankajk
Member
 
Avatar
Total Posts:  38
Joined:  2008-04-15
Mumbai -101, Maharastra, India
 
avintel - 19 May 2008 04:38 PM

I am soooo unbelievably lost.  Nothing works except the admin side of my cart.  i have equipment and categories installed. but nothing seems to work.  please help.

website is:

http://www.avintel.com/audiovideo

hi have you created categories for your store and it is important to give parent category to “Default Category” and put items in that category it will show you navigation bar on top click on that particular category and you will see your product on next page.
try this hope it will work.

 
Magento Community Magento Community
Magento Community
Magento Community
 
Yoke Lee
Sr. Member
 
Avatar
Total Posts:  80
Joined:  2008-05-08
China - Singapore
 

I thought it’s Root Category?

 
Magento Community Magento Community
Magento Community
Magento Community
 
sbsmatters
Jr. Member
 
Total Posts:  7
Joined:  2008-06-13
 

Can we resolve this issue once and for all, please?

I am having the same problem.  I have created categories in both the root and in the Default Category.

I have put one item in each category.

Still I do not have a Navigation bar in the header!

Please can someone post the correct steps that I would need to follow to allow the menu to show?

Many thanks

 
Magento Community Magento Community
Magento Community
Magento Community
 
sbsmatters
Jr. Member
 
Total Posts:  7
Joined:  2008-06-13
 

OK, panic over!!!

After a whole day of trying various different categories in both the root and default categories, I decided that something else must be afoot.

So, I checked in the database and found that in table “catalog_category_entity_varchar” there were two entries for the root category (Root Catalog and root-catalog)

For the default category there was only one entry.

So I deleted the Default Category and recreated, and hey-presto two entries appeared - Default Category and default-category

Now everything works fine.  Not sure how that happened but…

So, after more testing I think I can safely say that in order to get the navigation menu to appear you need to put your categories in the Default Category and NOT in the Root Category.

Hope this helps

 
Magento Community Magento Community
Magento Community
Magento Community
 
Yoke Lee
Sr. Member
 
Avatar
Total Posts:  80
Joined:  2008-05-08
China - Singapore
 

The root category should never be removed you know. it should always stay as the first category.

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top