Posting in the Magento forums has been disabled pending the implementation of a new and improved forum solution which should better serve the community.

For new questions please post at magento.stackexchange.com, the community-run support site for the Magento community. We will be providing updates on the new forum solution soon. For questions or concerns please email community@magento.com.

Magento Forum

After update to 1.8.0.1 the backend, frontend and the shopping cart wont working
 
Lulabaer
Jr. Member
 
Total Posts:  7
Joined:  2013-03-21
 

Hello everybody,
I´ve done the latest update to 1.8.1.0.I´ve upgraded from 1.7.0.1 to 1.8.1.0. Now i´ve got big problems with my webshop.

Because i´ve done the update in the live shop and noticed the errors after 3 weeks i can´t do a rollback to 1.7.0.1.

I´ve got now following issues:

1. The backend login wont work. if i log in with the correct username and password, the page only reload and i´ve become no error message or something like that.

2. Frontend Customer login and shopping cart wont work. Same as backend login. The page shows no error messages or something like that.

3. The picture view at the product page doesnt work. i cant zoom in or out and cant change the picture.

The first two problems i solve as i change some lines code in

app\\\\\\\\code\\\\\\\\core\\\\\\\\Mage\\\\\\\\Core\\\\\\\\Model\\\\\\\\Session\\\\\\\\Abstract\\\\\\\\varien.php

The code i change you finde near line 78

$this->getCookie()->getDomain(),
$this->getCookie()->isSecure(),
$this->getCookie()->getHttponly()

I commented it out.

With that i deaktivated cookies and the frontend and the backend login works again. But i dont know if that changes go along with other issues.

Now only the pictures on the product pages doesnt work.. I think that javascript and jquery wont work any longer, because the jquery slider on the home page ist broken too.

The shop is running now, but with the deaktivated cookies and without the article pictures.

We think it is a problem in the database. A clear installation of magento 1.8.1 work with our template files. The current database with a magento 1.7.1 installation wont work and bring the same errors as the 1.8.1. The Cookie issues are in both versions with our database. I think the error was creating with the update to 1.8.1 and is in the database?

Please help me
Thank you very much

 
Magento Community Magento Community
Magento Community
Magento Community
 
Lulabaer
Jr. Member
 
Total Posts:  7
Joined:  2013-03-21
 

Thank you for your Answer.

I set on all Files the Permission “755” but without any effects or solutions. The jquery issue is stay there.

 
Magento Community Magento Community
Magento Community
Magento Community
 
Lulabaer
Jr. Member
 
Total Posts:  7
Joined:  2013-03-21
 

Where are included the jQuery Libaries?

In the head.phtml only

<?php
/**
* Magento
*
* NOTICE OF LICENSE
*
* This source file is subject to the Academic Free License (AFL 3.0)
* that is bundled with this package in the file LICENSE_AFL.txt.
* It is also available through the world-wide-web at this URL:
* http://opensource.org/licenses/afl-3.0.php
* If you did not receive a copy of the license and are unable to
* obtain it through the world-wide-web, please send an email
* to license@magentocommerce.com so we can send you a copy immediately.
*
* DISCLAIMER
*
* Do not edit or add to this file if you wish to upgrade Magento to newer
* versions in the future. If you wish to customize Magento for your
* needs please refer to http://www.magentocommerce.com for more information.
*
* @category design
* @package base_default
* @copyright Copyright (c) 2013 Magento Inc. (http://www.magentocommerce.com)
* @license http://opensource.org/licenses/afl-3.0.php Academic Free License (AFL 3.0)
*/
?>
<meta http-equiv="Content-Type" content="<?php echo $this->getContentType() ?>” />
<title><?php echo $this->getTitle() ?></title>
<meta name="description" content="<?php echo htmlspecialchars($this->getDescription()) ?>” />
<meta name="keywords" content="<?php echo htmlspecialchars($this->getKeywords()) ?>” />
<meta name="robots" content="<?php echo htmlspecialchars($this->getRobots()) ?>” />
<link rel="icon" href="<?php echo $this->getFaviconFile(); ?>” type="image/x-icon" />
<link rel="shortcut icon” href="<?php echo $this->getFaviconFile(); ?>” type="image/x-icon" />
<!--[if lt IE 7]>
<script type="text/javascript">
//<![CDATA[
var BLANK_URL = ‘<?php echo $this->helper('core/js')->getJsUrl('blank.html') ?>’;
var BLANK_IMG = ‘<?php echo $this->helper('core/js')->getJsUrl('spacer.gif') ?>’;
//]]>
</script>
<![endif]-->
<?php echo $this->getCssJsHtml() ?>
<?php echo $this->getChildHtml() ?>
<?php echo $this->helper('core/js')->getTranslatorScript() ?>
<?php echo $this->getIncludes() ?>

I don´t see any jQuery Tags. Maybe another Idea?

 
Magento Community Magento Community
Magento Community
Magento Community
 
drivebywebsites
Jr. Member
 
Total Posts:  2
Joined:  2012-09-05
 

I have found the “upgrade process” via Magento Connect has caused a number of problems - I believe caused by failure to copy over files correctly.

Look at this thread - http://www.magentocommerce.com/boards/viewthread/764812/

I might suggest a similar solution to backup & copy over the core 1.8.1 files from a full 1.8.1 download.

 
Magento Community Magento Community
Magento Community
Magento Community
 
Krish_TechnoLab
Jr. Member
 
Total Posts:  29
Joined:  2014-02-03
India
 

1. The backend login wont work. if i log in with the correct username and password, the page only reload and i´ve become no error message or something like that.

Cookie Problem

2. Frontend Customer login and shopping cart wont work. Same as backend login. The page shows no error messages or something like that.

Form key issue change the domain of cookie

Krish TechnoLabs
http://www.krishtechnolabs.com/

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top