Posting in the Magento forums has been disabled pending the implementation of a new and improved forum solution which should better serve the community.

For new questions please post at magento.stackexchange.com, the community-run support site for the Magento community. We will be providing updates on the new forum solution soon. For questions or concerns please email community@magento.com.

Magento Forum

Skip Import Row is happening again
 
AnnaM
Guru
 
Avatar
Total Posts:  325
Joined:  2008-01-29
San Francisco
 

Since upgrading to latest version, I have changed nothing else, even csv’s that used to import, now do not.

# Starting Mage_Dataflow_Model_Convert_Adapter_Io :: load
# Loaded successfully: “/var/www/domains/epicurecookware/htdocs/var/export/ImportTriPlySS_ScePans_051808-2.csv”
# Starting Mage_Dataflow_Model_Convert_Parser_Csv :: parse
# Found 4 rows
# Starting catalog/convert_adapter_product :: parse
# Skip import row, required field “store” not defined
# Skip import row, required field “store” not defined
# Skip import row, required field “store” not defined
# Skip import row, required field “store” not defined

“store” has not changed, its still
default
I have the same profiles that worked before, and have chosen the website in the droppdown view rather than the top level Default for “Store”, just like alwasy. 

Return of problem.  I don’t know why. Is anybody else having this problem since the ugrade, or have I gone brain dead. Its the same profiles, csvs etc.

f\irst couple lines from SS, saved as csv UTF8.  I inserted the hyphens here so stuff would line up properly

store--------attribute_set--------type----------sku---------category_ids
default-------Default-----------Simple-----AS11106------------30

Any ideas?  Thanks.

 
Magento Community Magento Community
Magento Community
Magento Community
 
ryanr
Jr. Member
 
Total Posts:  14
Joined:  2008-01-03
 

If you are using Excel, try saving it as an “Excel XML 2003” and also make the change that on the import profile.  See if that might solve your problem.

 
Magento Community Magento Community
Magento Community
Magento Community
 
AnnaM
Guru
 
Avatar
Total Posts:  325
Joined:  2008-01-29
San Francisco
 

Thx for the reply I use open office, what I found that seemed to fix it is not having the descriptins or anything take up the depth of more than one row. Even if its one cell still, if it expacds downwards due to linefeeds, magetno import seems to see it as a new row.  I only had 4 proudcts I was importing in the above, and it was flagging many rows.  I removed the descs completely and the problem went away.  Its like this, below, though its one row, mage sees it as several rows

--------------------------------------
Sku | Desc | Weight
| this is a |
| really cool |
| set of |
|saucepans |
2 | | 3.5
--------------------------------------

see attachements instead.

In Open Office even widedening the cell so it all fit in one row didn’t help, it still kept that depth there of empty space, and magento sees it as several rows.  They are not merged cells, its just one cell but somehow got filled up vertically like that and import counted each line of it as a row apparently.

EDIT well I see the post did not line up anything so the message may not make sense.
I attach a screen print so you can see what I mean. Though its clearly just 6 rows as you see on the far left, magento was counting it as like 14 rows or some such.  The other pic shows WHY it has that deth, becasue I wasnted line feeds in the descripitons.

Image Attachments
ss.jpgss2.jpg
 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top