Posting in the Magento forums has been disabled pending the implementation of a new and improved forum solution which should better serve the community.

For new questions please post at magento.stackexchange.com, the community-run support site for the Magento community. We will be providing updates on the new forum solution soon. For questions or concerns please email community@magento.com.

Magento Forum

Page 1 of 3
Checkout just blank page…
 
onyxrev
Jr. Member
 
Total Posts:  14
Joined:  2008-05-17
 

Hello!  I installed Magento on a subdirectory on my server and have been customizing it slowly but surely.  I haven’t touched the checkout page or configured it and, oddly, it comes up as a blank page.  All the other redirect/url rewrites seem to work fine but checkout just stalls after hitting ‘checkout’.

It bombs trying to load up ‘/checkout/onepage/’

Check it… out:

http://www.danconnor.com/bborgan/

Hit checkout up top and see what I mean.

What could be going on?

Thanks!
Dan

 
Magento Community Magento Community
Magento Community
Magento Community
 
Moshe
Magento Team
 
Avatar
Total Posts:  1770
Joined:  2007-08-07
Los Angeles
 

Does it work ok with default theme?

 
Magento Community Magento Community
Magento Community
Magento Community
 
Tiger Japanese
Jr. Member
 
Total Posts:  1
Joined:  2008-04-26
 

You have to to the backend of the site and configure from system configuration

 
Magento Community Magento Community
Magento Community
Magento Community
 
Crucial
Enthusiast
 
Avatar
Total Posts:  770
Joined:  2007-11-07
Phoenix, AZ
 

Have you checked the error log for Apache? There should be some clues in there as to what’s going on.

 
Magento Community Magento Community
Magento Community
Magento Community
 
onyxrev
Jr. Member
 
Total Posts:  14
Joined:  2008-05-17
 

With the default theme I do successfully load up the checkout page but all the options are grayed out, as if a javascript isn’t running correctly - but that’s probably a different problem altogether.

I guess somewhere along the way I must have changed something in a layout file that made the checkout page not display.

 
Magento Community Magento Community
Magento Community
Magento Community
 
onyxrev
Jr. Member
 
Total Posts:  14
Joined:  2008-05-17
 

Weird…

I replaced checkout.xml in the custom layout with checkout.xml from the default theme, which fixes the blank page issue I originally posted about.

But changing the cart_sidebar area to the left instead of the right:

<reference name="right">
<block type="checkout/cart_sidebar" name="cart_sidebar" before="-" template="checkout/cart/sidebar.phtml"/>
</reference>

to

<reference name="left">
<block type="checkout/cart_sidebar" name="cart_sidebar" before="-" template="checkout/cart/sidebar.phtml"/>
</reference>

caused the blank checkout issue to return.  That’s the only change made.

 
Magento Community Magento Community
Magento Community
Magento Community
 
onyxrev
Jr. Member
 
Total Posts:  14
Joined:  2008-05-17
 

I had made a non-customized backup of the install directory and I reverted it, then reapplied my custom layout.  It’s all working now.  Don’t know what the issue was but thanks for your help!

 
Magento Community Magento Community
Magento Community
Magento Community
 
onyxrev
Jr. Member
 
Total Posts:  14
Joined:  2008-05-17
 

I figured it out.  When the cache is off I get the blank page issue.  It works when it’s on.  Something to look into for the dev team?

 
Magento Community Magento Community
Magento Community
Magento Community
 
Moshe
Magento Team
 
Avatar
Total Posts:  1770
Joined:  2007-08-07
Los Angeles
 

When cache is on, Magento uses less memory during PHP script run.

What is your memory_limit?

 
Magento Community Magento Community
Magento Community
Magento Community
 
onyxrev
Jr. Member
 
Total Posts:  14
Joined:  2008-05-17
 

Appears to be 32MB

Hosting is through HostMonster, who allows the use of php.ini customizations.

 
Magento Community Magento Community
Magento Community
Magento Community
 
wmike
Jr. Member
 
Total Posts:  29
Joined:  2008-06-03
 

Thanks guys for solving my problem as well.

Since I read some advice to disable cash while working on design, so all my cash was disabled.
Then, when I got to the point of testing one-page checkout I lost 2 days trying to find out why it doesn’t work.
Here is what I was getting:

My checkout stops right after I click “Proceed to Checkout”. Then, the new screen shows up with 3 bars: 1.Checkout Method; 2.Billing Information; 3.Shipping Information. No other options are displayed.
At this point I can’t go any further as the 1.Checkout Method bar is displayed as active or “down” and cursor is changing when moved over it but click or double-click make no difference...it won’t go.
I double and triple checked, and even enabled all payment methods but still it will not work.
There is no difference if logged in or guest.

I can still go back to the shopping cart and repeat the process but it will not work.

When “Checkout with Multiple Addresses” is used, then it works perfectly fine.
only when “Proceed to Checkout” button is used then the problem described in previous post occurs.

Now, after reading this post, I just enabled cash and everything works great.

I think, the cash issue should be mentioned in user manual so other people will not get into the same problem.

Great product!

 
Magento Community Magento Community
Magento Community
Magento Community
 
schmelzgeist
Sr. Member
 
Total Posts:  92
Joined:  2008-05-27
Marzipane World Capital (Lübeck, Germany)
 
onyxrev - 20 May 2008 09:57 AM

Weird…

I replaced checkout.xml in the custom layout with checkout.xml from the default theme, which fixes the blank page issue I originally posted about.

But changing the cart_sidebar area to the left instead of the right:

<reference name="right">
<block type="checkout/cart_sidebar" name="cart_sidebar" before="-" template="checkout/cart/sidebar.phtml"/>
</reference>

to

<reference name="left">
<block type="checkout/cart_sidebar" name="cart_sidebar" before="-" template="checkout/cart/sidebar.phtml"/>
</reference>

caused the blank checkout issue to return.  That’s the only change made.

Same problem here, going to “http://localhost/magento/yb24/checkout/onepage/” it turns blank. 

changing the mini cart, that is about the only change i made too, i’m a little confused ...

this is my page.xml since i need a two column layout i defined it here:

<default>
        <
block type="page/html" name="root" output="toHtml" template="page/2columns-left-start.phtml"> ...

my checkout.xml was left alone :

<checkout_cart_index>
        <
remove name="right"/>
        <
remove name="left"/>
        <!-- 
Mage_Checkout -->
        <
reference name="root">
            <
action method="setTemplate"><template>page/1column.phtml</template></action>
        </
reference>
        <
reference name="content">
            <
block type="checkout/cart" name="checkout.cart">
                <
action method="setCartTemplate"><value>checkout/cart.phtml</value></action>
                <
action method="setEmptyTemplate"><value>checkout/cart/noItems.phtml</value></action>
                <
action method="chooseTemplate"/>

                <
block type="core/text_list" name="checkout.cart.top_methods" as="top_methods">
                    <
block type="checkout/onepage_link" name="checkout.cart.methods.onepage" template="checkout/onepage/link.phtml"/>
                </
block>

                <
block type="core/text_list" name="checkout.cart.methods" as="methods">
                    <
block type="checkout/onepage_link" name="checkout.cart.methods.onepage" template="checkout/onepage/link.phtml"/>
                    <
block type="checkout/multishipping_link" name="checkout.cart.methods.multishipping" template="checkout/multishipping/link.phtml"/>
                </
block>

                <
block type="checkout/cart_coupon" name="checkout.cart.coupon" as="coupon" template="checkout/cart/coupon.phtml"/>
                <
block type="checkout/cart_shipping" name="checkout.cart.shipping" as="shipping" template="checkout/cart/shipping.phtml"/>
                <
block type="checkout/cart_crosssell" name="checkout.cart.crosssell" as="crosssell" template="checkout/cart/crosssell.phtml"/>
            </
block>
        </
reference>
    </
checkout_cart_index>

any idea?

oh,yes i enabled cache after i read this.  but no didn’t work :(

 
Magento Community Magento Community
Magento Community
Magento Community
 
schmelzgeist
Sr. Member
 
Total Posts:  92
Joined:  2008-05-27
Marzipane World Capital (Lübeck, Germany)
 

also i think 64 MB RAM per Script seems to be sufficient , but the problem still stays

 
Magento Community Magento Community
Magento Community
Magento Community
 
schmelzgeist
Sr. Member
 
Total Posts:  92
Joined:  2008-05-27
Marzipane World Capital (Lübeck, Germany)
 

help,anyone?  *nudge*

 
Magento Community Magento Community
Magento Community
Magento Community
 
schmelzgeist
Sr. Member
 
Total Posts:  92
Joined:  2008-05-27
Marzipane World Capital (Lübeck, Germany)
 

SOLVED. i repeated all the steps posted by onyxrev.

i still wonder why that happens, though..

 
Magento Community Magento Community
Magento Community
Magento Community
 
stereotomy
Jr. Member
 
Total Posts:  28
Joined:  2008-02-10
 

having the same issue here. it happened after upgrading to 1.1. I too use my custom theme. seems to be a problem with jscript.

stuck here (again).

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top
Page 1 of 3