Posting in the Magento forums has been disabled pending the implementation of a new and improved forum solution which should better serve the community.

For new questions please post at magento.stackexchange.com, the community-run support site for the Magento community. We will be providing updates on the new forum solution soon. For questions or concerns please email community@magento.com.

Magento Forum

Page 1 of 4
Authorize.net Response Error
 
Danebrood
Jr. Member
 
Total Posts:  8
Joined:  2007-08-31
 

Hey, I’m testing out Authorize.net on checkout. When I click the ‘Place Order’ button I get this error response:

{"error":true,"success":false,"error_messages":["Unable to read response, or response is empty"]}

I’ve tried it with testing on and off, guest account and logged-in account.

I’m guessing a number of things could be causing this. Does anyone have any guidance on how I can go about troubleshooting this or display some additional info on what’s going on?

thanks!

 
Magento Community Magento Community
Magento Community
Magento Community
 
Brady
Guru
 
Avatar
Total Posts:  330
Joined:  2007-09-10
Orange County, CA
 

I’m getting a similar error as well…

/checkout/onepage/saveOrder/

Response:

<pre>

<
b>Notice:</strong> <i>Undefined variableorder</iin <strong>/homepages/2/d212266666/htdocs/store

/app/code/core/Mage/Checkout/Model/Type/Onepage.php</strongon line <b>324</b><br>[0] in <strong>Mage_Checkout_Model_Type_Onepage-

>
saveOrder</b>() in <b>/homepages/2/d212266666/htdocs/store/app/code/core/Mage/Checkout/controllers/OnepageController

.php</bon line <b>185</b><br>[1] in <strong>Mage_Checkout_OnepageController->saveOrderAction</b>()

 
in <b>/homepages/2/d212266666/htdocs/store/app/code/core/Mage/Core/Controller/Varien/Action.php</b>

 
on line <b>278</b><br>[2] in <strong>Mage_Core_Controller_Varien_Action->dispatch</b>("saveOrder"in

 
<b>/homepages/2/d212266666/htdocs/store/app/code/core/Mage/Core/Controller/Varien/Router/Standard.php

</bon line <b>138</b><br>[3] in <strong>Mage_Core_Controller_Varien_Router_Standard->match</b>(Zend_Controller_Request_Http

in <b>/homepages/2/d212266666/htdocs/store/app/code/core/Mage/Core/Controller/Varien/Front.php</b>

 
on line <b>139</b><br>[4] in <strong>Mage_Core_Controller_Varien_Front->dispatch</b>() in <b>/homepages

/2/d212266666/htdocs/store/app/Mage.php</bon line <b>356</b><br>[5] in <strong>Mage::run</b>("base"

in <b>/homepages/2/d212266666/htdocs/store/index.php</bon line <b>27</b><br>

</
pre><br />

<
b>Fatal error</b>:  Call to a member function getErrors() on a non-object in <b>/homepages/2/d212266666

/htdocs/store/app/code/core/Mage/Checkout/Model/Type/Onepage.php</bon line <b>324</b><br />
 
Magento Community Magento Community
Magento Community
Magento Community
 
Moshe
Magento Team
 
Avatar
Total Posts:  1770
Joined:  2007-08-07
Los Angeles
 

@Danebrood: sounds like no response from authorize.net ...
Do you have any records in `paygate_authorizenet_debug` table? If yes, check the last records for error description in response.

@Brady: in Mage_Checkout_Model_Type_Onepage could you replace:

$res['error_messages'$order->getErrors();
with
if (isset($order)) {
  $res[
'error_messages'$order->getErrors();
}
And paste here the exception you get after that.
Thanks.
 
Magento Community Magento Community
Magento Community
Magento Community
 
Brady
Guru
 
Avatar
Total Posts:  330
Joined:  2007-09-10
Orange County, CA
 

Actually, the system works fine w/ that change in it.  I was logged in a a previous customer.  Payment method was Credit Card (not Authorize.net).

When I use it in Authnet Test Mode, I get the following error:

{"error":true,"success":false,"error_messages":["(TESTMODE) The merchant login ID or password is invalid or the account is inactive."]}

I’ll check to see if it’s something on my end.

 
Magento Community Magento Community
Magento Community
Magento Community
 
Danebrood
Jr. Member
 
Total Posts:  8
Joined:  2007-08-31
 

Figured out my problem. The config table ‘core_config_data’ has the authnet URI:

'payment/authorizenet/cgi_url'

set to:

'https://secure.authorize.net:433/gateway/transact.dll'

I changed the port to 443, and it works perfectly now.

 
Magento Community Magento Community
Magento Community
Magento Community
 
Moshe
Magento Team
 
Avatar
Total Posts:  1770
Joined:  2007-08-07
Los Angeles
 

Ouch… thanks for finding this smile

 
Magento Community Magento Community
Magento Community
Magento Community
 
Brady
Guru
 
Avatar
Total Posts:  330
Joined:  2007-09-10
Orange County, CA
 

Works fine for me as well.  I’m using a TEST AuthNet account and had to change the Transaction POST URL to https://test.authorize.net/gateway/transact.dll through the database.

 
Magento Community Magento Community
Magento Community
Magento Community
 
Danebrood
Jr. Member
 
Total Posts:  8
Joined:  2007-08-31
 

Hey Brady,

I’m able to perform test transactions using the standard ‘secure.authorize.net’ URL. The ‘test.authorize.net’ URL, is this a developers test account that Authnet offers?

I’d love to have an authnet account that isn’t tied to a bank, but just for testing code.

 
Magento Community Magento Community
Magento Community
Magento Community
 
lukesdyer
Jr. Member
 
Avatar
Total Posts:  9
Joined:  2007-12-19
Austin,TX
 
Danebrood - 04 October 2007 08:00 PM

Figured out my problem. The config table ‘core_config_data’ has the authnet URI:

'payment/authorizenet/cgi_url'

set to:

'https://secure.authorize.net:433/gateway/transact.dll'


I changed the port to 443, and it works perfectly now.

I am also getting a pop up box with the following message:

“Unable to read response, or response is empty”

I have disabled Credit Card, and enabled Credit Card(authorize.net)
I have entered my api login ID and transaction key in the configurations.

Where do I go to change : config table ‘core_config_data’ ?

 
Magento Community Magento Community
Magento Community
Magento Community
 
SeL_
Magento Team
 
Avatar
Total Posts:  1140
Joined:  2007-10-10
Paris, France
 

’core_config_data’ is a table in the database.
You have to run this statement in your database:

update core_config_data
set value 
'https://secure.authorize.net:443/gateway/transact.dll'
where path 'payment/authorizenet/cgi_url'
 
Magento Community Magento Community
Magento Community
Magento Community
 
lukesdyer
Jr. Member
 
Avatar
Total Posts:  9
Joined:  2007-12-19
Austin,TX
 
SeL - 19 December 2007 07:52 AM

‘core_config_data’ is a table in the database.
You have to run this statement in your database:

update core_config_data
set value 
'https://secure.authorize.net:443/gateway/transact.dll'
where path 'payment/authorizenet/cgi_url'

Thanks, I ran that query and placed another order.
I got the message:

Invalid HTTP response version

Any idea what that means?

 
Magento Community Magento Community
Magento Community
Magento Community
 
Brady
Guru
 
Avatar
Total Posts:  330
Joined:  2007-09-10
Orange County, CA
 

I have the same result as lukesdyer, although I’m trying to use the AuthNet TEST Account URL mentioned above.

 
Magento Community Magento Community
Magento Community
Magento Community
 
lukesdyer
Jr. Member
 
Avatar
Total Posts:  9
Joined:  2007-12-19
Austin,TX
 

I have authorize.net as the only active payment method in Magento.
-------------------------------------------------------------------------------------
>System > Configuration > Payment Methods > Authorize.net >

Enabled: Yes
Title: Credit Card
API Login ID: placed my api login here
Transaction key: I generated a key from authorize and placed that here
New order status: Pending
Test mode: No (my authorize.net account is also NOT in test mode)
-------------------------------------------------------------------------------------

I am still getting: Invalid HTTP response version

I have searched the forums, both magento community, google, and authorize.net website.
I can’t find anything on this error message.

 
Magento Community Magento Community
Magento Community
Magento Community
 
lukesdyer
Jr. Member
 
Avatar
Total Posts:  9
Joined:  2007-12-19
Austin,TX
 

RE: Invalid HTTP response version

I just checked my Authorize.net account and the test orders that I placed are:

Authorized/Pending Capture

I’m not sure if that sheds any more light on the problem.. but I thought that I would add it to the post

 
Magento Community Magento Community
Magento Community
Magento Community
 
FireIslandMan
Jr. Member
 
Total Posts:  10
Joined:  2007-12-20
 

Also getting error:

Invalid HTTP response version:

with either Authorize.net Test Mode: Yes or No

Although customer gets a Customer Receipt/Purchase Confirmation email if enabled in your Authorize.net account. When Test Mode OFF in Authorize.net account, the transaction appears in the “List of Unsettled Transactions” as Authorized/Pending Capture. But no orders are recorded in Magento admin.

Anybody here get Magento to successfully process orders with Authorize.net credit card payments yet?

 
Magento Community Magento Community
Magento Community
Magento Community
 
FireIslandMan
Jr. Member
 
Total Posts:  10
Joined:  2007-12-20
 

Can this have anything to do with the “Transaction Response Settings” in our Authorize.net account? What should these settings be?

Transaction Version
Receipt Page
Response/Receipt URLs
Silent Post URL
Receipt Page
Relay Response
Direct Response

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top
Page 1 of 4