Posting in the Magento forums has been disabled pending the implementation of a new and improved forum solution which should better serve the community.

For new questions please post at magento.stackexchange.com, the community-run support site for the Magento community. We will be providing updates on the new forum solution soon. For questions or concerns please email community@magento.com.

Magento Forum

Datenbankfehler beim Kunden Bearbeiten
 
rubik35
Jr. Member
 
Total Posts:  2
Joined:  2011-11-03
 

Hallöchen

ich habe ein riesen Problem. Wenn ich auf “Kunden” gehe, sehe ich alles. Aber sobald ich bei einem Kunden auf bearbeiten gehe kommt dieser fehler:

SQLSTATE[42S02]: Base table or view not found: 1146 Table ‘sf-com-neu.ops_alias’ doesn’t exist

Trace:
#0 /var/www/vhosts/DOMAIN/httpdocs/lib/Varien/Db/Statement/Pdo/Mysql.php(110): Zend_Db_Statement_Pdo->_execute(Array)
#1 /var/www/vhosts/DOMAIN/httpdocs/lib/Zend/Db/Statement.php(300): Varien_Db_Statement_Pdo_Mysql->_execute(Array)
#2 /var/www/vhosts/DOMAIN/httpdocs/lib/Zend/Db/Adapter/Abstract.php(479): Zend_Db_Statement->execute(Array)
#3 /var/www/vhosts/DOMAIN/httpdocs/lib/Zend/Db/Adapter/Pdo/Abstract.php(238): Zend_Db_Adapter_Abstract->query(’SELECT COUNT(*)...’, Array)
#4 /var/www/vhosts/DOMAIN/httpdocs/lib/Varien/Db/Adapter/Pdo/Mysql.php(419): Zend_Db_Adapter_Pdo_Abstract->query(’SELECT COUNT(*)...’, Array)
#5 /var/www/vhosts/DOMAIN/httpdocs/lib/Zend/Db/Adapter/Abstract.php(825): Varien_Db_Adapter_Pdo_Mysql->query(Object(Varien_Db_Select), Array)
#6 /var/www/vhosts/DOMAIN/httpdocs/lib/Varien/Data/Collection/Db.php(225): Zend_Db_Adapter_Abstract->fetchOne(Object(Varien_Db_Select), Array)
#7 /var/www/vhosts/DOMAIN/httpdocs/lib/Varien/Data/Collection.php(225): Varien_Data_Collection_Db->getSize()
#8 /var/www/vhosts/DOMAIN/httpdocs/lib/Varien/Data/Collection.php(211): Varien_Data_Collection->getLastPageNumber()
#9 /var/www/vhosts/DOMAIN/httpdocs/lib/Varien/Data/Collection/Db.php(516): Varien_Data_Collection->getCurPage()
#10 /var/www/vhosts/DOMAIN/httpdocs/lib/Varien/Data/Collection/Db.php(563): Varien_Data_Collection_Db->_renderLimit()
#11 /var/www/vhosts/DOMAIN/httpdocs/app/code/core/Mage/Adminhtml/Block/Widget/Grid.php(533): Varien_Data_Collection_Db->load()
#12 /var/www/vhosts/DOMAIN/httpdocs/app/code/community/Netresearch/OPS/Block/Adminhtml/Customer/Edit/Tab/Alias.php(100): Mage_Adminhtml_Block_Widget_Grid->_prepareCollection()
#13 /var/www/vhosts/DOMAIN/httpdocs/app/code/core/Mage/Adminhtml/Block/Widget/Grid.php(626): Netresearch_OPS_Block_Adminhtml_Customer_Edit_Tab_Alias->_prepareCollection()
#14 /var/www/vhosts/DOMAIN/httpdocs/app/code/core/Mage/Adminhtml/Block/Widget/Grid.php(632): Mage_Adminhtml_Block_Widget_Grid->_prepareGrid()
#15 /var/www/vhosts/DOMAIN/httpdocs/app/code/core/Mage/Core/Block/Abstract.php(862): Mage_Adminhtml_Block_Widget_Grid->_beforeToHtml()
#16 /var/www/vhosts/DOMAIN/httpdocs/app/code/core/Mage/Adminhtml/Block/Widget/Tabs.php(303): Mage_Core_Block_Abstract->toHtml()
#17 /var/www/vhosts/DOMAIN/httpdocs/app/design/adminhtml/default/default/template/widget/tabs.phtml(38): Mage_Adminhtml_Block_Widget_Tabs->getTabContent(Object(Netresearch_OPS_Block_Adminhtml_Customer_Edit_Tab_Alias))
#18 /var/www/vhosts/DOMAIN/httpdocs/var/cache/ew/files/Mage/Core/Block/Template/04f770974a5fa80de044e2b61949ab5a.php(241): include(’/var/www/vhosts...’)
... usw.

Ich habe nun tagelang Google bemüht, aber nichts gefunden. auch das Datenbank reperatur Tool hat nichts gebracht. Vielleicht kann mir jemand helfen.

das wäre super...am besten per mail oder hier

rubik50@hotmail.com

 
Magento Community Magento Community
Magento Community
Magento Community
 
Quinty
Jr. Member
 
Total Posts:  12
Joined:  2010-11-15
 

i also have this error while upgrading the Official Ogone extension.

I looked in the mysql directory and created the table manually

CREATE TABLE ‘ops_alias’ (
`id` int(11) unsigned NOT NULL auto_increment,
`customer_id` int(10),
`alias` varchar(32),
`brand` varchar(50),
`billing_address_hash` varchar(255),
`shipping_address_hash` varchar(255),
`pseudo_account_or_cc_no` varchar(255),
`expiration_date` varchar(10),
`payment_method` varchar(50),
`created_at` timestamp default CURRENT_TIMESTAMP,
PRIMARY KEY (`id`)
) ENGINE=InnoDB DEFAULT CHARSET=utf8;

At least the site doesn’t give an error anymore right now.

it’s been a while since I used Magento ... it’ so silly. I almost even can’t read the captcha to post this reply.

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top