Posting in the Magento forums has been disabled pending the implementation of a new and improved forum solution which should better serve the community.

For new questions please post at magento.stackexchange.com, the community-run support site for the Magento community. We will be providing updates on the new forum solution soon. For questions or concerns please email community@magento.com.

Magento Forum

0.6.12840 -InstallDB Issue? Timezone? 
 
NickL
Sr. Member
 
Avatar
Total Posts:  188
Joined:  2007-08-31
 

Anyone else experiencing this?

I just tried a new( clean) install of .12840. All seems ok until I click continue and install/wizard/installDb/ returns:

[message:protected] => Mysqli statement execute error Incorrect arguments to mysql_stmt_execute
    [string
:private] => 
    
[code:protected] => 0

Strict Noticestrtotime() [function.strtotime]It is not safe to rely on the system's timezone settings. Please use the date.timezone setting, the TZ environment variable or the date_default_timezone_set() function. In case you used any of those methods and you are still getting this warning, you most likely misspelled the timezone identifier. We selected 'America/New_York' for 'EDT/-4.0/DST' instead in /home/kmg/public_html/shop/app/code/core/Mage/Install/Model/Installer.php on line 38
[0] in strtotime(Mage_Core_Model_Config_Element) in /home/kmg/public_html/shop/app/code/core/Mage/Install/Model/Installer.php on line 38
[1] in Mage_Install_Model_Installer->isApplicationInstalled() in /home/kmg/public_html/shop/app/Mage.php on line 362
[2] in Mage::run("base") in /home/kmg/public_html/shop/index.php on line 27

and

exception 'Exception' with message 'You need init translate area' in /home/kmg/public_html/shop/app/Mage.php:299
Stack trace
:
#0 /home/kmg/public_html/shop/app/code/core/Mage/Core/Model/Translate.php(291): Mage::throwException('You need init t...')
#1 /home/kmg/public_html/shop/app/code/core/Mage/Core/Model/Translate.php(356): Mage_Core_Model_Translate->getData()
#2 /home/kmg/public_html/shop/app/code/core/Mage/Core/functions.php(47): Mage_Core_Model_Translate->translate(Array)
#3 /home/kmg/public_html/shop/app/code/core/Mage/Core/Model/Resource/Setup.php(242): __('Error in file: ...', '/home/kmg/publi...', 'Mysqli statemen...')
#4 /home/kmg/public_html/shop/app/code/core/Mage/Core/Model/Resource/Setup.php(122): Mage_Core_Model_Resource_Setup->_modifyResourceDb('upgrade', '0.6.0', '0.6.9')
#5 /home/kmg/public_html/shop/app/code/core/Mage/Core/Model/Resource/Setup.php(108): Mage_Core_Model_Resource_Setup->_installResourceDb('0.6.9')
#6 /home/kmg/public_html/shop/app/code/core/Mage/Core/Model/Resource/Setup.php(82): Mage_Core_Model_Resource_Setup->applyUpdates()
#7 /home/kmg/public_html/shop/app/code/core/Mage/Core/Model/Config.php(151): Mage_Core_Model_Resource_Setup::applyAllUpdates()
#8 /home/kmg/public_html/shop/app/Mage.php(326): Mage_Core_Model_Config->init(NULL)
#9 /home/kmg/public_html/shop/app/Mage.php(349): Mage::init(NULL)
#10 /home/kmg/public_html/shop/index.php(27): Mage::run('base')
#11 {main}

Anyone else get this?

 
Magento Community Magento Community
Magento Community
Magento Community
 
NickL
Sr. Member
 
Avatar
Total Posts:  188
Joined:  2007-08-31
 

Tried with both the light and heavy installations.  same result. Also tried changing time on the server… just to see if it made any difference. Not much luck tho. 

I’m guessing this can be localized to the new Time-zone declarations. Am i wrong?

 
Magento Community Magento Community
Magento Community
Magento Community
 
NickL
Sr. Member
 
Avatar
Total Posts:  188
Joined:  2007-08-31
 

Anyone else see this?  or no where to start to fix it?  I’ve been looking through the code and can’t locate where this new Time-zone declaration takes place.  Is there anyway possible to use the Previous Installer?

 
Magento Community Magento Community
Magento Community
Magento Community
 
my evil twin
Member
 
Total Posts:  34
Joined:  2007-08-31
Hamburg, Germany
 

same here.

tried to update, but didn’t work. now, i can’t even do a fresh install.

argh.

 
Magento Community Magento Community
Magento Community
Magento Community
 
NickL
Sr. Member
 
Avatar
Total Posts:  188
Joined:  2007-08-31
 

my evil twin:

Try This (for a Fresh Install)
1.) upload the new files from the new package (or unpack via SSH)
2.) goto your app/etc/ directory
3.) open up local.xml.template

Find this under <default setup>:

<resources>

            <
default_setup>
                <
connection>
                    <
host>{{db_host}}</host>
                    <
username>{{db_user}}</username>
                    <
password>{{db_pass}}</password>
                    <
dbname>{{db_name}}</dbname>
                    <
active>1</active>
                </
connection>
 </
default_setup>

And add this line above <host>{{db_host}}</host> :

<type>pdo_mysql</type>

So it should now read:

<default_setup>

                <
connection>
                    <
type>pdo_mysql</type>
                    <
host>{{db_host}}</host>
                    <
username>{{db_user}}</username>
                    <
password>{{db_pass}}</password>
                    <
dbname>{{db_name}}</dbname>
                    <
active>1</active>
                </
connection>
            </
default_setup>

Save your changes to local.xml.template and then do a Fresh Install using that file.  That worked ok I my end.  I believe it’s some sort of issue with Zend Framework.  I’m sure someone from the Magento Team can elaborate.

btw.. props to Moshe on this.

 
Magento Community Magento Community
Magento Community
Magento Community
 
my evil twin
Member
 
Total Posts:  34
Joined:  2007-08-31
Hamburg, Germany
 

doesn’t work for me :(

i get this:

Strict Notice: strtotime() [function.strtotime]: It is not safe to rely on the system’s timezone settings. Please use the date.timezone setting, the TZ environment variable or the date_default_timezone_set() function. In case you used any of those methods and you are still getting this warning, you most likely misspelled the timezone identifier. We selected ‘Europe/Berlin’ for ‘CEST/2.0/DST’ instead in /www/htdocs/v027509/marc/shop/app/code/core/Mage/Install/Model/Installer.php on line 38
[0] in strtotime(Mage_Core_Model_Config_Element) in /www/htdocs/v027509/marc/shop/app/code/core/Mage/Install/Model/Installer.php on line 38
[1] in Mage_Install_Model_Installer->isApplicationInstalled() in /www/htdocs/v027509/marc/shop/app/Mage.php on line 362
[2] in Mage::run("base") in /www/htdocs/v027509/marc/shop/index.php on line 27

exception ‘Exception’ with message ‘You need init translate area’ in /www/htdocs/v027509/marc/shop/app/Mage.php:299
Stack trace:
#0 /www/htdocs/v027509/marc/shop/app/code/core/Mage/Core/Model/Translate.php(291): Mage::throwException(’You need init t...’)
#1 /www/htdocs/v027509/marc/shop/app/code/core/Mage/Core/Model/Translate.php(356): Mage_Core_Model_Translate->getData()
#2 /www/htdocs/v027509/marc/shop/app/code/core/Mage/Core/functions.php(47): Mage_Core_Model_Translate->translate(Array)
#3 /www/htdocs/v027509/marc/shop/app/code/core/Mage/Core/Model/Resource/Setup.php(242): __()
#4 /www/htdocs/v027509/marc/shop/app/code/core/Mage/Core/Model/Resource/Setup.php(122): Mage_Core_Model_Resource_Setup->_modifyResourceDb(’Error in file: ...’, ‘/www/htdocs/v02...’, ‘SQLSTATE[HY000]...’)
#5 /www/htdocs/v027509/marc/shop/app/code/core/Mage/Core/Model/Resource/Setup.php(108): Mage_Core_Model_Resource_Setup->_installResourceDb(’upgrade’, ‘0.6.0’, ‘0.6.4’)
#6 /www/htdocs/v027509/marc/shop/app/code/core/Mage/Core/Model/Resource/Setup.php(82): Mage_Core_Model_Resource_Setup->applyUpdates(’0.6.4’)
#7 /www/htdocs/v027509/marc/shop/app/code/core/Mage/Core/Model/Config.php(151): Mage_Core_Model_Resource_Setup::applyAllUpdates()
#8 /www/htdocs/v027509/marc/shop/app/Mage.php(326): Mage_Core_Model_Config->init()
#9 /www/htdocs/v027509/marc/shop/app/Mage.php(349): Mage::init(NULL)
#10 /www/htdocs/v027509/marc/shop/index.php(27): Mage::run(NULL)
#11 {main}

:(

 
Magento Community Magento Community
Magento Community
Magento Community
 
Moshe
Magento Team
 
Avatar
Total Posts:  1770
Joined:  2007-08-07
Los Angeles
 

@my evin twin: try to clean var/cache/config, remove app/etc/local.xml and re-run install procedure.

 
Magento Community Magento Community
Magento Community
Magento Community
 
my evil twin
Member
 
Total Posts:  34
Joined:  2007-08-31
Hamburg, Germany
 

i did that several times, but it didn’t work.

actually, it worked just fine when i left the standard-settings, before i always tried to change it to “german/europe-berlin/europe”.

 
Magento Community Magento Community
Magento Community
Magento Community
 
Moshe
Magento Team
 
Avatar
Total Posts:  1770
Joined:  2007-08-07
Los Angeles
 

@my evil twin: got it. will make failsafe check. thanks

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top