Magento Forum

   
Page 1 of 19
Payment method - new module tutorial
 
Moshe
Magento Team
 
Avatar
Total Posts:  1770
Joined:  2007-08-07
Los Angeles
 

Hi all,

Here’s small tutorial on creating a payment module:
http://www.magentocommerce.com/wiki/how-to/create-payment-method-module

It shows basic technics of creating a generic module and also some specific API for payment modules.

Let me know if there’s anything to clarify or improve smile

Thank you.

 
Magento Community Magento Community
Magento Community
Magento Community
 
Tweakmag
Guru
 
Avatar
Total Posts:  307
Joined:  2007-08-31
London, UK
 

Thanks Moshe. Very handy smile

 
Magento Community Magento Community
Magento Community
Magento Community
 
jsperri
Sr. Member
 
Total Posts:  126
Joined:  2007-08-31
Fistufle
 

Dunno if the article is being edited, but I can’t access it at the moment. I am getting “This Article Does Not Exist Yet.” in the WIKI.

Hope to see it back soon smile

 
Magento Community Magento Community
Magento Community
Magento Community
 
Moshe
Magento Team
 
Avatar
Total Posts:  1770
Joined:  2007-08-07
Los Angeles
 

it’s back, sorry about that

 
Magento Community Magento Community
Magento Community
Magento Community
 
WisdOMbooks
Sr. Member
 
Avatar
Total Posts:  144
Joined:  2007-08-31
Kolkata (Calcutta) - INDIA
 

Is this Module creating P A V e M E N T s ? ? ?  LOL

Image Attachments
paVements.jpg
 
Magento Community Magento Community
Magento Community
Magento Community
 
Moshe
Magento Team
 
Avatar
Total Posts:  1770
Joined:  2007-08-07
Los Angeles
 

Interesting.. Probably using large font in browser? Doesn’t fit into line-height

 
Magento Community Magento Community
Magento Community
Magento Community
 
jsperri
Sr. Member
 
Total Posts:  126
Joined:  2007-08-31
Fistufle
 

Just curious if anyone tried the tutorial, did it work for you ?

In my case I got the following error when reloading the catalog homepage for the first time:

Warningsimplexml_load_string() [function.simplexml-load-string]Entityline 1parser error Specification mandate value for attribute xml in /var/www/site/lib/Varien/Simplexml/Config.php on line 310
[0] in simplexml_load_string
("
"
"Mage_Core_Model_Config_Element"in /var/www/site/lib/Varien/Simplexml/Config.php on line 310
[1] in Varien_Simplexml_Config
->loadString("
"
"Mage_Core_Model_Config_Element"in /var/www/site/lib/Varien/Simplexml/Config.php on line 298
[2] in Varien_Simplexml_Config
->loadFile("/var/www/site/app/code/local/Mage/NewModule/etc/config.xml") in /var/www/site/app/code/core/Mage/Core/Model/Config.php on line 138
[3] in Mage_Core_Model_Config
->init(NULLin /var/www/site/app/Mage.php on line 326
[4] in Mage
::init(NULLin /var/www/site/app/Mage.php on line 349
[5] in Mage
::run("base"in /var/www/site/index.php on line 27
I suspect I have not properly modified /etc/local.xml, as I am not sure where the new block of code should go.

 
Magento Community Magento Community
Magento Community
Magento Community
 
WisdOMbooks
Sr. Member
 
Avatar
Total Posts:  144
Joined:  2007-08-31
Kolkata (Calcutta) - INDIA
 
Moshe - 04 October 2007 08:31 PM

Interesting.. Probably using large font in browser?
Doesn’t fit into line-height

My browser’s fonts are at a regular 100% in MsIE

It is like that in ALL the titles of the Wiki that they are cut off at their base-line.

See another couple of samples in the attached images.

A minor point, no doubt, but an eye-sore, nonetheless
.
Anybody else sees this like me? Any suggested remedy?

Image Attachments
MagentoWIKI.jpgMagentoWIKI2.jpg
 
Magento Community Magento Community
Magento Community
Magento Community
 
WisdOMbooks
Sr. Member
 
Avatar
Total Posts:  144
Joined:  2007-08-31
Kolkata (Calcutta) - INDIA
 

OK: I just tested it with Opera and FireFox and there it is all right,
the writing appears complete ON, BELOW and ABOVE the line.

The problem, then, remains with MsIE.
What to do then (short of changing the browser smile ) ?

 
Magento Community Magento Community
Magento Community
Magento Community
 
adimagento
Administrator
 
Avatar
Total Posts:  626
Joined:  2007-08-29
Los Angeles, CA
 

Thanks WisdOMbooks, we are aware of this issue with IE6 and are working to fix this style conflict as soon as possible. You can also see these titles fine on FireFox in the mean time.

 
Magento Community Magento Community
Magento Community
Magento Community
 
WisdOMbooks
Sr. Member
 
Avatar
Total Posts:  144
Joined:  2007-08-31
Kolkata (Calcutta) - INDIA
 

Thank you, AdiMagento.
I can survive going on guessing the below-the-line strokes,
it keeps my brain working LOL

-----------------------------------------------------------------------
ADImagento…
I guess you know what ADI means in Sanskrit?!
It stands for: SUPREME, PRIMEVAL, ORIGINAL,etc.
Which describes you as the BOSS of Magento… am I right grin ?
[sorry, Robin (Roy + Rubin =)...]

 
Magento Community Magento Community
Magento Community
Magento Community
 
Inline Media
Sr. Member
 
Avatar
Total Posts:  130
Joined:  2007-09-17
The Netherlands
 

I’ve followed the payment tutorial, but It doesn’t show up in de Admin / System / Configuration / Payment Methods.
Did I mis something?

 
Magento Community Magento Community
Magento Community
Magento Community
 
jsperri
Sr. Member
 
Total Posts:  126
Joined:  2007-08-31
Fistufle
 

Looks like the mysql install script for the new payment module did not execute.
Did you get any error like I did when browsing to the catalog homepage, just after adding/modifying the new module files ?

I can’t help much, as I haven’t fixed it myself, yet.

 
Magento Community Magento Community
Magento Community
Magento Community
 
Inline Media
Sr. Member
 
Avatar
Total Posts:  130
Joined:  2007-09-17
The Netherlands
 

No I’m not getting any orders, I doubled checked if I made all the files and copied the exact examples, but it all looks fine.

 
Magento Community Magento Community
Magento Community
Magento Community
 
Moshe
Magento Team
 
Avatar
Total Posts:  1770
Joined:  2007-08-07
Los Angeles
 

@bluemotion: can you please try to add whatever went to local.xml to app/etc/config.xml ?

 
Magento Community Magento Community
Magento Community
Magento Community
 
lorenzo01
Sr. Member
 
Avatar
Total Posts:  221
Joined:  2007-09-06
France
 

hello,
does the file mysql4-install-0.1.0.php function with MySQL 5.0.32 ?
because the installation of this new payment module does not function with me

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
    Back to top
Page 1 of 19