Magento Forum

   
Page 1 of 2
Magento Instalation
 
Bruno Sanos
Jr. Member
 
Total Posts:  9
Joined:  2008-05-10
 

hello, I’m trying to install the shop on my website and I would like I can correct this error. Follow the link: http://www.bhpages.com/loja

Thank you

Image Attachments
imagem.JPG
 
Magento Community Magento Community
Magento Community
Magento Community
 
Crucial Web Host
Guru
 
Avatar
Total Posts:  364
Joined:  2007-11-08
Phoenix, AZ
 

Try this from shell in the root directory of your installation;

chmod -R 777 var/

 
Magento Community Magento Community
Magento Community
Magento Community
 
Bruno Sanos
Jr. Member
 
Total Posts:  9
Joined:  2008-05-10
 

Applied chmod-R 777 var / more not corrected.

 
Magento Community Magento Community
Magento Community
Magento Community
 
Crucial
Enthusiast
 
Avatar
Total Posts:  770
Joined:  2007-11-07
Phoenix, AZ
 

What about the entire Magento directory:

chmod -R 777 magento

Replace magento with the directory name where it’s installed.

 
Magento Community Magento Community
Magento Community
Magento Community
 
picou
Jr. Member
 
Total Posts:  13
Joined:  2008-05-25
 

Hello,
I’m having the same probleme:
Tried to change back the name folder from “boutique” to “magenta” but does not solve the problem.
Could someone point me in the wright direction?

This is my server information:

General server information:
Operating system Linux
Service Status Click to View
Kernel version 2.6.23.14
Machine Type i686
Apache version 2.2.6 (Unix)
PERL version 5.8.8
Path to PERL /usr/bin/perl
Path to sendmail /usr/sbin/sendmail
Installed Perl Modules Click to View
PHP version 5.2.5
MySQL version 4.1.22-standard
cPanel Version 11.18.5-RELEASE 24225
Theme cPanel X v2.6.0
Documentation Click to View
cPanel Pro 1.0 (RC1)

Thanks.

start error here --------------------------
There has been an error processing your request.

cache_dir is not writable
Trace:
#0 /home/pointpc/public_html/boutique/app/code/core/Zend/Cache/Backend/File.php(149): Zend_Cache::throwException(’cache_dir is no...’)
#1 /home/pointpc/public_html/boutique/app/code/core/Zend/Cache/Backend/File.php(121): Zend_Cache_Backend_File->setCacheDir(’/home/pointpc/p...’)
#2 /home/pointpc/public_html/boutique/lib/Zend/Cache.php(124): Zend_Cache_Backend_File->__construct(Array)
#3 /home/pointpc/public_html/boutique/app/code/core/Mage/Core/Model/App.php(830): Zend_Cache::factory(’Core’, ‘File’, Array, Array)
#4 /home/pointpc/public_html/boutique/app/code/core/Mage/Core/Model/Locale.php(71): Mage_Core_Model_App->getCache()
#5 /home/pointpc/public_html/boutique/app/code/core/Mage/Core/Model/Config.php(697): Mage_Core_Model_Locale->__construct(Array)
#6 /home/pointpc/public_html/boutique/app/Mage.php(294): Mage_Core_Model_Config->getModelInstance(’core/locale’, Array)
#7 /home/pointpc/public_html/boutique/app/Mage.php(308): Mage::getModel(’core/locale’, Array)
#8 /home/pointpc/public_html/boutique/app/code/core/Mage/Core/Model/App.php(687): Mage::getSingleton(’core/locale’)
#9 /home/pointpc/public_html/boutique/app/code/core/Mage/Core/Model/Translate.php(312): Mage_Core_Model_App->getLocale()
#10 /home/pointpc/public_html/boutique/app/code/core/Mage/Core/Model/Translate.php(152): Mage_Core_Model_Translate->getLocale()
#11 /home/pointpc/public_html/boutique/app/code/core/Mage/Core/Model/Translate.php(95): Mage_Core_Model_Translate->setConfig(Array)
#12 /home/pointpc/public_html/boutique/app/code/core/Mage/Core/Model/App/Area.php(139): Mage_Core_Model_Translate->init(’install’)
#13 /home/pointpc/public_html/boutique/app/code/core/Mage/Core/Model/App/Area.php(114): Mage_Core_Model_App_Area->_initTranslate()
#14 /home/pointpc/public_html/boutique/app/code/core/Mage/Core/Model/App/Area.php(86): Mage_Core_Model_App_Area->_loadPart(’translate’)
#15 /home/pointpc/public_html/boutique/app/code/core/Mage/Core/Model/App.php(488): Mage_Core_Model_App_Area->load()
#16 /home/pointpc/public_html/boutique/app/code/core/Mage/Core/Controller/Varien/Action.php(369): Mage_Core_Model_App->loadArea(’install’)
#17 /home/pointpc/public_html/boutique/app/code/core/Mage/Install/controllers/WizardController.php(29): Mage_Core_Controller_Varien_Action->preDispatch()
#18 /home/pointpc/public_html/boutique/app/code/core/Mage/Core/Controller/Varien/Action.php(335): Mage_Install_WizardController->preDispatch()
#19 /home/pointpc/public_html/boutique/app/code/core/Mage/Core/Controller/Varien/Router/Standard.php(159): Mage_Core_Controller_Varien_Action->dispatch(’config’)
#20 /home/pointpc/public_html/boutique/app/code/core/Mage/Core/Controller/Varien/Front.php(146): Mage_Core_Controller_Varien_Router_Standard->match(Object(Mage_Core_Controller_Request_Http))
#21 /home/pointpc/public_html/boutique/app/Mage.php(427): Mage_Core_Controller_Varien_Front->dispatch()
#22 /home/pointpc/public_html/boutique/index.php(40): Mage::run()
end error here --------------------------

 
Magento Community Magento Community
Magento Community
Magento Community
 
Crucial Web Host
Guru
 
Avatar
Total Posts:  364
Joined:  2007-11-08
Phoenix, AZ
 

Try this from shell in your Magento directory.

chmod -R 777 var/

 
Magento Community Magento Community
Magento Community
Magento Community
 
picou
Jr. Member
 
Total Posts:  13
Joined:  2008-05-25
 

Ok, reconsidered the information about chmod that was correct on the VAR folder.
I simply modifies all the chmod INSIDE the folder VAR to 777 and installed with all the default information (english, Dollars)
modified the folder name back to “boutique”
IT IS NOW INSTALLED PROPERLY
Thank you for your help!

 
Magento Community Magento Community
Magento Community
Magento Community
 
Crucial Web Host
Guru
 
Avatar
Total Posts:  364
Joined:  2007-11-08
Phoenix, AZ
 
picou - 26 May 2008 05:34 AM

I simply modifies all the chmod INSIDE the folder VAR to 777 and installed with all the default information (english, Dollars)
modified the folder name back to “boutique”
IT IS NOW INSTALLED PROPERLY
Thank you for your help!

Glad to hear you’ve gotten Magento working.

Yes, all the folders/files under var directory must write permissions for the web server.  The ‘-R’ flag tells chmod to apply the mode change recursively. 

If you are not doing this by shell it may be necessary to chmod the directories individually if your FTP program does not support recursive permission mode changes.

I hope you enjoy Magento as much as we have!

 
Magento Community Magento Community
Magento Community
Magento Community
 
dkoo761
Jr. Member
 
Total Posts:  8
Joined:  2008-10-10
 

VERY helpful info! I thought I had set it to 777 -R but on closer inspection it was 757 smile

 
Magento Community Magento Community
Magento Community
Magento Community
 
Owz
Jr. Member
 
Total Posts:  3
Joined:  2008-11-24
 

i have had the same problem, I have tried to change the file permissions of the main folders and htaccess file to 777 but I still get the same error..

I have installed magento before and it worked fine.. but I did a clean re-install and now this error pops up…

Any idea why it might still be happening?

my server details:

Operating system Linux
Kernel version 2.6.24.5-grsec
Machine Type i686
Apache version 2.2.10 (Unix)
PERL version 5.8.8
PHP version 5.2.6
MySQL version 5.0.67-community

 
Magento Community Magento Community
Magento Community
Magento Community
 
Owz
Jr. Member
 
Total Posts:  3
Joined:  2008-11-24
 

cache_dir is not writable
Trace:
#0 /home/owz2004/public_html/magento/app/code/core/Zend/Cache/Backend/File.php(149): Zend_Cache::throwException(’cache_dir is no...’)
#1 /home/owz2004/public_html/magento/app/code/core/Zend/Cache/Backend/File.php(121): Zend_Cache_Backend_File->setCacheDir(’/home/owz2004/p...’)
#2 /home/owz2004/public_html/magento/lib/Zend/Cache.php(124): Zend_Cache_Backend_File->__construct(Array)
#3 /home/owz2004/public_html/magento/app/code/core/Mage/Core/Model/App.php(936): Zend_Cache::factory(’Core’, ‘File’, Array, Array)
#4 /home/owz2004/public_html/magento/app/code/core/Mage/Core/Model/App.php(949): Mage_Core_Model_App->getCache()
#5 /home/owz2004/public_html/magento/app/code/core/Mage/Core/Model/Config.php(337): Mage_Core_Model_App->loadCache(’config_global’)
#6 /home/owz2004/public_html/magento/lib/Varien/Simplexml/Config.php(382): Mage_Core_Model_Config->_loadCache(’config_global’)
#7 /home/owz2004/public_html/magento/app/code/core/Mage/Core/Model/Config.php(149): Varien_Simplexml_Config->loadCache()
#8 /home/owz2004/public_html/magento/app/code/core/Mage/Core/Model/App.php(243): Mage_Core_Model_Config->init(Array)
#9 /home/owz2004/public_html/magento/app/Mage.php(424): Mage_Core_Model_App->init(’’, ‘store’, Array)
#10 /home/owz2004/public_html/magento/app/Mage.php(443): Mage::app(’’, ‘store’, Array)
#11 /home/owz2004/public_html/magento/index.php(52): Mage::run()
#12 {main}

 
Magento Community Magento Community
Magento Community
Magento Community
 
Crucial
Enthusiast
 
Avatar
Total Posts:  770
Joined:  2007-11-07
Phoenix, AZ
 
Owz - 14 January 2009 12:20 PM

cache_dir is not writable

Delete the entire var/cache directory, or make sure safe_mode for PHP isn’t enabled. Would help if you posted your PHP info file as well, it’s easier than guessing at what’s wrong.

http://www.magentocommerce.com/wiki/groups/227/create_a_php_info_file

 
Magento Community Magento Community
Magento Community
Magento Community
 
Ubunter
Sr. Member
 
Avatar
Total Posts:  104
Joined:  2010-05-05
Madrid
 

Hello Crucial,
I don’t know if the thread it’s up to date, but my issue it’s…

I’m under 1.4.2.0 and the same I had within 1.4.1.1 and 1.4.10…

The issue that I can’t work and get all working only if I have chmod 777, just when I run magento-cleanup to fix the correct chmods, see attached screen-shoot, I get this error back, see screen-shoot…

I try to fix the chmod 777 -R only above /var, but no result…

And it’s not correct to have chmod 777 above all magento root directory, what do you think?

Regards,

Image Attachments
after-change.pngmagento-cleanup.pngMagento-check.png
 
Magento Community Magento Community
Magento Community
Magento Community
 
lideys
Jr. Member
 
Total Posts:  18
Joined:  2010-01-19
 

I’m having the same problem!
How can I fix it?

cache_dir is not writable

Trace:
#0 /var/www/vhosts/pet2you.com.br/httpdocs/lib/Zend/Cache/Backend/File.php(157): Zend_Cache::throwException(’cache_dir is no...’)
#1 /var/www/vhosts/pet2you.com.br/httpdocs/lib/Zend/Cache/Backend/File.php(121): Zend_Cache_Backend_File->setCacheDir(’tmp’)
#2 /var/www/vhosts/pet2you.com.br/httpdocs/lib/Zend/Cache.php(152): Zend_Cache_Backend_File->__construct(Array)
#3 /var/www/vhosts/pet2you.com.br/httpdocs/lib/Zend/Cache.php(93): Zend_Cache::_makeBackend(’File’, Array, false, false)
#4 /var/www/vhosts/pet2you.com.br/httpdocs/lib/Zend/Locale/Data.php(307): Zend_Cache::factory(’Core’, ‘File’, Array, Array)
#5 /var/www/vhosts/pet2you.com.br/httpdocs/app/code/core/Mage/Core/Block/Html/Calendar.php(42): Zend_Locale_Data::getList(’pt_BR’, ‘days’)
#6 /var/www/vhosts/pet2you.com.br/httpdocs/app/code/core/Mage/Core/Block/Abstract.php(753): Mage_Core_Block_Html_Calendar->_toHtml()
#7 /var/www/vhosts/pet2you.com.br/httpdocs/app/code/core/Mage/Core/Block/Abstract.php(520): Mage_Core_Block_Abstract->toHtml()
#8 /var/www/vhosts/pet2you.com.br/httpdocs/app/code/core/Mage/Core/Block/Abstract.php(471): Mage_Core_Block_Abstract->_getChildHtml(’calendar’, true)
#9 /var/www/vhosts/pet2you.com.br/httpdocs/app/design/adminhtml/default/default/template/page/head.phtml(34): Mage_Core_Block_Abstract->getChildHtml(’calendar’)
#10 /var/www/vhosts/pet2you.com.br/httpdocs/app/code/core/Mage/Core/Block/Template.php(212): include(’/var/www/vhosts...’)
#11 /var/www/vhosts/pet2you.com.br/httpdocs/app/code/core/Mage/Core/Block/Template.php(239): Mage_Core_Block_Template->fetchView(’adminhtml/defau...’)
#12 /var/www/vhosts/pet2you.com.br/httpdocs/app/code/core/Mage/Core/Block/Template.php(253): Mage_Core_Block_Template->renderView()
#13 /var/www/vhosts/pet2you.com.br/httpdocs/app/code/core/Mage/Core/Block/Abstract.php(753): Mage_Core_Block_Template->_toHtml()
#14 /var/www/vhosts/pet2you.com.br/httpdocs/app/code/core/Mage/Core/Block/Abstract.php(520): Mage_Core_Block_Abstract->toHtml()
#15 /var/www/vhosts/pet2you.com.br/httpdocs/app/code/core/Mage/Core/Block/Abstract.php(471): Mage_Core_Block_Abstract->_getChildHtml(’head’, true)
#16 /var/www/vhosts/pet2you.com.br/httpdocs/app/design/adminhtml/default/default/template/page.phtml(43): Mage_Core_Block_Abstract->getChildHtml(’head’)
#17 /var/www/vhosts/pet2you.com.br/httpdocs/app/code/core/Mage/Core/Block/Template.php(212): include(’/var/www/vhosts...’)
#18 /var/www/vhosts/pet2you.com.br/httpdocs/app/code/core/Mage/Core/Block/Template.php(239): Mage_Core_Block_Template->fetchView(’adminhtml/defau...’)
#19 /var/www/vhosts/pet2you.com.br/httpdocs/app/code/core/Mage/Core/Block/Template.php(253): Mage_Core_Block_Template->renderView()
#20 /var/www/vhosts/pet2you.com.br/httpdocs/app/code/core/Mage/Adminhtml/Block/Template.php(81): Mage_Core_Block_Template->_toHtml()
#21 /var/www/vhosts/pet2you.com.br/httpdocs/app/code/core/Mage/Core/Block/Abstract.php(753): Mage_Adminhtml_Block_Template->_toHtml()
#22 /var/www/vhosts/pet2you.com.br/httpdocs/app/code/core/Mage/Core/Model/Layout.php(529): Mage_Core_Block_Abstract->toHtml()
#23 /var/www/vhosts/pet2you.com.br/httpdocs/app/code/core/Mage/Core/Controller/Varien/Action.php(389): Mage_Core_Model_Layout->getOutput()
#24 /var/www/vhosts/pet2you.com.br/httpdocs/app/code/community/TBT/Enhancedgrid/controllers/Catalog/ProductController.php(56): Mage_Core_Controller_Varien_Action->renderLayout()
#25 /var/www/vhosts/pet2you.com.br/httpdocs/app/code/core/Mage/Core/Controller/Varien/Action.php(418): TBT_Enhancedgrid_Catalog_ProductController->indexAction()
#26 /var/www/vhosts/pet2you.com.br/httpdocs/app/code/core/Mage/Core/Controller/Varien/Router/Standard.php(254): Mage_Core_Controller_Varien_Action->dispatch(’index’)
#27 /var/www/vhosts/pet2you.com.br/httpdocs/app/code/core/Mage/Core/Controller/Varien/Front.php(177): Mage_Core_Controller_Varien_Router_Standard->match(Object(Mage_Core_Controller_Request_Http))
#28 /var/www/vhosts/pet2you.com.br/httpdocs/app/code/core/Mage/Core/Model/App.php(304): Mage_Core_Controller_Varien_Front->dispatch()
#29 /var/www/vhosts/pet2you.com.br/httpdocs/app/Mage.php(596): Mage_Core_Model_App->run(Array)
#30 /var/www/vhosts/pet2you.com.br/httpdocs/index.php(80): Mage::run(’’, ‘store’)
#31 {main}

 
Magento Community Magento Community
Magento Community
Magento Community
 
chiefair
Mentor
 
Avatar
Total Posts:  1839
Joined:  2009-06-04
 

Resetting Magento File Permissions

In addition to file permissions, make sure the files and directories are owned by your account’s login id. Nothing stinks so much as to run something from cron as root and have it mark a couple of files in var/cache as owned by root AND then wonder why things don’t work.

Running under mod_php might require your directories to be 775 and files be 664 so that your webserver gid can access them. (not a good idea on a shared environment)

Understanding Linux File Systems Permissions

Reading a stack trace doesn’t enable me to tell you specifically how to fix it, but the above contains enough information to help you increase your Linux Server Administration Skills enough to run the permissions and ownership problems down.

 
Magento Community Magento Community
Magento Community
Magento Community
 
lideys
Jr. Member
 
Total Posts:  18
Joined:  2010-01-19
 

Hi,

Thank you for help me, but I’m sorry, I do not understand how to fix my problem.
I tryed to execute magento-cleanup.php and apparently it works, but my problem persist.

So, do you have another idea? Or could you please specify how can corret the problem with your tip?

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
    Back to top
Page 1 of 2