Posting in the Magento forums has been disabled pending the implementation of a new and improved forum solution which should better serve the community.

For new questions please post at magento.stackexchange.com, the community-run support site for the Magento community. We will be providing updates on the new forum solution soon. For questions or concerns please email community@magento.com.

Magento Forum

Import Tax Rates not working
 
wiseacredesign
Jr. Member
 
Avatar
Total Posts:  7
Joined:  2008-04-17
Cincinnati, OH
 

I’ve created a .csv file based on the type of information generated when exporting a tax rate—but I get an error of ”Invalid file format upload attempt” every time.

I’ve added quotes, I’ve removed quotes, I’ve tried an .xml file; I’ve tried every conceivable way to import—every time I get the same error. What am I doing wrong; how do I import tax rates successfully?

Thanks for the help in advance.

 
Magento Community Magento Community
Magento Community
Magento Community
 
joolsr
Sr. Member
 
Total Posts:  99
Joined:  2008-01-16
 

seems there’s a lot of people with same problem ...

 
Magento Community Magento Community
Magento Community
Magento Community
 
maijar
Member
 
Total Posts:  49
Joined:  2008-06-15
 

Anything new with this topic? Using 1.1.1 and still not working.

 
Magento Community Magento Community
Magento Community
Magento Community
 
timdorr
Jr. Member
 
Total Posts:  3
Joined:  2008-08-08
 
maijar - 06 August 2008 09:14 PM

Anything new with this topic? Using 1.1.1 and still not working.

I haven’t tried 1.1.x yet, but it is probably the same issue as with 1.0. The problem is most likely the line breaks being used in your file. I use a Mac, so it saves it with Macintosh line endings. I don’t know if it works with DOS line breaks, but I switched my CSV file to use Unix line breaks and it worked right away after that. I don’t think you can do that within Excel, so you’ll have to use a text editor that can do the conversion for you.

On my Mac, I used BBEdit (you can use TextWrangler for free: http://www.barebones.com/products/textwrangler/ ). Just open up the .csv file, File > Save As..., and in the file dialog that pops up, click the Options… button to change line breaks to Unix.

I don’t know of a good option on Windows, but there might not be a problem if it handles DOS line breaks correctly. I haven’t tried, so maybe someone else can provide confirmation one way or the other.

 
Magento Community Magento Community
Magento Community
Magento Community
 
davew123
Jr. Member
 
Total Posts:  10
Joined:  2010-09-03
 

Had similar issue of importing tax rates.

Situation:
Working on a Mac.
Using MS Excel to edit tables for Alameda County, CA.
Did not use file with quotes around data.

Successful after saving to .csv file with specific file format saved as “Windows Comma Separated”.

Sample:
Code Country State Zip/Post Code Rate Zip/Post is Range Range From Range To default french german
US-CA-*-Rate 1 US CA * 7.5
US-NY-*-Rate 1 US NY * 8.375
Alameda County Tax US CA 94501-94587 1.5 1 94501 94587
Alameda County Tax 94588 US CA 94588 1.5
Alameda County Tax 94601 US CA 94601 1.5
Alameda County Tax 94602 US CA 94602 1.5

 
Magento Community Magento Community
Magento Community
Magento Community
 
nkpfin
Newbie
 
Total Posts:  0
Joined:  2013-03-16
 

the solution that worked for me was:
Import existing tax rates using the Import / Export tax rates link. Do not Export from Manage Tax Rates screen - that export is incomplete.

Use the column structure from exported file and build data set that you want to import. Save this file as CSV (Comma Delimited). Import.

I didnt use quotes or UNIX format.  Spent half a day dealing with all that, but nothing worked, except what’s above.

 
Magento Community Magento Community
Magento Community
Magento Community
 
GoMageTeam
Guru
 
Avatar
Total Posts:  356
Joined:  2013-01-13
Warsaw, Poland
 

Hello,

Please, look at this information: http://www.magentocommerce.com/knowledge-base/entry/tip-importing-tax-rates
Secondly, open, please, your CSV file using the text editor, for example, Geany, and look at the characters of the line breaking, they should be in the Linux format. And, most likely, you have CR+LF in the file( line feed and carriage return), but you should have only LF. And you should do your file with OpenOffice program.

 
Magento Community Magento Community
Magento Community
Magento Community
 
v4ino
Jr. Member
 
Total Posts:  2
Joined:  2013-07-12
 

So after 2+ days of banging my head trying to import Tax Rates from a .txt file I finally figured out what I did wrong - I was getting the message “Invalid file format upload attempt”. With 1,000+ zip codes to enter I was stubborn about finding a solution.

When you export from Sales->Tax->Manage Tax Zones and Rates you get the following column headers.
Code Country State Zip/Post Code Rate

When you export from Sales->Tax->Import/Export Tax Rates and click the Export Tax Rates button you get following column headers.
Code Country State Zip/Post Code Rate Zip/Post is Range Range From Range To default french german

So just add the extra column or export from Import/Export Tax Rates and it will upload smoothly.

Also, when searching for a solution I came across a great article about adding “ “ around a excel .CSV file.

http://www.markinns.com/articles/full/export_excel_csvs_with_double_quotes

Hope this helps

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top