Posting in the Magento forums has been disabled pending the implementation of a new and improved forum solution which should better serve the community.

For new questions please post at magento.stackexchange.com, the community-run support site for the Magento community. We will be providing updates on the new forum solution soon. For questions or concerns please email community@magento.com.

Magento Forum

Fatal error: Call to undefined method PEAR_Error::set()
 
logosol
Jr. Member
 
Total Posts:  3
Joined:  2008-05-02
 

Hi,

I get this error when i´m entering system>magento connect >manage extensions:

Fatal error: Call to undefined method PEAR_Error::set() in /home/a1025/s1025036/public_html/store/downloader/Maged/Pear.php on line 105

Any idea what´s wrong and how I can fix this?

/Robert

 
Magento Community Magento Community
Magento Community
Magento Community
 
Andreas Bruckmeier
Jr. Member
 
Total Posts:  8
Joined:  2008-05-14
 

same problem here but no solution!

 
Magento Community Magento Community
Magento Community
Magento Community
 
shopnz
Jr. Member
 
Total Posts:  15
Joined:  2008-06-19
 

Same problem - even a reinstall didn’t fix it

 
Magento Community Magento Community
Magento Community
Magento Community
 
shopnz
Jr. Member
 
Total Posts:  15
Joined:  2008-06-19
 

delete the pear.ini file worked and can now access connect , but hasnt fixed my real problem which is the installer is putting a theme into a magento folder not into root folders where the install is

 
Magento Community Magento Community
Magento Community
Magento Community
 
shopnz
Jr. Member
 
Total Posts:  15
Joined:  2008-06-19
 

Thought i better mention , its in this folder smile
/downloader/pearlib/pear.ini

It will rebuild its self when you go to connect

 
Magento Community Magento Community
Magento Community
Magento Community
 
matponta
Member
 
Total Posts:  39
Joined:  2008-05-20
Italy
 

Thank you shopnz, useful info!

Mattia

 
Magento Community Magento Community
Magento Community
Magento Community
 
blindnotes
Jr. Member
 
Total Posts:  5
Joined:  2008-08-27
 

Thanks alot. This helped me getting back into Connect!

cheers

 
Magento Community Magento Community
Magento Community
Magento Community
 
Aikanet
Member
 
Avatar
Total Posts:  40
Joined:  2009-03-16
Düsseldorf, Germany
 

Worked for me. Thanks for the tip!

 
Magento Community Magento Community
Magento Community
Magento Community
 
BlueKai
Member
 
Avatar
Total Posts:  42
Joined:  2008-09-04
Madrid Spain
 

worked for me too.. thank you

 
Magento Community Magento Community
Magento Community
Magento Community
 
Gavin Hall
Jr. Member
 
Avatar
Total Posts:  18
Joined:  2008-01-18
 

Worked for me also - many thanks

 
Magento Community Magento Community
Magento Community
Magento Community
 
Alex Leonard
Member
 
Total Posts:  43
Joined:  2010-02-03
 

Saved my ass, thanks!

No idea what caused it to break in the first place either :(

 
Magento Community Magento Community
Magento Community
Magento Community
 
junomedia
Sr. Member
 
Avatar
Total Posts:  142
Joined:  2008-09-10
Nottingham, England
 

Thanks, worked great!

 
Magento Community Magento Community
Magento Community
Magento Community
 
feel_faith
Jr. Member
 
Total Posts:  1
Joined:  2008-10-13
 

deleting pear.ini also worked for me
thanks guys!

 
Magento Community Magento Community
Magento Community
Magento Community
 
deasach
Jr. Member
 
Total Posts:  9
Joined:  2010-01-11
 

Worked for me too, it would be nice to why. Any ideas?

 
Magento Community Magento Community
Magento Community
Magento Community
 
WebhostUK LTD
Sr. Member
 
Avatar
Total Posts:  163
Joined:  2009-08-27
UK
 

Thank you to share just solved a customer issue.

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top