Posting in the Magento forums has been disabled pending the implementation of a new and improved forum solution which should better serve the community.

For new questions please post at magento.stackexchange.com, the community-run support site for the Magento community. We will be providing updates on the new forum solution soon. For questions or concerns please email community@magento.com.

Magento Forum

I am also having https:// problems
 
enofman
Jr. Member
 
Total Posts:  11
Joined:  2007-08-31
 

I am using Xampp with Apache 2.2.4; MySQL 5.0.45; PHP 5.2.3; PEAR, I have set the rewrite_mod, enable cyrpt, install a new version of php_pdo_mysql.dll. I can access the installation wizard, however after I put in the database name and make sure all the address are correct I press continue and go back to that scene and get the following error.  Url “https://localhost:443/magento/” is not accessible; I was understood the newest version of xampp comes with a temp ssl certificate.  I think the problem is in the htaccess file, but I am unable to figure it out.  I am running Win XP Pro on a local machine, so I can’t give an address to look at and I’m sorry about that, but any help would be much appreciated.

Thanks in advance,
enofman
Gary

 
Magento Community Magento Community
Magento Community
Magento Community
 
jacobsdad
Jr. Member
 
Total Posts:  1
Joined:  2007-09-01
 

Had the same problem with Xampp and windows.

Easiest way round it is, during the install, set the secure connection up with the same settings as the default store i.e. localhost, /magento/, http and port 80.

Then when it’s finished installing go to the backend and select Sytem > Configuration then Web(from the left hand menu). Find the Secure heading and change the protocol to HTTPS(SSL) and the port to 443. Then just click Save Config and try it out by adding something to your cart and going to checkout.

 
Magento Community Magento Community
Magento Community
Magento Community
 
Siddharth Menon
Jr. Member
 
Avatar
Total Posts:  20
Joined:  2007-08-31
Mumbai
 

Yes for secure hosting settings use the following

Protocol : http
Port : 80

Thats it wink . You cannot use https cert on local hosting.

 
Magento Community Magento Community
Magento Community
Magento Community
 
nod74
Member
 
Total Posts:  35
Joined:  2007-09-01
 

I have the same problem, but when i set it to http and port 80 in the secure connection i get this:

PDOException Object
(
[message:protected] => SQLSTATE[HY000]: General error: 2014 Cannot execute queries while other unbuffered queries are active.  Consider using PDOStatement::fetchAll().  Alternatively, if your code is only ever going to run against mysql, you may enable query buffering by setting the PDO::MYSQL_ATTR_USE_BUFFERED_QUERY attribute.
[string:private] => [code:protected] => HY000
[file:protected] => D:\xampplite\htdocs\magento\lib\Varien\Db\Adapter\Pdo\Mysql.php
[line:protected] => 82
[trace:private] => Array
(
[0] => Array
(
[file] => D:\xampplite\htdocs\magento\lib\Varien\Db\Adapter\Pdo\Mysql.php
[line] => 82
[function] => query
[class] => PDO
[type] => ->
[args] => Array
(
[0] =>—--------------------------------------------------------

--
-- Table structure for table `core_resource`
--

DROP TABLE IF EXISTS `core_resource`;
CREATE TABLE `core_resource` (
`code` varchar(50) NOT NULL default ‘’,
`version` varchar(50) NOT NULL default ‘’,
PRIMARY KEY (`code`)
) ENGINE=InnoDB DEFAULT CHARSET=utf8 COMMENT=’Resource version registry’;

)

)

[1] => Array
(
[file] => D:\xampplite\htdocs\magento\lib\Varien\Db\Adapter\Pdo\Mysql.php
[line] => 113
[function] => raw_query
[class] => Varien_Db_Adapter_Pdo_Mysql
[type] => ->
[args] => Array
(
[0] =>—--------------------------------------------------------

--
-- Table structure for table `core_resource`
--

DROP TABLE IF EXISTS `core_resource`;
CREATE TABLE `core_resource` (
`code` varchar(50) NOT NULL default ‘’,
`version` varchar(50) NOT NULL default ‘’,
PRIMARY KEY (`code`)
) ENGINE=InnoDB DEFAULT CHARSET=utf8 COMMENT=’Resource version registry’;

)

)

[2] => Array
(
[file] => D:\xampplite\htdocs\magento\app\code\core\Mage\Core\Model\Resource\Setup.php
[line] => 408
[function] => multi_query
[class] => Varien_Db_Adapter_Pdo_Mysql
[type] => ->
[args] => Array
(
[0] =>—--------------------------------------------------------

--
-- Table structure for table `core_resource`
--

DROP TABLE IF EXISTS `core_resource`;
CREATE TABLE `core_resource` (
`code` varchar(50) NOT NULL default ‘’,
`version` varchar(50) NOT NULL default ‘’,
PRIMARY KEY (`code`)
) ENGINE=InnoDB DEFAULT CHARSET=utf8 COMMENT=’Resource version registry’;

)

)

[3] => Array
(
[file] => D:\xampplite\htdocs\magento\app\code\core\Mage\Core\sql\core_setup\mysql4-install-0.6.0.php
[line] => 39
[function] => run
[class] => Mage_Core_Model_Resource_Setup
[type] => ->
[args] => Array
(
[0] =>—--------------------------------------------------------

--
-- Table structure for table `core_resource`
--

DROP TABLE IF EXISTS `core_resource`;
CREATE TABLE `core_resource` (
`code` varchar(50) NOT NULL default ‘’,
`version` varchar(50) NOT NULL default ‘’,
PRIMARY KEY (`code`)
) ENGINE=InnoDB DEFAULT CHARSET=utf8 COMMENT=’Resource version registry’;

)

)

[4] => Array
(
[file] => D:\xampplite\htdocs\magento\app\code\core\Mage\Core\Model\Resource\Setup.php
[line] => 223
[args] => Array
(
[0] => D:\xampplite\htdocs\magento\app\code\core\Mage\Core\sql\core_setup\mysql4-install-0.6.0.php
)

[function] => include
)

[5] => Array
(
[file] => D:\xampplite\htdocs\magento\app\code\core\Mage\Core\Model\Resource\Setup.php
[line] => 121
[function] => _modifyResourceDb
[class] => Mage_Core_Model_Resource_Setup
[type] => ->
[args] => Array
(
[0] => install
[1] => [2] => 0.6.5
)

)

[6] => Array
(
[file] => D:\xampplite\htdocs\magento\app\code\core\Mage\Core\Model\Resource\Setup.php
[line] => 108
[function] => _installResourceDb
[class] => Mage_Core_Model_Resource_Setup
[type] => ->
[args] => Array
(
[0] => 0.6.5
)

)

[7] => Array
(
[file] => D:\xampplite\htdocs\magento\app\code\core\Mage\Core\Model\Resource\Setup.php
[line] => 82
[function] => applyUpdates
[class] => Mage_Core_Model_Resource_Setup
[type] => ->
[args] => Array
(
)

 
Magento Community Magento Community
Magento Community
Magento Community
 
_
Sr. Member
 
Total Posts:  152
Joined:  2007-08-31
 

This error was discused in this topic: http://www.magentocommerce.com/boards/viewthread/51/

 
Magento Community Magento Community
Magento Community
Magento Community
 
nod74
Member
 
Total Posts:  35
Joined:  2007-09-01
 

thanks that helped

 
Magento Community Magento Community
Magento Community
Magento Community
 
enofman
Jr. Member
 
Total Posts:  11
Joined:  2007-08-31
 

Thanks for the help I figure it was something that was going to be hard to figure out.
This look GREAT

Thank Varien for Magento
enofman

 
Magento Community Magento Community
Magento Community
Magento Community
 
lovemagento_24h
Jr. Member
 
Avatar
Total Posts:  9
Joined:  2012-12-01
 

Thank you for your help!!!

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top