Posting in the Magento forums has been disabled pending the implementation of a new and improved forum solution which should better serve the community.

For new questions please post at magento.stackexchange.com, the community-run support site for the Magento community. We will be providing updates on the new forum solution soon. For questions or concerns please email community@magento.com.

Magento Forum

Page 1 of 2
Magento connect don’t detect upgrade
 
zmove
Guru
 
Total Posts:  317
Joined:  2008-04-30
 

Hello,

I’m on a fresh magento 1.4.1 install with some community extension like :

- Ahead work blog
- Easy tabs
- Easy lightbox
- ...

Several of these modules get updated since I installed it (for example I have ahead work blog 1.0.17 and now it’s 1.0.19). Easy lightbox is 1.0.1 now and I have 1.0…

When I go on magentoconnect and I click “Check for upgrade”, magento doesn’t detect any upgrade to do.

Somebody experience the same problem ? As it doesn’t detect several modules update, I supposed it was a magento problem and not extension problem…

Alex

 
Magento Community Magento Community
Magento Community
Magento Community
 
Jezza
Jr. Member
 
Total Posts:  2
Joined:  2008-05-29
 

Quite a few people seem to be running into this issue (http://www.magentocommerce.com/boards/viewthread/73424/), including myself, but there doesn’t seem to be any answer at the moment.

 
Magento Community Magento Community
Magento Community
Magento Community
 
zmove
Guru
 
Total Posts:  317
Joined:  2008-04-30
 

Ok, thank you for the reply. I noticed that you can upgrade the extension by choosing “reinstall” in the dropdown, but this is not a real fix…

 
Magento Community Magento Community
Magento Community
Magento Community
 
Jools
Sr. Member
 
Total Posts:  95
Joined:  2009-03-05
 

This problem with the magento community channel has been around since mid December 2009! It seems impossible to get the attention of anyone at Varien! I’m getting incredibly frustrated in the amount of time it takes for this to even get noticed.

I have opened a bug here (shame I made a small typo in the subject)

http://www.magentocommerce.com/bug-tracking/issue?issue=8521

I even blogged it here

http://maglife.co.uk

not to mention the other thread of course. It seems quite random as to which threads on the forum the magento team take notice of and which get ignored, the same with the bugtracker!

the problem is easy to reproduce from a fresh install too

tar xvzf magento-1.4.0.1.gz
cd magento

./pear mage-setup .

config-set etc etc

./pear install magento-community/B4Before_ProtxDirect
downloading B4Before_ProtxDirect
-1.3.2.21.tgz ...
Starting to download B4Before_ProtxDirect-1.3.2.21.tgz (28,166 bytes)
.........
done28,166 bytes
install ok
channel://connect.magentocommerce.com/community/B4Before_ProtxDirect-1.3.2.21

ok so latest version is 1.3.2.21let's remove it and add an older version.

./pear uninstall magento-community/B4Before_ProtxDirect
uninstall ok: channel://connect.magentocommerce.com/community/B4Before_ProtxDirect-1.3.2.21

./pear install magento-community/B4Before_ProtxDirect-1.3.2.18
downloading B4Before_ProtxDirect-1.3.2.18.tgz ...
Starting to download B4Before_ProtxDirect-1.3.2.18.tgz (28,040 bytes)
.........done: 28,040 bytes
install ok: channel://connect.magentocommerce.com/community/B4Before_ProtxDirect-1.3.2.18

so we should now have an upgrade available right ?

jools@travelmate:~/temp/magento$ ./pear list-upgrades
Channel connect.magentocommerce.com/community: No upgrades available

NOPE!

I get this on both 5.2.10-2ubuntu6.4 (ubuntu) and 5.2.6-1+lenny6 (debian)

Something must have happened to the channel data at some point that is causing a problem for pear, unless I have overlooked something, but it makes no sense to me.

PLEASE! someone at varien look into this. . If anyone knows another way to get their attention, please let me know!!

 
Magento Community Magento Community
Magento Community
Magento Community
 
tradiArt
Guru
 
Avatar
Total Posts:  379
Joined:  2008-04-28
 

Seems that we are not alone, we are having the same problem.

A solution has been provided to this? Thank you!

 
Magento Community Magento Community
Magento Community
Magento Community
 
cooldar
Sr. Member
 
Total Posts:  95
Joined:  2008-05-14
 

I have the same issue, even reinstall doesn’t seem to upgrade for me

 
Magento Community Magento Community
Magento Community
Magento Community
 
Onthedode
Member
 
Avatar
Total Posts:  44
Joined:  2009-06-04
Paris, France
 

Any news on this issue ?
I have the same problem with AW_Blog, BusinessDecision_Interaktingslider, Locale_Mage_community_fr_FR, and OpentapsIntegration for example. No problem for the core though. Reinstall works, but it’s only a workaround, and you’ll have to check manually for an update anyway.

Bye.

 
Magento Community Magento Community
Magento Community
Magento Community
 
Magento developer UA
Jr. Member
 
Avatar
Total Posts:  5
Joined:  2010-10-11
 

Have anyone found the solution yet?

 
Magento Community Magento Community
Magento Community
Magento Community
 
furnitureforyoultd
Enthusiast
 
Total Posts:  833
Joined:  2009-03-09
 

nothing yet, however the new magento connect manager does show updates. I tried downgrading to the 1.3.0 and 1.3.2.4 downloader and there was no change.

 
Magento Community Magento Community
Magento Community
Magento Community
 
Rhonda_Rondeau
Enthusiast
 
Total Posts:  924
Joined:  2010-08-03
Culver City
 

Hey guys, this is kind of an old thread..

Can you guys explain what’s going on?

What are you upgrading from/to?

I’m thinking this might not be the same issue as the original thread?

Rhonda

 
Magento Community Magento Community
Magento Community
Magento Community
 
furnitureforyoultd
Enthusiast
 
Total Posts:  833
Joined:  2009-03-09
 

the problem is Magento Connect doesn’t show community updates, even if you install the oldest version of an extension and click “check for updates” 2 seconds after installation completes. the only way to install updates is to input the key again and have the downloader install it for you.

core channel doesn’t have this problem and as I said neither does the new connect manager.

 
Magento Community Magento Community
Magento Community
Magento Community
 
Rhonda_Rondeau
Enthusiast
 
Total Posts:  924
Joined:  2010-08-03
Culver City
 

got it. Ok—I’ll see what I can find out.

 
Magento Community Magento Community
Magento Community
Magento Community
 
Rhonda_Rondeau
Enthusiast
 
Total Posts:  924
Joined:  2010-08-03
Culver City
 

Hi Guys,

I am sorry that I’m late and getting back to you, I try to keep up with everything but sometimes there are things that do slip.

I do see the problem and I tested and I don’t see any updates either. 

I’m assuming the expected behavior is that the line on the channel changes color to that pinkish color?

Rhonda

 
Magento Community Magento Community
Magento Community
Magento Community
 
Rhonda_Rondeau
Enthusiast
 
Total Posts:  924
Joined:  2010-08-03
Culver City
 

I’ve submitted a request to have this looked at. Thanks guys.

Rhonda

 
Magento Community Magento Community
Magento Community
Magento Community
 
tradiArt
Guru
 
Avatar
Total Posts:  379
Joined:  2008-04-28
 
rondata - 30 December 2010 08:35 AM

I’ve submitted a request to have this looked at. Thanks guys.

Rhonda

Thank you Rondata. We know Varien is listening grin

 
Magento Community Magento Community
Magento Community
Magento Community
 
Rhonda_Rondeau
Enthusiast
 
Total Posts:  924
Joined:  2010-08-03
Culver City
 

Sorry guys,

No update yet. I’ll check first thing Monday.. sorry for the delay.

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top
Page 1 of 2