Posting in the Magento forums has been disabled pending the implementation of a new and improved forum solution which should better serve the community.

For new questions please post at magento.stackexchange.com, the community-run support site for the Magento community. We will be providing updates on the new forum solution soon. For questions or concerns please email community@magento.com.

Magento Forum

Entire Product/Catalog pages not working
 
Artmart
Jr. Member
 
Avatar
Total Posts:  9
Joined:  2010-01-21
Australia
 

Hi all, does anyone else have this problem and/or solution?
I did a fresh install of magento 1.4.0.1 with sample data and it installed fine… no problems with the backend you can add products and all the functionality is there. I also installed my own custom theme and tweaked it to my liking, no problem.
The only problem that I have is that the Catalog/Product pages won’t show up or work…
when you click on the product links (except for the electronics link which is a block only page) an error message appears:

Warning: PDO::quote() expects parameter 1 to be string, object given in /home4/fitandse/public_html/lib/Zend/Db/Adapter/Pdo/Abstract.php on line 296

This has me stumped… any ideas?
The web address is http://www.fitandsexy.com.au
Please click on the ‘my body’ link and then try any of the links in the ‘Catalog’ dropdown to see the errors.

Any help would be appreciated. I have read and tried all the tricks in the forums.
Cheers.

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top