Posting in the Magento forums has been disabled pending the implementation of a new and improved forum solution which should better serve the community.

For new questions please post at magento.stackexchange.com, the community-run support site for the Magento community. We will be providing updates on the new forum solution soon. For questions or concerns please email community@magento.com.

Magento Forum

Page 1 of 4
Email - New Order Confirmation (Failure to Send Emails)
 
cssc
Jr. Member
 
Avatar
Total Posts:  7
Joined:  2008-04-24
 

I think I found a BUG.

I’ve seen a lot of discussion about this. Now. after testing different scenarios, I think I found a problem.

If I place anything in the “Send Order Email Copy To” field, NOTHING gets sent. I have tried a simple email address, and even tried having the addresss followed by a comma. Then I tried the email address preceded by a comma.  For me, I found the field MUST be blank, otherwise the customer will not receive the confirmation. (I guess PayPal can send me mine.)

I would like to use this feature if someone can tell me how, or perhaps fix what I feel may be a bug.

Thanks to all.

 
Magento Community Magento Community
Magento Community
Magento Community
 
leeaston
Sr. Member
 
Total Posts:  77
Joined:  2007-11-26
France
 
cssc - 10 May 2008 06:03 AM

For me, I found the field MUST be blank, otherwise the customer will not receive the confirmation. (I guess PayPal can send me mine.) I would like to use this feature if someone can tell me how, or perhaps fix what I feel may be a bug.

I’m having similar problems, except if I leave it blank or filled no order confirmation email is sent out.

There is a bug somewhere that’s for sure.

 
Magento Community Magento Community
Magento Community
Magento Community
 
yrick
Jr. Member
 
Total Posts:  14
Joined:  2008-03-19
Redding, CA
 

I haven’t found a fix. I would just like to know if the “order confirmation” email for store owner works at all?!
I always get customer order confirmation emails, but have never received store owner purchase confirmation emails.

Rick

 
Magento Community Magento Community
Magento Community
Magento Community
 
Mark Robinson
Member
 
Total Posts:  40
Joined:  2008-04-08
 

This isn’t working for me either. I’ve just updated to version 19700 to see if that would fix it and it hasn’t. So just to repeat my problem is I’m not getting order confirmation emails as defined in “Send Order Email Copy To” field

 
Magento Community Magento Community
Magento Community
Magento Community
 
jimmypalmer
Sr. Member
 
Total Posts:  79
Joined:  2008-05-04
 

It’s not working for me either.  Anyone found a fix yet?

 
Magento Community Magento Community
Magento Community
Magento Community
 
kenosis
Member
 
Total Posts:  45
Joined:  2008-03-14
 

Not working for me either in Mage 1.19700 - would really like to get this working.

Ken

 
Magento Community Magento Community
Magento Community
Magento Community
 
jimmypalmer
Sr. Member
 
Total Posts:  79
Joined:  2008-05-04
 

i’ve got a hack if you want it…

 
Magento Community Magento Community
Magento Community
Magento Community
 
kenosis
Member
 
Total Posts:  45
Joined:  2008-03-14
 

Yes please!  Will return the favor in kind, if at all possible.  You can email me directly at: or post here if you prefer.

 
Magento Community Magento Community
Magento Community
Magento Community
 
tradiArt
Guru
 
Avatar
Total Posts:  379
Joined:  2008-04-28
 

oh oh....

Each time I make a test order… no email is arriving!! Is this normal?

Your help is really appreciated in advance. Best regards.

 
Magento Community Magento Community
Magento Community
Magento Community
 
jimmypalmer
Sr. Member
 
Total Posts:  79
Joined:  2008-05-04
 

@kenosis - are you having trouble with the customer receiving an email? or the emails in the “Send Order Email Copy To” field?

 
Magento Community Magento Community
Magento Community
Magento Community
 
kenosis
Member
 
Total Posts:  45
Joined:  2008-03-14
 

Jimmy - any luck on posting your fix?  I think several of would be interested!!

Cheers,

Ken

 
Magento Community Magento Community
Magento Community
Magento Community
 
jimmypalmer
Sr. Member
 
Total Posts:  79
Joined:  2008-05-04
 

sure...here is what I use.  Keep in mind it is very “quick and dirty” and would be considered a big ol’ hardcoded hack.  Use at your own risk:

there is a method called sendNewOrderEmail() in the file called Order.php the class is called Mage_Sales_Model_Order found in app > code > core > Mage > Sales > Model > Order.php.  At the end of this function (right before the return) I just dropped the following code in to send a separate email to my distributors:

$mail = new Zend_Mail();
$mail->setBodyHtml("New Order “.$this->getShippingAddress()->format(’html’)."<br /><br />Shipping: “.$this->getShippingMethod()."<br /><br >”.$itemsBlock->toHtml());
$mail->setFrom("youremail@email.com")
->addTo("anotheremail@email.com")
->setSubject("Your Subject here");
$mail->send();

 
Magento Community Magento Community
Magento Community
Magento Community
 
kenosis
Member
 
Total Posts:  45
Joined:  2008-03-14
 

Thanks Jimmy - I get it.  Much appreciated.

Ken

 
Magento Community Magento Community
Magento Community
Magento Community
 
kenosis
Member
 
Total Posts:  45
Joined:  2008-03-14
 

Can one of the Mage core team gurus please weigh in on this and give a final conclusive answer?  I know there’s been a bug filed and fixed on this however it appears several of us are still suffering from this one.  Perhaps we need the latest greatest version?  If so, I’d like to know the issue is really resolved before doing that.

Ken

 
Magento Community Magento Community
Magento Community
Magento Community
 
tradiArt
Guru
 
Avatar
Total Posts:  379
Joined:  2008-04-28
 

I agree…

I have disabled spam assasin in my server, established english united states and no email is arriving.

Will be nice to hear if there is a solution to this.

Thank you very much!!

 
Magento Community Magento Community
Magento Community
Magento Community
 
Digiscape
Jr. Member
 
Total Posts:  1
Joined:  2008-01-13
 

On my setup customers still receive an email whether there is a copy email setup or not.

However for the first copy email address added it attempts to send it too >
Notice addition of > to the address

If you add 2 adresses to the copy email field (seperated by comma), the 2nd email address is sent correctly

Regards
Jason Turnbull

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top
Page 1 of 4