Posting in the Magento forums has been disabled pending the implementation of a new and improved forum solution which should better serve the community.

For new questions please post at magento.stackexchange.com, the community-run support site for the Magento community. We will be providing updates on the new forum solution soon. For questions or concerns please email community@magento.com.

Magento Forum

cron / mcrypt error
 
My2cents
Jr. Member
 
Total Posts:  30
Joined:  2009-03-11
 

can someone tell me what this cron error means and how to fix it…

Fatal error: Call to undefined function mcrypt_module_open() in /home/ez/public_html/lib/Varien/Crypt/Mcrypt.php on line 63

I am hosted at Simplehelix running a multi store on magento v1.4.1

I do have mcrypt running no my server..

Joe

 
Magento Community Magento Community
Magento Community
Magento Community
 
mancourt
Member
 
Avatar
Total Posts:  34
Joined:  2010-08-03
 

I am having this same issue. Any luck with this?

 
Magento Community Magento Community
Magento Community
Magento Community
 
My2cents
Jr. Member
 
Total Posts:  30
Joined:  2009-03-11
 

I did get past this… but i dont remember what the solution was… as I remember my issue was a conflict with an ext.

Sorry I cant be more help…

 
Magento Community Magento Community
Magento Community
Magento Community
 
mancourt
Member
 
Avatar
Total Posts:  34
Joined:  2010-08-03
 

Ya I checked with our host and they said it wasn’t an issue. Might have been an issue with the “Sweet Tooth” component…

 
Magento Community Magento Community
Magento Community
Magento Community
 
My2cents
Jr. Member
 
Total Posts:  30
Joined:  2009-03-11
 

what i would recommend is deactivate extensions until the problems goes away… I have 25+ extensions running… what i find is sometimes
extensions that are coded poorly will conflict is unforseen ways… that even the programmers who wrote the code can’t figure out....

I have this problem right now… I have two extensions that work great on the front end… but when they are both running they crash admin…

JOe

 
Magento Community Magento Community
Magento Community
Magento Community
 
junomedia
Sr. Member
 
Avatar
Total Posts:  142
Joined:  2008-09-10
Nottingham, England
 

Did you find out what caused this. I’ve just moved a site from one server to another and the error has started occurring.

Andy.

 
Magento Community Magento Community
Magento Community
Magento Community
 
My2cents
Jr. Member
 
Total Posts:  30
Joined:  2009-03-11
 

in my case as best as I can remember the issue was caused by a corrupted file in an extension

I just went back and looked at my service tickets… my problem was with AH’s HUD ext.  I had a corrupted file and the helpdesk wasn’t setup correctly..

I re-installed the ext. and followed the setup instructions to the letter ... the problem went away....

IN retrospect 18 + months later, I most likely would not have experienced the issue had there been a concise and clear set of installation and setup instructions…

What we have is non-english speaking programmers creating great add-ons… but unless you are a programmer or very experienced webmaster the likelihood of getting them to work to their maximum is slim… this is true of any ext. that does more then the most basic task…

I have many est. collecting virtual dust… because I can’t get the them work and support is non-existent… I even have a couple of extensions where support is good… but the techs don’t know how to fix there own mistakes…

What we need is a place to post extensions that don’t work, with a description of the issues encountered… and a place to tell others about sellers who are less the fair and honest.. or offer no support…

 
Magento Community Magento Community
Magento Community
Magento Community
 
outre99
Jr. Member
 
Total Posts:  16
Joined:  2009-06-28
 

Had the same issue.
After searching through all of the files that come with Magento i realized that mcrypt_module_open was not define anywhere, which would explain the error.
It’s actually defined in the php-mcrypt library, which should be installed on the server in order to work.  A quick look and phpinfo revealed that my server did not have mcrypt installed.  After installing php5-mcrypt and restarting Apache the error went away and everything is working.

 
Magento Community Magento Community
Magento Community
Magento Community
 
doughboy
Member
 
Total Posts:  55
Joined:  2010-03-29
 

I am having same problem However, I am running Centos 5.6 with Plesk.  Php 5.3.2 (installed by Plesk) and I can not get mcrypt installed.  Everytime I try to install php_mycryt I get error messages.  Basically it sais there are conflicts between php53-common and php53u-common

I dont’ want to break my plesk panel so i can’t just reinstall PHP.  I am wondering if php_mcrypt is install but just not enabled properly ???

Any ideas??

 
Magento Community Magento Community
Magento Community
Magento Community
 
tapion
Jr. Member
 
Total Posts:  1
Joined:  2012-08-13
 

This error is for not exists the extension mcrypt of PHP

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top