Posting in the Magento forums has been disabled pending the implementation of a new and improved forum solution which should better serve the community.

For new questions please post at magento.stackexchange.com, the community-run support site for the Magento community. We will be providing updates on the new forum solution soon. For questions or concerns please email community@magento.com.

Magento Forum

Cannot initialize ‘channel://connect.magentocommerce.com/XXXX - error
 
James B
Jr. Member
 
Total Posts:  19
Joined:  2007-11-13
 

I get this error every time I try to use Magento Connect:

Failed to download magento-core/Interface_Frontend_Default_Modern within preferred state “stable”, latest release is version 1.0.19702, stability “beta”, use “channel://connect.magentocommerce.com/core/Interface_Frontend_Default_Modern-1.0.19702” to install
Cannot initialize ‘channel://connect.magentocommerce.com/core/Interface_Frontend_Default_Modern’, invalid or missing package file
Install Errors
Package “channel://connect.magentocommerce.com/core/Interface_Frontend_Default_Modern” is not valid
PEAR ERROR: install failed

Any ideas?

 
Magento Community Magento Community
Magento Community
Magento Community
 
Sytou
Jr. Member
 
Total Posts:  1
Joined:  2008-05-08
 

I have the same problem.
I solve it : in your Magento Connect Manager (in your site) change in Settings Tab, Stable to Beta (depends on state for the extension you want download).
I hope this may help you.

 
Magento Community Magento Community
Magento Community
Magento Community
 
Justin Cook
Jr. Member
 
Total Posts:  19
Joined:  2008-05-08
Adelaide SA
 

I have the same problem. Have changed the tab to make sure release matches and still not working.

 
Magento Community Magento Community
Magento Community
Magento Community
 
Madin
Jr. Member
 
Total Posts:  9
Joined:  2008-08-01
Germany
 

Can’t someone give advice on this problem?
I’m unable to install magento-community/CashOnDelivery or BankPayment. PEAR is updated to the latest version and I also tried all 3 states: alpha, beta, stable.

No releases available for package "connect.magentocommerce.com/community/BankPayment"
Cannot initialize 'channel://connect.magentocommerce.com/community/BankPayment'invalid or missing package file
Install Errors
Package 
"channel://connect.magentocommerce.com/community/BankPayment" is not valid
PEAR ERROR
install failed

My Magento 1.1.1 is running on PHP Version 5.2.5 (Xamp/Windows)

 
Magento Community Magento Community
Magento Community
Magento Community
 
eitai2001
Guru
 
Total Posts:  330
Joined:  2008-05-14
Johannesburg, South Africa
 
Sytou - 09 May 2008 10:49 AM

I have the same problem.
I solve it : in your Magento Connect Manager (in your site) change in Settings Tab, Stable to Beta (depends on state for the extension you want download).
I hope this may help you.

Thank you a ton smile !!!!

 
Magento Community Magento Community
Magento Community
Magento Community
 
Politron
Jr. Member
 
Total Posts:  2
Joined:  2009-01-20
 
eitai2001 - 24 August 2008 10:42 AM

Sytou - 09 May 2008 10:49 AM
I have the same problem.
I solve it : in your Magento Connect Manager (in your site) change in Settings Tab, Stable to Beta (depends on state for the extension you want download).
I hope this may help you.

Thank you a ton smile !!!!

Works for me as well now. Greate idea! Thanks for help and post!

Cheers

 
Magento Community Magento Community
Magento Community
Magento Community
 
optical
Member
 
Total Posts:  35
Joined:  2009-08-06
 

I can’t seem to change the state to alpha.  It set it and it looks like it goes back to Stable.  Any suggestions?

 
Magento Community Magento Community
Magento Community
Magento Community
 
madone83
Jr. Member
 
Total Posts:  7
Joined:  2010-03-26
 
optical - 24 February 2010 02:50 AM

I can’t seem to change the state to alpha.  It set it and it looks like it goes back to Stable.  Any suggestions?

Anyon has a reply to post? Nobody solved it?

Still getting this error:

No releases for package "magento-community/RewardsPoint2" exist
Cannot initialize 
'channel://connect.magentocommerce.com/community/RewardsPoint2-0.5'invalid or missing package file
Install Errors
Package 
"channel://connect.magentocommerce.com/community/RewardsPoint2-0.5" is not valid
PEAR ERROR
install failed

Please help!!  snake

 
Magento Community Magento Community
Magento Community
Magento Community
 
Tom Coady
Member
 
Total Posts:  41
Joined:  2010-02-13
 

I have a similar error whether connect is set to beta or stable:

./pear upgrade-all
Error getting channel info from connect
.magentocommerce.com/communityInvalid xml downloaded from "http://connect.magentocommerce.com/community/Chiara_PEAR_Server_REST/p/packages.xml"XML Error'not well-formed (invalid token)' on line '129'
 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top