Posting in the Magento forums has been disabled pending the implementation of a new and improved forum solution which should better serve the community.

For new questions please post at magento.stackexchange.com, the community-run support site for the Magento community. We will be providing updates on the new forum solution soon. For questions or concerns please email community@magento.com.

Magento Forum

PayPal Express Checkout on 1.4.0.1
 
mtstover
Jr. Member
 
Total Posts:  26
Joined:  2009-07-02
 

Is there a way to disable paypal express with Paypal Pro?  They seem to get checked together and I cannot disable express—which makes 50% of my orders go haywire!

 
Magento Community Magento Community
Magento Community
Magento Community
 
maperdel
Jr. Member
 
Total Posts:  20
Joined:  2010-07-16
 

I applied the Iceberg Commerce solution and it worked just fine on version 1.4.1.1. I guess magento developers confuse the response parameter REDIRECTREQUIRED with SUCCESSPAGEREDIRECTREQUESTED (based on the code comments).

I read on some guy’s blog that the paypal support staff told him the SUCCESSPAGEREDIRECTREQUESTED parameters has no use these days. Well,in my opnion, the paypal developers should return false for this parameter if it is not longer used.

On the other hand, the billing address in magento is not displayed correctly for the credit card payment through paypal express checkout. Anyone has a workaround for this issue?

 
Magento Community Magento Community
Magento Community
Magento Community
 
Track 23
Member
 
Total Posts:  50
Joined:  2008-03-19
 
mtstover - 06 October 2010 01:25 PM

Is there a way to disable paypal express with Paypal Pro?  They seem to get checked together and I cannot disable express—which makes 50% of my orders go haywire!

I’m also wondering this. I don’t want to use PayPal Express, but it won’t let me disable it when I’m using PayPal Pro. Very frustrating!

 
Magento Community Magento Community
Magento Community
Magento Community
 
Track 23
Member
 
Total Posts:  50
Joined:  2008-03-19
 

Well, I figured out a hack (in regards to above post)! I managed to disable PayPal Express by using Safari’s Inspect Element developer tool and temporarily deleting the disabled designation from the PayPal Express checkbox tag. Then I was able to uncheck the box and save my configuration. When the page reloads the box is checked and disabled again, but when I go to the front end to check out - voila - PayPal Express is gone! I just need to remember to do that every time I make any changes to the PayPal configuration.

I’m sure there’s a better way, but this works for me! Oh, and you could probably just as easily do it with Firebug in Firefox.

 
Magento Community Magento Community
Magento Community
Magento Community
 
amstar
Jr. Member
 
Total Posts:  2
Joined:  2009-06-30
 

YOU BEAUTY

PERFECT SOLUTION
smile:):):):):)

 
Magento Community Magento Community
Magento Community
Magento Community
 
fastrack
Member
 
Total Posts:  56
Joined:  2009-02-04
 

thanks for the quick disable solution. I was looking for that too. keep in mind, however, according to the paypal TOS, if you disable express and only use WPP, they can charge you another 1% per transaction.

 
Magento Community Magento Community
Magento Community
Magento Community
 
rossko
Jr. Member
 
Total Posts:  5
Joined:  2010-05-05
 

i\’m confused… it appears paypal express checkout is working fine out of the box on 1.4.0.1

what am i doing wrong?

 
Magento Community Magento Community
Magento Community
Magento Community
 
fastrack
Member
 
Total Posts:  56
Joined:  2009-02-04
 

interested in disabling express checkout?
comment out this line of code in /adminhtml/default/default/template/paypal/system/config/fieldset/global.phtml
for me it\’s line 101.

//  ec: $H({switcher: \'express\', fieldset: \'express\'}),

then you can disable in admin.

 
Magento Community Magento Community
Magento Community
Magento Community
 
IWDAgency
Member
 
Avatar
Total Posts:  73
Joined:  2010-11-16
Baton Rouge, Louisiana
 

I don’t seems to have problem using paypal its because I’m not using paypal premium or express.. I got personal paypal account only I don’t know if that matters anyways but kindly check this links Express Check Out and Paypal Express Check Out Introduction they might be useful informations for this issue.

 
Magento Community Magento Community
Magento Community
Magento Community
 
Neovidere
Jr. Member
 
Total Posts:  17
Joined:  2010-09-16
 

@fasttrack

Any idea where to do this in 1.4.2?

I found the file you altered in

/ app / code / core / Mage / Paypal / Block / Adminhtml / System / Config / Fieldset / Global.php

but that line isn’t in there.

 
Magento Community Magento Community
Magento Community
Magento Community
 
airsoftsupplydrop
Jr. Member
 
Total Posts:  4
Joined:  2009-01-16
 

Does anyone now if it’s possible to enable PayPal Website Payments Standard along side Website Payments Pro Pay flow.

As when you select Website Payments Pro it blank out Website Payments Standard.

As I don’t won’t the express checkout the way magneto has it setup. But still wont to be able to offer PayPal as a payment option.

 
Magento Community Magento Community
Magento Community
Magento Community
 
robsonuk
Jr. Member
 
Total Posts:  12
Joined:  2010-05-03
 
fastrack - 16 November 2010 04:39 PM

interested in disabling express checkout?
comment out this line of code in /adminhtml/default/default/template/paypal/system/config/fieldset/global.phtml
for me it\’s line 101.

//  ec: $H({switcher: \'express\', fieldset: \'express\'}),

then you can disable in admin.

Worked perfectly. Thank you!

 
Magento Community Magento Community
Magento Community
Magento Community
 
grazzt
Sr. Member
 
Total Posts:  106
Joined:  2010-02-28
 

Iceberg’s solution worked for me. Thanks!

 
Magento Community Magento Community
Magento Community
Magento Community
 
Nofosg8
Sr. Member
 
Total Posts:  93
Joined:  2008-10-26
 

Any fix for 1.4.2 ??? tried everything that is posted here and nothing works..... I have had 32 customers e-mail me in the past few weeks with this issue many of them are recurring customers and they aren’t too happy.... Hopefully they will come back again.....

 
Magento Community Magento Community
Magento Community
Magento Community
 
grazzt
Sr. Member
 
Total Posts:  106
Joined:  2010-02-28
 

I have version 1.4.2 and following this solution fixed the problem. Maybe you should try after applying that solution to go to paypal configuration and
1) empty all fields,
2) save configuration
3) refresh cache
4) fill in your paypal email address in paypal configuration
5) save configuration
6) fill the rest paypal configuration fields
7) save configuration
8) refresh cache
That\’s what I did exactly and it worked.

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top