Magento Forum

   
Probleme Update auf 1.0.19870
 
millejano
Member
 
Avatar
Total Posts:  40
Joined:  2007-09-18
 

Also beim Update von 1.0.19700 (inkl. Patch) auf 1.0.19870 über Magento Connect hatte ich folgende einige Probleme:

Beim Update von Mage_All_Latest gab es folgende Fehlermeldung( domainnamen durch domain.tld ersetzt!):

permission denied (delete): /var/www/vhosts/domain.tld/httpdocs/app/code/core/Mage/Catalog/controllers/Product/CompareController.php
ERROR: commit failed

Resultat war alles war auf dem neusten Stand außer: Mage_Core_Modules

Datei gesucht, chmod 777 angewandt (hatte bei anderen Probleme mit Magento Connect bei mir bereits schon geholfen)

Also nochmal Mage_Core_Modules updaten, ging jedoch nicht, folgende Fehlermeldung:
. magento-core/interface_frontend_default_modern requires package “magento-core/Mage_Core_Modules” (version >= 1.0.19700, version <= 1.0.19700), downloaded version is 1.0.19870
magento-core/Mage_Core_Modules cannot be installed, conflicts with installed packages
Install Errors
No valid packages found
PEAR ERROR: upgrade failed

Okay, Dateien-Backup eingespielt um danach erstmal die Mage_Core_Modules updaten, danach den Rest.
Nun komme ich nicht mehr auf Magento Connect:

Fatal error: main() [function.require]: Failed opening required ‘/var/www/vhosts/domain.tld/httpdocs/downloader/pearlib/php/PEAR.php’ (include_path=’/var/www/vhosts/domain.tld/httpdocs/downloader/pearlib/php:/var/www/vhosts/domain.tld/httpdocs/app/code/local:/var/www/vhosts/domain.tld/httpdocs/app/code/community:/var/www/vhosts/domain.tld/httpdocs/app/code/core:/var/www/vhosts/domain.tld/httpdocs/lib:.:’) in /var/www/vhosts/domain.tld/httpdocs/lib/Varien/Pear.php on line 265

Persmission soviel wie ich sehe sind gleich, da ja nur kopiert per ssh in einen anderen Ordner.
Nach einigen erfolglosen Test einfach chmod -R 777 auf den downloader-Ordner .

Magento Connet geht wieder, Login ist möglich.
Beim Versuch Mage_Core_Modules updaten, folgende Meldung:

magento-core/interface_frontend_default_modern requires package “magento-core/Mage_Core_Modules” (version >= 1.0.19700, version <= 1.0.19700), downloaded version is 1.0.19870
magento-core/interface_install_default requires package “magento-core/Mage_Core_Modules” (version >= 1.0.19700, version <= 1.0.19700), downloaded version is 1.0.19870
magento-core/mage_core_adminhtml requires package “magento-core/Mage_Core_Modules” (version >= 1.0.19700, version <= 1.0.19700), downloaded version is 1.0.19870
magento-core/mage_all_latest requires package “magento-core/Mage_Core_Modules” (version >= 1.0.19700, version <= 1.0.19700), downloaded version is 1.0.19870
magento-core/interface_frontend_default requires package “magento-core/Mage_Core_Modules” (version >= 1.0.19700, version <= 1.0.19700), downloaded version is 1.0.19870
magento-core/Mage_Core_Modules cannot be installed, conflicts with installed packages
Install Errors
No valid packages found
PEAR ERROR: upgrade failed

Und jetzt bin ich mir nicht mehr genau sicher: Ich glaube ich hab Interface_Frontend_Default_Modern updatet und danach war auch Mage_Core_Modules auf dem neusten Stand und ich musste nur noch den Rest nachziehen.

Kann mir mal jemand erklären wieso das das Update der Core Dateienen nicht möglich war - sieht nach einem Fehler im Updatesystem aus.

bye, mille

 
Magento Community Magento Community
Magento Community
Magento Community
 
novalis
Moderator
 
Avatar
Total Posts:  266
Joined:  2007-10-13
Berlin, Germany
 

Hi mille,

ich hatte ein ähnliches Problem. Du kannst ohne Probleme ein Update über MagentoConnect durchführen, darfst aber nicht “alle Pakete” aktualisieren, sondern nur “Mage_All_irgendwas"… also dieses Metapaket. Damit lief es bei mir wunderbar durch.

Gruß,
Nov

 
Magento Community Magento Community
Magento Community
Magento Community
 
millejano
Member
 
Avatar
Total Posts:  40
Joined:  2007-09-18
 

Danke novalis, werde ich nochmal beim nächsten Update testen.

bye, mille

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
    Back to top