Posting in the Magento forums has been disabled pending the implementation of a new and improved forum solution which should better serve the community.

For new questions please post at magento.stackexchange.com, the community-run support site for the Magento community. We will be providing updates on the new forum solution soon. For questions or concerns please email community@magento.com.

Magento Forum

Page 1 of 2
pdo_mysql .htaccess ? 
 
PremiumProductions
Jr. Member
 
Total Posts:  22
Joined:  2008-04-23
 

I am having trouble gettins Magento installed.
I have had my host change me from a PHP4 to PHP5 server
But I am still unable to get past the pdo_mysql must be loaded error on running the install.
I asked my host about pdo_Mysql, and they said:-
“You can change apache handlers via .htaccess to allow other extensions to work as PHP script\”

Frankly i don’t know how to do that. (i am a noob)
I have searched the forums and seem to be going around and around.

Can somebody give me a step by step guide please?

Thank You smile
Paul.

 
Magento Community Magento Community
Magento Community
Magento Community
 
PremiumProductions
Jr. Member
 
Total Posts:  22
Joined:  2008-04-23
 

Anybody?
Please?

 
Magento Community Magento Community
Magento Community
Magento Community
 
Moshe
Magento Team
 
Avatar
Total Posts:  1770
Joined:  2007-08-07
Los Angeles
 

Try this tutorial: http://www.magentocommerce.com/knowledge-base/entry/installing-magento-on-a-php4-server

 
Magento Community Magento Community
Magento Community
Magento Community
 
Crucial
Enthusiast
 
Avatar
Total Posts:  770
Joined:  2007-11-07
Phoenix, AZ
 
PremiumProductions - 08 May 2008 06:40 PM

I asked my host about pdo_Mysql, and they said:-
“You can change apache handlers via .htaccess to allow other extensions to work as PHP script\”

What they told you doesn’t make sense. PDO_MYSQL has nothing to do with Apache handlers. They need to install the PDO and PDO_MYSQL extensions for PHP, something that requires root access to the server.

 
Magento Community Magento Community
Magento Community
Magento Community
 
Moshe
Magento Team
 
Avatar
Total Posts:  1770
Joined:  2007-08-07
Los Angeles
 

@Crucial: my translation of hosting’s response was:

“We’re not going to add pdo_mysql to our PHP installation, so you might as well set up handlers in your .htaccess to use your own PHP binary with compiled extensions, including pdo_mysql”

That’s why I gave the CGI tutorial smile

 
Magento Community Magento Community
Magento Community
Magento Community
 
Crucial
Enthusiast
 
Avatar
Total Posts:  770
Joined:  2007-11-07
Phoenix, AZ
 

Heh, I was wondering what you linked to the CGI stuff. Now that I read it again, that would make sense. Could have been worded better on their part though. Do let us know if that worked for you, PremiumProductions.

 
Magento Community Magento Community
Magento Community
Magento Community
 
PremiumProductions
Jr. Member
 
Total Posts:  22
Joined:  2008-04-23
 

Thanks for your help guys.
I have now tried the the CGI method.
(Just so i understand...i assume the download of php5-cgi includes the pdo-Mysql setup.  Is that correct?)
Now when i go to my site, it comes up with “500 Internal Server Error”
I believe I followed it closely, but obviously i missed something.

Any ideas?

Thank you.

 
Magento Community Magento Community
Magento Community
Magento Community
 
JLHC
Mentor
 
Avatar
Total Posts:  1287
Joined:  2008-05-09
Tampa, FL
 

What is your site (with magento installed and also the problems occurred)?

 
Magento Community Magento Community
Magento Community
Magento Community
 
PremiumProductions
Jr. Member
 
Total Posts:  22
Joined:  2008-04-23
 

Hi and thanks.
My website in question is http://www.SurvivalZone.com.au
It is hosted at http://www.h2hosting.com
Now when i go to my site, it comes up with “500 Internal Server Error”

 
Magento Community Magento Community
Magento Community
Magento Community
 
PremiumProductions
Jr. Member
 
Total Posts:  22
Joined:  2008-04-23
 

Any chance of some help here?
Please?
I hate to say it, but i thinking about using zen cart or os commerce or something if i can’t get this sorted.

 
Magento Community Magento Community
Magento Community
Magento Community
 
robcs
Jr. Member
 
Total Posts:  24
Joined:  2008-05-23
 

Copy libmysql.dll to c:\windows\system32\ and you’re done!

smile

 
Magento Community Magento Community
Magento Community
Magento Community
 
robcs
Jr. Member
 
Total Posts:  24
Joined:  2008-05-23
 

Wow… sorry I misread the post!

The error #500 usually is the .htaccess file misconfigured ... rename the file and test.

 
Magento Community Magento Community
Magento Community
Magento Community
 
PremiumProductions
Jr. Member
 
Total Posts:  22
Joined:  2008-04-23
 

Thank you for the help.
I will try looking at that.

 
Magento Community Magento Community
Magento Community
Magento Community
 
Crucial
Enthusiast
 
Avatar
Total Posts:  770
Joined:  2007-11-07
Phoenix, AZ
 

If you’re on a environment where PHP runs through CGI, then you do need to edit the .htaccess file and also remove some things. Change the following:

############################################ 
## uncomment these lines for CGI mode 
## make sure to specify the correct cgi php binary file name 
## it might be /cgi-bin/php-cgi 

#Action php5-cgi /cgi-bin/php5-cgi 
#AddHandler php5-cgi .php

To this instead:

############################################ 
## uncomment these lines for CGI mode 
## make sure to specify the correct cgi php binary file name 
## it might be /cgi-bin/php-cgi 

Action php5-cgi /cgi-bin/php5-cgi 
AddHandler php5
-cgi .php

If you’re still receiving a 500 error, then first try changing /cgi-bin/php5-cgi to /cgi-bin/php-cgi and see if that works (or ask your host what path to use, though the default path should work). If you’re still getting an error, try removing AddHandler php5-cgi .php.

 
Magento Community Magento Community
Magento Community
Magento Community
 
PremiumProductions
Jr. Member
 
Total Posts:  22
Joined:  2008-04-23
 
Crucial - 25 May 2008 07:57 PM

If you’re on a environment where PHP runs through CGI, then you do need to edit the .htaccess file and also remove some things. Change the following:

############################################ 
## uncomment these lines for CGI mode 
## make sure to specify the correct cgi php binary file name 
## it might be /cgi-bin/php-cgi 

#Action php5-cgi /cgi-bin/php5-cgi 
#AddHandler php5-cgi .php

To this instead:

############################################ 
## uncomment these lines for CGI mode 
## make sure to specify the correct cgi php binary file name 
## it might be /cgi-bin/php-cgi 

Action php5-cgi /cgi-bin/php5-cgi 
AddHandler php5
-cgi .php

If you’re still receiving a 500 error, then first try changing /cgi-bin/php5-cgi to /cgi-bin/php-cgi and see if that works (or ask your host what path to use, though the default path should work). If you’re still getting an error, try removing AddHandler php5-cgi .php.

Thank you for your assistance. smile
I have unremarked the above lines. No good. It just produces 500 error.

I believe i have confirmed the path to the cgi-bin directory is correct.
and i have confirmed the file name is php5-cgi
If i remark out the add handler line it comes back with the” pdo_mysql must be loaded” error

Any other ideas for me?

Once again ....thank you for trying...I appreciate it smile

 
Magento Community Magento Community
Magento Community
Magento Community
 
Moshe
Magento Team
 
Avatar
Total Posts:  1770
Joined:  2007-08-07
Los Angeles
 

@PremiumProductions: could you try setting Magento folder to permission 755 and index.php to 644 ?

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top
Page 1 of 2