Posting in the Magento forums has been disabled pending the implementation of a new and improved forum solution which should better serve the community.

For new questions please post at magento.stackexchange.com, the community-run support site for the Magento community. We will be providing updates on the new forum solution soon. For questions or concerns please email community@magento.com.

Magento Forum

404 not found on all pages except home page
 
bloggleme
Sr. Member
 
Avatar
Total Posts:  101
Joined:  2008-05-06
 

I have looked all over the forums, seen all of the similar situations, and none of the solutions have worked for me. We are currently using Mosso for hosting our server, and we have PHP 5.2 installed and mod rewrite enabled on our linux server. Now, with url rewrites enabled, pages are 404 not found. With it disabled, I have /index.php/ in the url - which sucks for SEO. Any suggestions? I have done all of the chmod commands correctly :(

Error Message when I try to go to /magento/customers/account

The requested URL /mnt/target03/354761/327600/www.mysite.com/web/content/magento/index.php was not found on this server.

I have not modified the htaccess file at all.

I am running PHP 5.2 on my server. I have Magento installed at http://www.mydomain.com/Magento and my CGI bin is at http://www.mydomain.com/cgi-bin/php5-cgi

I get an object not found error when trying to go to that directory. Within my host, my web root is located at: /www.mydomain.com/web/content/
CGI bin is located at: /www.mydomain.com/web/cgi-bin/

Thanks ahead of time.

 
Magento Community Magento Community
Magento Community
Magento Community
 
bloggleme
Sr. Member
 
Avatar
Total Posts:  101
Joined:  2008-05-06
 

Problem solved: I went looking through my htaccess file and saw this line: #RewriteBase /magento/ - I noticed it was commented out and tried uncommenting it. Now it works.

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top