Posting in the Magento forums has been disabled pending the implementation of a new and improved forum solution which should better serve the community.

For new questions please post at magento.stackexchange.com, the community-run support site for the Magento community. We will be providing updates on the new forum solution soon. For questions or concerns please email community@magento.com.

Magento Forum

Magento und PayPal IPN
 
schaumee
Jr. Member
 
Total Posts:  1
Joined:  2013-10-09
 

Hallo zusammen,

[Magento Version 1.8.0.0]

ich werde hier noch verrückt… Ich habe ein Problem mit der Paypal Integration in meinen Shop.

Die Zahlungen funktionieren reibungslos und die Bestellungen werden auch alle angezeigt. Die Paypal Einstellungen im Backend sind bei PayPal Website Payments Standard:

Zahlungsvorgang: Verkauf
Zahlung möglich von: Alle erlaubten Länder
Sandbox Modus: nein
Artikel des Warenkorbs übertragen: ja
Debug Modus: ja
SSL-Prüfung aktivieren: ja (SSL Zertifikat vorhanden und aktiviert)

Bei Paypal entsprechend habe ich auch IPN aktiviert auf die URL https://meinshop.de/paypal/ipn (ist auch erreichbar das habe ich gecheckt.)

Nun zu meinem Problem: Der Status der Bestellung wird nicht geupdatet.

Ich habe schon in einigen Foren verschiedenste Dinge probiert zuletzt auch das http://www.dhmedia.com.au/article/debugging-paypal-ipn-postback-failures-magento

Jedoch ohne Erfolg. Dank dem Debug Modus kann ich sagen, dass ich eine IPN bekomme. Diese wir mit postback an die richtige Adresse weitergegeben, jedoch bekomme ich ein leeres postback_result

[postback_result] => 
    
[exception] => PayPal IPN postback failureSee paypal_unknown_ipn.log for details.

Wenn ich jedoch die Seite von Hand aufrufe, das heißt https://www.paypal.com/cgi-bin/webscr mit dem entsprechenden postback als string steht in meinem Fenster im Browser VERIFIED.

Warum kommt das VERIFIED nicht bei Magento an?

Vielen Dank für eure Hilfe

 
Magento Community Magento Community
Magento Community
Magento Community
 
erikm
Jr. Member
 
Total Posts:  10
Joined:  2011-02-02
 

Hallo, habe das gleiche Problem - wie hast du es behoben?

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top