Posting in the Magento forums has been disabled pending the implementation of a new and improved forum solution which should better serve the community.

For new questions please post at magento.stackexchange.com, the community-run support site for the Magento community. We will be providing updates on the new forum solution soon. For questions or concerns please email community@magento.com.

Magento Forum

security header is not valid
 
bzsaw
Sr. Member
 
Avatar
Total Posts:  141
Joined:  2008-02-13
 

How do I go about fixing this? I have SSL setup and active.

Thanks,

Image Attachments
Picture 5.png
 
Magento Community Magento Community
Magento Community
Magento Community
 
bzsaw
Sr. Member
 
Avatar
Total Posts:  141
Joined:  2008-02-13
 

∆ BUMP

Can anyone help please?

Thanks,

 
Magento Community Magento Community
Magento Community
Magento Community
 
Moshe
Magento Team
 
Avatar
Total Posts:  1770
Joined:  2007-08-07
Los Angeles
 

@tparsons: Do you have any working secure page on this domain?

create test.php inside magento folder and try accessing it.
If does’t work, probably .htaccess. rename or remove .htaccess and try again.
if still doesn’t work, it is web server configuration problem.

 
Magento Community Magento Community
Magento Community
Magento Community
 
bzsaw
Sr. Member
 
Avatar
Total Posts:  141
Joined:  2008-02-13
 

Hi Moshe,

Thanks for helping.... here is the current running store with SSL working

http://tinyurl.com/6278rm

I’ll try the test.php file in a little bit.

Thanks,

 
Magento Community Magento Community
Magento Community
Magento Community
 
bzsaw
Sr. Member
 
Avatar
Total Posts:  141
Joined:  2008-02-13
 

In my Magento /dev folder

http://tinyurl.com/6rsebz

test.php works perfectly.

Do you have any other idea of what could be causing this? It only happens at the last step of checking out.

Thanks,

 
Magento Community Magento Community
Magento Community
Magento Community
 
bzsaw
Sr. Member
 
Avatar
Total Posts:  141
Joined:  2008-02-13
 

∆ BUMP

HELP… this the only thing holding me up of going live.

I can’t seem to figure it out.

Thanks,

 
Magento Community Magento Community
Magento Community
Magento Community
 
bzsaw
Sr. Member
 
Avatar
Total Posts:  141
Joined:  2008-02-13
 

Figured it out. I had to do with the permissions set at PAYPAL for the system to use the API.

Thanks,

 
Magento Community Magento Community
Magento Community
Magento Community
 
TrendyPet
Jr. Member
 
Total Posts:  1
Joined:  2008-05-08
 

I am having a similar problem, I am curious as to what you changed regarding the permissions on PAYPAL for the system to use the API?

 
Magento Community Magento Community
Magento Community
Magento Community
 
biscuitstudios
Jr. Member
 
Total Posts:  3
Joined:  2007-11-05
 

i was having the same header errors on my 1.1.3 install… struggled forever with it and this is finally what worked.

in magento admin:

1. added in all the correct “developer” paypal API information
2. set sandbox to yes
3. set debug to yes
4. set the paypal URL to https://www.paypal.com/cgi-bin/webscr?cmd=_express-checkout&commit;=&token;=

these steps got website payments pro to work when submitting a credit card for testing purposes (site is not live).

unfortunately, paypal express still does not work… i get an error message once the page makes it over to paypal… where it states the transaction is invalid.

any thoughts on getting paypal express to work?

 
Magento Community Magento Community
Magento Community
Magento Community
 
Alex M
Jr. Member
 
Total Posts:  2
Joined:  2008-10-21
 

I get the same error with v1.1.6, both when testing the Paypal button, and when going through the magento checkout process and clicking “Place Order.” I have sandbox set to yes, and debug set to yes. When I turned them both off, the error went away, and it let me make the purchase. However, it redirected me to the magento 404 page, never sending me to paypal at all. I do not have a security certificate, is that my problem? I’d really like to know everything works right before I decide to go get a security cert. Any ideas?

 
Magento Community Magento Community
Magento Community
Magento Community
 
itchytrig
Sr. Member
 
Avatar
Total Posts:  162
Joined:  2008-10-03
UK
 

Hi,

Was this resolved at all?

Getting same problems!

thanks in advance…

 
Magento Community Magento Community
Magento Community
Magento Community
 
Pankaj Gupta
Jr. Member
 
Total Posts:  10
Joined:  2008-11-29
 

Hi!

I was facing the same issue. Now solved smile

Check these properly.They should not contain spaces and to be correct exactly.

API User Name
API Password
API Signature
Page Style = blank
Proxy Host = blank
Proxy Port = blank
Sandbox Flag = yes
Debug Flag = NO
Use Proxy = NO

Paypal URL = https://www.sandbox.paypal.com/webscr&cmd;=_express-checkout&token;=

 
Magento Community Magento Community
Magento Community
Magento Community
 
lukemcr
Jr. Member
 
Avatar
Total Posts:  15
Joined:  2008-08-18
 

Another thing that may help is making sure you set the PayPal information for the Default Store Configuration as well as for your main site. Setting it for the site but not as the default didn’t work for me.

 
Magento Community Magento Community
Magento Community
Magento Community
 
perfectshape
Jr. Member
 
Total Posts:  13
Joined:  2010-02-25
 
lukemcr - 02 March 2010 09:36 AM

Another thing that may help is making sure you set the PayPal information for the Default
Store Configuration as well as for your main site. Setting it for the site but not as the default didn’t work for me.

Luke I wanted to say thanks as this solved my problem and may help someone else to know it.

We had a similar error - Paypal error 10002 talking about security headers.

We had been live for a few weeks with our English website and I started setting up another website (domain) which is a French site using a different paypal email address.

Even though the default settings were not changed, this somehow broke the English site’s setup and thankfully a few dedicated customers who are users of paypal informed us.

To fix it I setup again at the English site at website level (rather than using default) and re-entered API codes, then at the English store level used the site defaults. The error has gone now.

It seemed for some reason the old settings were not being picked up generating the error.

Cheers,

Dave

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top