Posting in the Magento forums has been disabled pending the implementation of a new and improved forum solution which should better serve the community.

For new questions please post at magento.stackexchange.com, the community-run support site for the Magento community. We will be providing updates on the new forum solution soon. For questions or concerns please email community@magento.com.

Magento Forum

Page 2 of 3
1.4.0.0 (fresh install) upgrade problems to 1.4.0.1
 
Martin
Guru
 
Avatar
Total Posts:  445
Joined:  2007-08-31
Brno | London | Los Angeles
 

Or - you can do something else - backup current Magento directory, than delete all files except:

/app/etc/local.xml

download and untar fresh Magento 1.4.0.1 and restore your template and custom modules.

That should probably work - and if no, than just downgrade back to 1.3.2.4 ...

 
Magento Community Magento Community
Magento Community
Magento Community
 
Jonathan123
Sr. Member
 
Total Posts:  215
Joined:  2008-09-14
 

Same problem here…

Starting to download Mage_Core_Modules-1.4.0.1.tgz (1,773,350 bytes)
...
done1,773,350 bytes
Could not get contents of package 
"/home/store1/public_html/downloader/pearlib/download/Mage_Core_Modules-1.4.0.1.tgz"Invalid tgz file.
Download of "magento-core/mage_core_modules" succeededbut it is not a valid package archive
Error
cannot download "magento-core/Mage_Core_Modules"

Tried deleting pear’s cache, and tried the Tar.php hack/patch, still not working.

 
Magento Community Magento Community
Magento Community
Magento Community
 
Jonathan123
Sr. Member
 
Total Posts:  215
Joined:  2008-09-14
 

Ok, I got it to work. Please note, this is a complete hack, and as such use this with care, it’s probably not safe, etc. etc.

Open /downloader/pearlib/php/Archive/Tar.php , line 243

change:

if (!$this->_extractList(''$v_list_detail"list"'''')) {
                
unset($v_list_detail);
                
$v_list_detail 0;
            
}

to

$this->_extractList(''$v_list_detail"list"'''');
/*
        if (!$this->_extractList('', $v_list_detail, "list", '', '')) {
                unset($v_list_detail);
                $v_list_detail = 0;
            }
*/
 
Magento Community Magento Community
Magento Community
Magento Community
 
mpoulieris
Jr. Member
 
Total Posts:  11
Joined:  2010-02-14
drama
 

this 1.4.0.1 have many bugs finally,i cant log in in the admin area,i am gettinf the following error : Fatal error: Call to undefined method Mage_Admin_Model_Observer::actionPostDispatchAdmin() in /home/**********/public_html/app/code/core/Mage/Core/Model/App.php on line 1207 .
i dont know how i can fix it this,i have SSH access but i dont know how this can use it,can anyone tell me whta i must do so i can log in the admin area?
thanks

 
Magento Community Magento Community
Magento Community
Magento Community
 
J-Mod
Jr. Member
 
Avatar
Total Posts:  11
Joined:  2009-12-28
 

double post ... sorry!

 
Magento Community Magento Community
Magento Community
Magento Community
 
J-Mod
Jr. Member
 
Avatar
Total Posts:  11
Joined:  2009-12-28
 

First, download the magento 1.4.0.1 package to your computer. Next, on your server, remove the /magento/downloader directory and the /magento/pear file. Then, from the 1.4.0.1 package you downloaded to your computer, upload the /magento/downloader directory and /magento/pear file to your server.

Next, using SSH, navigate to the /magento directory (or whatever directory that your magento store is located) ... and issue the following commands ...

./pear mage-setup .
./
pear install magento-core/Mage_All_Latest

rm 
-rf downloader/pearlib/cache/* downloader/pearlib/download/*//tempend ?>

Notice the ‘.’ after the

./pear mage-setup .
command ... be sure to include the period when issuing the command!

All should work fine after you do this.

 
Magento Community Magento Community
Magento Community
Magento Community
 
mpoulieris
Jr. Member
 
Total Posts:  11
Joined:  2010-02-14
drama
 

can i use the magento connector for upgrade or i must do it via SSH?
thanks

 
Magento Community Magento Community
Magento Community
Magento Community
 
J-Mod
Jr. Member
 
Avatar
Total Posts:  11
Joined:  2009-12-28
 
mpoulieris - 03 March 2010 10:00 AM

can i use the magento connector for upgrade or i must do it via SSH?
thanks

This should work with Magento Connect also ... just remove the downloader directory and the pear file I mentioned in my other post, then run Magento Connect.

 
Magento Community Magento Community
Magento Community
Magento Community
 
mpoulieris
Jr. Member
 
Total Posts:  11
Joined:  2010-02-14
drama
 

didnt work,i have error message,i must upload the downloader file again and the pear file.

 
Magento Community Magento Community
Magento Community
Magento Community
 
mpoulieris
Jr. Member
 
Total Posts:  11
Joined:  2010-02-14
drama
 

install ok: channel://connect.magentocommerce.com/core/Lib_PEAR-1.4.0.0
install ok: channel://connect.magentocommerce.com/core/Lib_LinLibertineFont-2.8.14.0
install ok: channel://pear.php.net/Archive_Tar-1.3.5
install ok: channel://pear.php.net/Structures_Graph-1.0.3
install ok: channel://pear.php.net/Console_Getopt-1.2.3
install ok: channel://pear.php.net/XML_Util-1.2.1
install ok: channel://pear.php.net/PEAR-1.9.0
install ok: channel://connect.magentocommerce.com/core/Mage_Pear_Helpers-1.0.18800
install ok: channel://connect.magentocommerce.com/core/Lib_Google_Checkout-1.4.0.0
install ok: channel://connect.magentocommerce.com/core/Lib_Js_Calendar-1.51.0
install ok: channel://connect.magentocommerce.com/core/Lib_Js_Prototype-1.6.0.3.0
install ok: channel://connect.magentocommerce.com/core/Lib_Js_Ext-1.4.0.0
install ok: channel://connect.magentocommerce.com/core/Lib_Js_TinyMCE-3.2.5.0
install ok: channel://connect.magentocommerce.com/core/Lib_ZF_Locale-1.9.6.0
install ok: channel://connect.magentocommerce.com/core/Mage_Downloader-1.4.0.0
install ok: channel://connect.magentocommerce.com/core/Lib_Js_Mage-1.4.0.1
install ok: channel://connect.magentocommerce.com/core/Lib_ZF-1.9.6.0
install ok: channel://connect.magentocommerce.com/core/Lib_Varien-1.4.0.0
install ok: channel://connect.magentocommerce.com/core/Mage_Core_Modules-1.4.0.1
install ok: channel://connect.magentocommerce.com/core/Mage_Core_Adminhtml-1.4.0.1
install ok: channel://connect.magentocommerce.com/core/Interface_Frontend_Default-1.4.0.0
install ok: channel://connect.magentocommerce.com/core/Interface_Install_Default-1.4.0.1
install ok: channel://connect.magentocommerce.com/core/Mage_Centinel-1.4.0.0
install ok: channel://connect.magentocommerce.com/core/Interface_Frontend_Base_Default-1.4.0.1
install ok: channel://connect.magentocommerce.com/core/Phoenix_Moneybookers-1.2
install ok: channel://connect.magentocommerce.com/core/Interface_Adminhtml_Default-1.4.0.1
install ok: channel://connect.magentocommerce.com/core/Mage_All_Latest-1.4.0.1
PEAR: Optional feature webinstaller available (PEAR’s web-based installer)
PEAR: Optional feature gtkinstaller available (PEAR’s PHP-GTK-based installer)
PEAR: Optional feature gtk2installer available (PEAR’s PHP-GTK2-based installer)
PEAR: To install optional features use “pear install pear/PEAR#featurename”

Fatal error: Exception thrown without a stack frame in Unknown on line 0

i upload the new downloader file and the pear file from 1.4.0.1 and i run from the magetno connector the :magento-core/Mage_All_Latest and i have teh results abone,pls check.

 
Magento Community Magento Community
Magento Community
Magento Community
 
J-Mod
Jr. Member
 
Avatar
Total Posts:  11
Joined:  2009-12-28
 

Were you upgrading from 1.4.0.0 to 1.4.0.1 or you were upgrading from a 1.3 release?

mpoulieris - 03 March 2010 12:01 PM

install ok: channel://connect.magentocommerce.com/core/Lib_PEAR-1.4.0.0
install ok: channel://connect.magentocommerce.com/core/Lib_LinLibertineFont-2.8.14.0
install ok: channel://pear.php.net/Archive_Tar-1.3.5
install ok: channel://pear.php.net/Structures_Graph-1.0.3
install ok: channel://pear.php.net/Console_Getopt-1.2.3
install ok: channel://pear.php.net/XML_Util-1.2.1
install ok: channel://pear.php.net/PEAR-1.9.0
install ok: channel://connect.magentocommerce.com/core/Mage_Pear_Helpers-1.0.18800
install ok: channel://connect.magentocommerce.com/core/Lib_Google_Checkout-1.4.0.0
install ok: channel://connect.magentocommerce.com/core/Lib_Js_Calendar-1.51.0
install ok: channel://connect.magentocommerce.com/core/Lib_Js_Prototype-1.6.0.3.0
install ok: channel://connect.magentocommerce.com/core/Lib_Js_Ext-1.4.0.0
install ok: channel://connect.magentocommerce.com/core/Lib_Js_TinyMCE-3.2.5.0
install ok: channel://connect.magentocommerce.com/core/Lib_ZF_Locale-1.9.6.0
install ok: channel://connect.magentocommerce.com/core/Mage_Downloader-1.4.0.0
install ok: channel://connect.magentocommerce.com/core/Lib_Js_Mage-1.4.0.1
install ok: channel://connect.magentocommerce.com/core/Lib_ZF-1.9.6.0
install ok: channel://connect.magentocommerce.com/core/Lib_Varien-1.4.0.0
install ok: channel://connect.magentocommerce.com/core/Mage_Core_Modules-1.4.0.1
install ok: channel://connect.magentocommerce.com/core/Mage_Core_Adminhtml-1.4.0.1
install ok: channel://connect.magentocommerce.com/core/Interface_Frontend_Default-1.4.0.0
install ok: channel://connect.magentocommerce.com/core/Interface_Install_Default-1.4.0.1
install ok: channel://connect.magentocommerce.com/core/Mage_Centinel-1.4.0.0
install ok: channel://connect.magentocommerce.com/core/Interface_Frontend_Base_Default-1.4.0.1
install ok: channel://connect.magentocommerce.com/core/Phoenix_Moneybookers-1.2
install ok: channel://connect.magentocommerce.com/core/Interface_Adminhtml_Default-1.4.0.1
install ok: channel://connect.magentocommerce.com/core/Mage_All_Latest-1.4.0.1
PEAR: Optional feature webinstaller available (PEAR’s web-based installer)
PEAR: Optional feature gtkinstaller available (PEAR’s PHP-GTK-based installer)
PEAR: Optional feature gtk2installer available (PEAR’s PHP-GTK2-based installer)
PEAR: To install optional features use “pear install pear/PEAR#featurename”

Fatal error: Exception thrown without a stack frame in Unknown on line 0

i upload the new downloader file and the pear file from 1.4.0.1 and i run from the magetno connector the :magento-core/Mage_All_Latest and i have teh results abone,pls check.

 
Magento Community Magento Community
Magento Community
Magento Community
 
mpoulieris
Jr. Member
 
Total Posts:  11
Joined:  2010-02-14
drama
 

from 1.4.0.0 to 1.4.0.1

 
Magento Community Magento Community
Magento Community
Magento Community
 
mpoulieris
Jr. Member
 
Total Posts:  11
Joined:  2010-02-14
drama
 

d u know what permision rights i must give and where?i use in all files that have index.php ,the index.php 755,but as i see that i some steps theres errors like:
Exception printing is disabled by default for security reasons.

 
Magento Community Magento Community
Magento Community
Magento Community
 
J-Mod
Jr. Member
 
Avatar
Total Posts:  11
Joined:  2009-12-28
 
J-Mod - 03 March 2010 01:47 PM


i upload the new downloader file

Downloader is an entire directory ... did you upload the 1.4.0.1 downloader directory to your root directory where your index.php file is at? Are the permissions (755) properly set for it?

 
Magento Community Magento Community
Magento Community
Magento Community
 
J-Mod
Jr. Member
 
Avatar
Total Posts:  11
Joined:  2009-12-28
 
mpoulieris - 03 March 2010 02:10 PM

but as i see that i some steps theres errors like:
Exception printing is disabled by default for security reasons.

That error is telling you that when an exception is thrown (when something goes wrong), it will not be printed to the screen for you to see. This is a feature you can turn on or off ... you should leave it off if your Magento store is live. Instead, you can have error logging enabled to see what the errors are, that way only you can see the errors ... for security reasons and for user friendliness.

Do you know how to use the command line? Download a program called Putty and you’ll see how to establish a SSH connection to your server. Personally, I think upgrading is just as easy through the command line vs. through Magento Connect ... and you can do much more from the command line.

Wish I could help more, but there are more than a few variables that may be causing your problem.

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top
Page 2 of 3