Posting in the Magento forums has been disabled pending the implementation of a new and improved forum solution which should better serve the community.

For new questions please post at magento.stackexchange.com, the community-run support site for the Magento community. We will be providing updates on the new forum solution soon. For questions or concerns please email community@magento.com.

Magento Forum

Page 1 of 3
1.4.0.0 (fresh install) upgrade problems to 1.4.0.1
 
oldcreekwbf
Jr. Member
 
Total Posts:  24
Joined:  2008-06-13
 

Hi,

So I’m currently working on customizing a Magneto store on a fresh install of Magento 1.4.0.0 and I noticed that Magento upgraded to 1.4.0.1. Figuring that I might as well get the upgrade out of the way, I went to ConnectManager to install the latest version. But I keep running into errors could use some help. Here is the process by which I am trying to upgrade:

Essentially after logging into the Magento Connect Manager I click on the “Check for Upgrades” button. Magento then highlights that there are multiple packages that are available to upgrade to 1.4.0.1 (screenshot attached to this post)

I’ve tried many combinations but to keep things simple for this post, I will only set Mage_All_Latest to update by setting its dropdown menu to “Upgrade to 1.4.0.1 (stable)”. I then set the checkbox below the “Commit Changes” button to “Clear all sessions after successful install or upgrade” and click “Commit Changes”.

The following errors occur

downloading Mage_All_Latest-1.4.0.1.tgz ...
Starting to download Mage_All_Latest-1.4.0.1.tgz (1,039 bytes)
. ...
done1,039 bytes
downloading Mage_Core_Modules
-1.4.0.1.tgz ...
Starting to download Mage_Core_Modules-1.4.0.1.tgz (1,773,350 bytes)
...
done1,773,350 bytes
Could not get contents of package 
"/home/oldcreek/staging/downloader/pearlib/download/Mage_Core_Modules-1.4.0.1.tgz"Invalid tgz file.
Download of "magento-core/Mage_Core_Modules" succeededbut it is not a valid package archive
Error
cannot download "magento-core/Mage_Core_Modules"
downloading Mage_Core_Adminhtml-1.4.0.1.tgz ...
Starting to download Mage_Core_Adminhtml-1.4.0.1.tgz (450,211 bytes)
...
done450,211 bytes
Could not get contents of package 
"/home/oldcreek/staging/downloader/pearlib/download/Mage_Core_Adminhtml-1.4.0.1.tgz"Invalid tgz file.
Download of "magento-core/Mage_Core_Adminhtml" succeededbut it is not a valid package archive
Error
cannot download "magento-core/Mage_Core_Adminhtml"
downloading Interface_Adminhtml_Default-1.4.0.1.tgz ...
Starting to download Interface_Adminhtml_Default-1.4.0.1.tgz (1,022,411 bytes)
...
done1,022,411 bytes
Could not get contents of package 
"/home/oldcreek/staging/downloader/pearlib/download/Interface_Adminhtml_Default-1.4.0.1.tgz"Invalid tgz file.
Download of "magento-core/Interface_Adminhtml_Default" succeededbut it is not a valid package archive
Error
cannot download "magento-core/Interface_Adminhtml_Default"
downloading Interface_Install_Default-1.4.0.1.tgz ...
Starting to download Interface_Install_Default-1.4.0.1.tgz (108,693 bytes)
...
done108,693 bytes
downloading Interface_Frontend_Base_Default
-1.4.0.1.tgz ...
Starting to download Interface_Frontend_Base_Default-1.4.0.1.tgz (332,987 bytes)
...
done332,987 bytes
Could not get contents of package 
"/home/oldcreek/staging/downloader/pearlib/download/Interface_Frontend_Base_Default-1.4.0.1.tgz"Invalid tgz file.
Download of "magento-core/Interface_Frontend_Base_Default" succeededbut it is not a valid package archive
Error
cannot download "magento-core/Interface_Frontend_Base_Default"
magento-core/Mage_All_Latest requires package "magento-core/Mage_Core_Modules" (version >= 1.4.0.1version <= 1.4.0.1), installed version is 1.4.0.0
magento
-core/Mage_All_Latest requires package "magento-core/Mage_Core_Adminhtml" (version >= 1.4.0.1version <= 1.4.0.1), installed version is 1.4.0.0
magento
-core/Mage_All_Latest requires package "magento-core/Interface_Adminhtml_Default" (version >= 1.4.0.1version <= 1.4.0.1), installed version is 1.4.0.0
magento
-core/Mage_All_Latest requires package "magento-core/Interface_Frontend_Base_Default" (version >= 1.4.0.1version <= 1.4.0.1), installed version is 1.4.0.0
magento
-core/mage_all_latest requires package "magento-core/Interface_Install_Default" (version >= 1.4.0.0version <= 1.4.0.0), downloaded version is 1.4.0.1
magento
-core/Interface_Install_Default cannot be installedconflicts with installed packages
Install Errors
Download failed
PEAR ERROR
upgrade failed

Any insights or help would be appreciated. Thanks in advance!!

Image Attachments
screenshot.png
 
Magento Community Magento Community
Magento Community
Magento Community
 
Domiyeah
Member
 
Total Posts:  33
Joined:  2008-10-22
 

same probleme here wink

 
Magento Community Magento Community
Magento Community
Magento Community
 
chadhenry
Member
 
Total Posts:  38
Joined:  2009-01-01
 

I get the following:

downloading Mage_Core_Modules-1.4.0.1.tgz ...
Starting to download Mage_Core_Modules-1.4.0.1.tgz (1,773,350 bytes)
. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . ...
done1,773,350 bytes
ERROR
connect.magentocommerce.com/core/Mage_Core_Modulesconflicting files founden_US/template/email/sales/creditmemo_new.html (connect.magentocommerce.com/core/mage_locale_en_usen_US/template/email/sales/creditmemo_new_guest.html (connect.magentocommerce.com/core/mage_locale_en_usen_US/template/email/sales/creditmemo_update.html (connect.magentocommerce.com/core/mage_locale_en_usen_US/template/email/sales/creditmemo_update_guest.html (connect.magentocommerce.com/core/mage_locale_en_usen_US/template/email/sales/invoice_new.html (connect.magentocommerce.com/core/mage_locale_en_usen_US/template/email/sales/invoice_new_guest.html (connect.magentocommerce.com/core/mage_locale_en_usen_US/template/email/sales/invoice_update.html (connect.magentocommerce.com/core/mage_locale_en_usen_US/template/email/sales/invoice_update_guest.html (connect.magentocommerce.com/core/mage_locale_en_usen_US/template/email/sales/order_new.html (connect.magentocommerce.com/core/mage_locale_en_usen_US/template/email/sales/order_new_guest.html (connect.magentocommerce.com/core/mage_locale_en_usen_US/template/email/sales/order_update.html (connect.magentocommerce.com/core/mage_locale_en_usen_US/template/email/sales/order_update_guest.html (connect.magentocommerce.com/core/mage_locale_en_usen_US/template/email/sales/shipment_new.html (connect.magentocommerce.com/core/mage_locale_en_usen_US/template/email/sales/shipment_new_guest.html (connect.magentocommerce.com/core/mage_locale_en_usen_US/template/email/sales/shipment_update.html (connect.magentocommerce.com/core/mage_locale_en_usen_US/template/email/sales/shipment_update_guest.html (connect.magentocommerce.com/core/mage_locale_en_usen_US/template/email/account_new.html (connect.magentocommerce.com/core/mage_locale_en_usen_US/template/email/account_new_confirmation.html (connect.magentocommerce.com/core/mage_locale_en_usen_US/template/email/account_new_confirmed.html (connect.magentocommerce.com/core/mage_locale_en_usen_US/template/email/admin_password_new.html (connect.magentocommerce.com/core/mage_locale_en_usen_US/template/email/contact_form.html (connect.magentocommerce.com/core/mage_locale_en_usen_US/template/email/currency_update_warning.html (connect.magentocommerce.com/core/mage_locale_en_usen_US/template/email/log_clean_warning.html (connect.magentocommerce.com/core/mage_locale_en_usen_US/template/email/newsletter_subscr_confirm.html (connect.magentocommerce.com/core/mage_locale_en_usen_US/template/email/newsletter_subscr_success.html (connect.magentocommerce.com/core/mage_locale_en_usen_US/template/email/newsletter_unsub_success.html (connect.magentocommerce.com/core/mage_locale_en_usen_US/template/email/password_new.html (connect.magentocommerce.com/core/mage_locale_en_usen_US/template/email/payment_failed.html (connect.magentocommerce.com/core/mage_locale_en_usen_US/template/email/product_alert_cron_error.html (connect.magentocommerce.com/core/mage_locale_en_usen_US/template/email/product_price_alert.html (connect.magentocommerce.com/core/mage_locale_en_usen_US/template/email/product_share.html (connect.magentocommerce.com/core/mage_locale_en_usen_US/template/email/product_stock_alert.html (connect.magentocommerce.com/core/mage_locale_en_usen_US/template/email/sitemap_generate_warning.html (connect.magentocommerce.com/core/mage_locale_en_usen_US/template/email/wishlist_share.html (connect.magentocommerce.com/core/mage_locale_en_usen_US/Mage_AdminNotification.csv (connect.magentocommerce.com/core/mage_locale_en_usen_US/Mage_Api.csv (connect.magentocommerce.com/core/mage_locale_en_usen_US/Mage_Backup.csv (connect.magentocommerce.com/core/mage_locale_en_usen_US/Mage_Bundle.csv (connect.magentocommerce.com/core/mage_locale_en_usen_US/Mage_Catalog.csv (connect.magentocommerce.com/core/mage_locale_en_usen_US/Mage_CatalogInventory.csv (connect.magentocommerce.com/core/mage_locale_en_usen_US/Mage_CatalogRule.csv (connect.magentocommerce.com/core/mage_locale_en_usen_US/Mage_CatalogSearch.csv (connect.magentocommerce.com/core/mage_locale_en_usen_US/Mage_Checkout.csv (connect.magentocommerce.com/core/mage_locale_en_usen_US/Mage_Cms.csv (connect.magentocommerce.com/core/mage_locale_en_usen_US/Mage_Contacts.csv (connect.magentocommerce.com/core/mage_locale_en_usen_US/Mage_Core.csv (connect.magentocommerce.com/core/mage_locale_en_usen_US/Mage_Cron.csv (connect.magentocommerce.com/core/mage_locale_en_usen_US/Mage_Customer.csv (connect.magentocommerce.com/core/mage_locale_en_usen_US/Mage_Dataflow.csv (connect.magentocommerce.com/core/mage_locale_en_usen_US/Mage_Directory.csv (connect.magentocommerce.com/core/mage_locale_en_usen_US/Mage_Downloadable.csv (connect.magentocommerce.com/core/mage_locale_en_usen_US/Mage_Eav.csv (connect.magentocommerce.com/core/mage_locale_en_usen_US/Mage_GiftMessage.csv (connect.magentocommerce.com/core/mage_locale_en_usen_US/Mage_GoogleAnalytics.csv (connect.magentocommerce.com/core/mage_locale_en_usen_US/Mage_GoogleBase.csv (connect.magentocommerce.com/core/mage_locale_en_usen_US/Mage_GoogleCheckout.csv (connect.magentocommerce.com/core/mage_locale_en_usen_US/Mage_GoogleOptimizer.csv (connect.magentocommerce.com/core/mage_locale_en_usen_US/Mage_Index.csv (connect.magentocommerce.com/core/mage_locale_en_usen_US/Mage_Install.csv (connect.magentocommerce.com/core/mage_locale_en_usen_US/Mage_Log.csv (connect.magentocommerce.com/core/mage_locale_en_usen_US/Mage_Media.csv (connect.magentocommerce.com/core/mage_locale_en_usen_US/Mage_Newsletter.csv (connect.magentocommerce.com/core/mage_locale_en_usen_US/Mage_Page.csv (connect.magentocommerce.com/core/mage_locale_en_usen_US/Mage_Paygate.csv (connect.magentocommerce.com/core/mage_locale_en_usen_US/Mage_Payment.csv (connect.magentocommerce.com/core/mage_locale_en_usen_US/Mage_Paypal.csv (connect.magentocommerce.com/core/mage_locale_en_usen_US/Mage_PaypalUk.csv (connect.magentocommerce.com/core/mage_locale_en_usen_US/Mage_Poll.csv (connect.magentocommerce.com/core/mage_locale_en_usen_US/Mage_ProductAlert.csv (connect.magentocommerce.com/core/mage_locale_en_usen_US/Mage_Rating.csv (connect.magentocommerce.com/core/mage_locale_en_usen_US/Mage_Reports.csv (connect.magentocommerce.com/core/mage_locale_en_usen_US/Mage_Review.csv (connect.magentocommerce.com/core/mage_locale_en_usen_US/Mage_Rss.csv (connect.magentocommerce.com/core/mage_locale_en_usen_US/Mage_Rule.csv (connect.magentocommerce.com/core/mage_locale_en_usen_US/Mage_Sales.csv (connect.magentocommerce.com/core/mage_locale_en_usen_US/Mage_SalesRule.csv (connect.magentocommerce.com/core/mage_locale_en_usen_US/Mage_Sendfriend.csv (connect.magentocommerce.com/core/mage_locale_en_usen_US/Mage_Shipping.csv (connect.magentocommerce.com/core/mage_locale_en_usen_US/Mage_Sitemap.csv (connect.magentocommerce.com/core/mage_locale_en_usen_US/Mage_Tag.csv (connect.magentocommerce.com/core/mage_locale_en_usen_US/Mage_Tax.csv (connect.magentocommerce.com/core/mage_locale_en_usen_US/Mage_Usa.csv (connect.magentocommerce.com/core/mage_locale_en_usen_US/Mage_Weee.csv (connect.magentocommerce.com/core/mage_locale_en_usen_US/Mage_Widget.csv (connect.magentocommerce.com/core/mage_locale_en_usen_US/Mage_Wishlist.csv (connect.magentocommerce.com/core/mage_locale_en_us)

Seems like another bad release....

Only the Mage_Core_Modules package doesn’t upgrade and I still see all the errors on my backend and frontend that say
Fatal error: Exception thrown without a stack frame in Unknown on line 0

 
Magento Community Magento Community
Magento Community
Magento Community
 
Michel Hiemstra
Jr. Member
 
Total Posts:  1
Joined:  2010-02-19
 

Same problem here, i get this message:

downloading Mage_All_Latest-1.4.0.1.tgz ...
Starting to download Mage_All_Latest-1.4.0.1.tgz (1,039 bytes)
. ...
done1,039 bytes
downloading Mage_Core_Modules
-1.4.0.1.tgz ...
Starting to download Mage_Core_Modules-1.4.0.1.tgz (1,773,350 bytes)
...
done1,773,350 bytes
downloading Mage_Core_Adminhtml
-1.4.0.1.tgz ...
Starting to download Mage_Core_Adminhtml-1.4.0.1.tgz (450,211 bytes)
...
done450,211 bytes
downloading Interface_Adminhtml_Default
-1.4.0.1.tgz ...
Starting to download Interface_Adminhtml_Default-1.4.0.1.tgz (1,022,411 bytes)
...
done1,022,411 bytes
downloading Interface_Frontend_Default
-1.4.0.0.tgz ...
Starting to download Interface_Frontend_Default-1.4.0.0.tgz (736,859 bytes)
...
done736,859 bytes
downloading Interface_Install_Default
-1.4.0.1.tgz ...
Starting to download Interface_Install_Default-1.4.0.1.tgz (108,693 bytes)
...
done108,693 bytes
downloading Mage_Downloader
-1.4.0.0.tgz ...
Starting to download Mage_Downloader-1.4.0.0.tgz (183,789 bytes)
...
done183,789 bytes
downloading Mage_Centinel
-1.4.0.0.tgz ...
Starting to download Mage_Centinel-1.4.0.0.tgz (36,460 bytes)
...
done36,460 bytes
downloading Interface_Frontend_Base_Default
-1.4.0.1.tgz ...
Starting to download Interface_Frontend_Base_Default-1.4.0.1.tgz (332,987 bytes)
...
done332,987 bytes
downloading Phoenix_Moneybookers
-1.2.tgz ...
Starting to download Phoenix_Moneybookers-1.2.tgz (178,184 bytes)
...
done178,184 bytes
downloading Lib_Varien
-1.4.0.0.tgz ...
Starting to download Lib_Varien-1.4.0.0.tgz (126,181 bytes)
...
done126,181 bytes
downloading Lib_Google_Checkout
-1.4.0.0.tgz ...
Starting to download Lib_Google_Checkout-1.4.0.0.tgz (27,161 bytes)
...
done27,161 bytes
downloading Lib_Js_Calendar
-1.51.0.tgz ...
Starting to download Lib_Js_Calendar-1.51.0.tgz (23,859 bytes)
...
done23,859 bytes
downloading Lib_Js_Mage
-1.4.0.1.tgz ...
Starting to download Lib_Js_Mage-1.4.0.1.tgz (87,791 bytes)
...
done87,791 bytes
downloading Lib_Js_Prototype
-1.6.0.3.0.tgz ...
Starting to download Lib_Js_Prototype-1.6.0.3.0.tgz (222,617 bytes)
...
done222,617 bytes
downloading Lib_Js_Ext
-1.4.0.0.tgz ...
Starting to download Lib_Js_Ext-1.4.0.0.tgz (265,141 bytes)
...
done265,141 bytes
downloading Lib_Js_TinyMCE
-3.2.5.0.tgz ...
Starting to download Lib_Js_TinyMCE-3.2.5.0.tgz (831,669 bytes)
...
done831,669 bytes
downloading Lib_ZF
-1.9.6.0.tgz ...
Starting to download Lib_ZF-1.9.6.0.tgz (1,763,063 bytes)
...
done1,763,063 bytes
downloading Mage_Pear_Helpers
-1.0.18800.tgz ...
Starting to download Mage_Pear_Helpers-1.0.18800.tgz (9,225 bytes)
...
done9,225 bytes
downloading Lib_ZF_Locale
-1.9.6.0.tgz ...
Starting to download Lib_ZF_Locale-1.9.6.0.tgz (1,522,612 bytes)
...
done1,522,612 bytes
downloading PEAR
-1.9.0.tgz ...
Starting to download PEAR-1.9.0.tgz (291,634 bytes)
...
done291,634 bytes
downloading XML_Util
-1.2.1.tgz ...
Starting to download XML_Util-1.2.1.tgz (17,729 bytes)
...
done17,729 bytes
Magento Downloader
Exception caught
:

WarningParameter 3 to PEAR_Task_Replace::validateXml() expected to be a referencevalue given in /data/www/officedealer/public_html/downloader/pearlib/php/PEAR/PackageFile/v2/Validator.php on line 1143

Backtrace
:

#0 [internal function]: mageCoreErrorHandler(2, 'Parameter 3 to ...', '/data/www/offic...', 1143, Array)
#1 /data/www/officedealer/public_html/downloader/pearlib/php/PEAR/PackageFile/v2/Validator.php(1143): call_user_func(Array, Object(PEAR_PackageFile_v2), Array, Object(PEAR_Config), Array)
#2 /data/www/officedealer/public_html/downloader/pearlib/php/PEAR/PackageFile/v2/Validator.php(1216): PEAR_PackageFile_v2_Validator->_validateFilelist(Array, false, '')
#3 /data/www/officedealer/public_html/downloader/pearlib/php/PEAR/PackageFile/v2/Validator.php(252): PEAR_PackageFile_v2_Validator->_validateFilelist()
#4 /data/www/officedealer/public_html/downloader/pearlib/php/PEAR/PackageFile/v2.php(1920): PEAR_PackageFile_v2_Validator->validate(Object(PEAR_PackageFile_v2), 3)
#5 /data/www/officedealer/public_html/downloader/pearlib/php/PEAR/Registry.php(1226): PEAR_PackageFile_v2->validate()
#6 /data/www/officedealer/public_html/downloader/pearlib/php/PEAR/Registry.php(1619): PEAR_Registry->_addPackage2(Object(PEAR_PackageFile_v2))
#7 /data/www/officedealer/public_html/downloader/pearlib/php/PEAR/Installer.php(1385): PEAR_Registry->addPackage2(Object(PEAR_PackageFile_v2))
#8 /data/www/officedealer/public_html/downloader/pearlib/php/PEAR/Command/Install.php(666): PEAR_Installer->install(Object(PEAR_Downloader_Package), Array)
#9 /data/www/officedealer/public_html/downloader/pearlib/php/PEAR/Command/Common.php(285): PEAR_Command_Install->doInstall('install', Array, Array)
#10 /data/www/officedealer/public_html/downloader/Maged/Pear.php(234): PEAR_Command_Common->run('install', Array, Array)
#11 /data/www/officedealer/public_html/downloader/Maged/Pear.php(301): Maged_Pear->run('install', Array, Array)
#12 /data/www/officedealer/public_html/downloader/Maged/Model/Pear.php(245): Maged_Pear->runHtmlConsole(Array)
#13 /data/www/officedealer/public_html/downloader/Maged/Controller.php(135): Maged_Model_Pear->installPackage('magento-core/Ma...')
#14 /data/www/officedealer/public_html/downloader/Maged/Controller.php(368): Maged_Controller->pearInstallPackagePostAction()
#15 /data/www/officedealer/public_html/downloader/Maged/Controller.php(183): Maged_Controller->dispatch()
#16 /data/www/officedealer/public_html/downloader/index.php(35): Maged_Controller::run()
#17 {main}

Magento is a trademark of Irubin Consulting IncDBA VarienCopyright Â© 2008 Irubin Consulting Inc.

I was hoping to have a working backend, i can’t even add images to products with 1.4.0.0 :(

Image Attachments
Screen shot 2010-02-20 at 5.18.32 PM.png
 
Magento Community Magento Community
Magento Community
Magento Community
 
Martin
Guru
 
Avatar
Total Posts:  445
Joined:  2007-08-31
Brno | London | Los Angeles
 

1. uninstall magento-core/Mage_Locale_en_US package
2. upgrade magento-core/Mage_Core_Modules package

that’s it ...

 
Magento Community Magento Community
Magento Community
Magento Community
 
chadhenry
Member
 
Total Posts:  38
Joined:  2009-01-01
 
Martin - 21 February 2010 04:37 AM

1. uninstall magento-core/Mage_Locale_en_US package
2. upgrade magento-core/Mage_Core_Modules package

that’s it ...

Mage core upgraded fine, but now I can’t get into the manager to install the Locale EN package. I keep getting errors and/ or redirected back to the admin.

 
Magento Community Magento Community
Magento Community
Magento Community
 
Martin
Guru
 
Avatar
Total Posts:  445
Joined:  2007-08-31
Brno | London | Los Angeles
 

Strange, that solved it for me with no other problems. And magento-core/Mage_Core_Modules 1.4.0.1 package already includes en_US locale, so there is no need to install it again ...

May be try to clean cache ...

 
Magento Community Magento Community
Magento Community
Magento Community
 
chadhenry
Member
 
Total Posts:  38
Joined:  2009-01-01
 

I’m getting the following error in my logs when I try to access magento connect:

a:5:{i:0;s:221:"Warning: include(PEAR/Error.php) [<a href='function.include'>function.include</a>]: failed to open stream: No such file or directory  in /home/username/public_html/domain.com/lib/Varien/Autoload.php on line 93";i:1;s:2325:"#0 /home/username/public_html/domain.com/lib/Varien/Autoload.php(93): mageCoreErrorHandler(2, 'include(PEAR/Er...', '/home/username/...', 93, Array)
#1 /home/username/public_html/domain.com/lib/Varien/Autoload.php(93): Varien_Autoload::autoload()
#2 [internal function]: Varien_Autoload->autoload('PEAR_Error')
#3 /home/username/public_html/domain.com/downloader/pearlib/php/PEAR.php(829): spl_autoload_call('PEAR_Error')
#4 /home/username/public_html/domain.com/lib/Varien/Autoload.php(93): include('/home/username/...')
#5 [internal function]: Varien_Autoload->autoload('PEAR_Error')
#6 /home/username/public_html/domain.com/downloader/pearlib/php/PEAR.php(102): spl_autoload_call('PEAR')
#7 /home/username/public_html/domain.com/lib/Varien/Pear.php(27): require_once('/home/username/...')
#8 /home/username/public_html/domain.com/lib/Varien/Pear/Package.php(3): require_once('/home/username/...')
#9 /home/username/public_html/domain.com/app/code/core/Mage/Adminhtml/controllers/Extensions/LocalController.php(27): require_once('/home/username/...')
#10 /home/username/public_html/domain.com/app/code/core/Mage/Core/Controller/Varien/Router/Standard.php(318): include('/home/username/...')
#11 /home/username/public_html/domain.com/app/code/core/Mage/Core/Controller/Varien/Router/Standard.php(288): Mage_Core_Controller_Varien_Router_Standard->_includeControllerClass('PEAR')
#12 /home/username/public_html/domain.com/app/code/core/Mage/Core/Controller/Varien/Router/Standard.php(201): Mage_Core_Controller_Varien_Router_Standard->_validateControllerClassName('PEAR')
#13 /home/username/public_html/domain.com/app/code/core/Mage/Core/Controller/Varien/Front.php(177): Mage_Core_Controller_Varien_Router_Standard->match('/home/username/...', 'Mage_Adminhtml_...')
#14 /home/username/public_html/domain.com/app/code/core/Mage/Core/Model/App.php(304): Mage_Core_Controller_Varien_Front->dispatch('Mage_Adminhtml', 'extensions_loca...')
#15 /home/username/public_html/domain.com/app/Mage.php(596): Mage_Core_Model_App->run(Object(Mage_Core_Controller_Request_Http))
#16 /home/username/public_html/domain.com/index.php(78): Mage::run()
#17 {main}"
;s:3:"url";s:77:"/index.php/admin/extensions_local/index/key/key#/";s:11:"script_name";s:10:"/index.php";s:4:"skin";s:7:"default";}
 
Magento Community Magento Community
Magento Community
Magento Community
 
Martin
Guru
 
Avatar
Total Posts:  445
Joined:  2007-08-31
Brno | London | Los Angeles
 

Do you have SSH access? Try to run the following commands from the Magento root directory:

./pear mage-setup .
./
pear install magento-core/Mage_All_Latest

You will see bunch of following error messages:

Notice: Use of undefined constant PEAR assumed 'PEAR' in PEAR.php on line 102
Notice
: Use of undefined constant PEAR assumed 'PEAR' in /var/www/www.domain.com/downloader/pearlib/php/PEAR.php on line 102
Notice
: Use of undefined constant _PEAR_call_destructors assumed '_PEAR_call_destructors' in PEAR.php on line 775
Notice
: Use of undefined constant _PEAR_call_destructors assumed '_PEAR_call_destructors' in /var/www/www.domain.com/downloader/pearlib/php/PEAR.php on line 775
Notice
: Use of undefined constant PEAR_Error assumed 'PEAR_Error' in PEAR.php on line 829
Notice
: Use of undefined constant PEAR_Error assumed 'PEAR_Error' in /var/www/www.domain.com/downloader/pearlib/php/PEAR.php on line 829

but don’t mind them - after running above commands everything should be OK and your Magento Connect should be accessible again ...

 
Magento Community Magento Community
Magento Community
Magento Community
 
chadhenry
Member
 
Total Posts:  38
Joined:  2009-01-01
 
Martin - 21 February 2010 07:39 AM

Do you have SSH access? Try to run the following commands from the Magento root directory:

./pear mage-setup .
./
pear install magento-core/Mage_All_Latest

You will see bunch of following error messages:

Notice: Use of undefined constant PEAR assumed 'PEAR' in PEAR.php on line 102
Notice
: Use of undefined constant PEAR assumed 'PEAR' in /var/www/www.domain.com/downloader/pearlib/php/PEAR.php on line 102
Notice
: Use of undefined constant _PEAR_call_destructors assumed '_PEAR_call_destructors' in PEAR.php on line 775
Notice
: Use of undefined constant _PEAR_call_destructors assumed '_PEAR_call_destructors' in /var/www/www.domain.com/downloader/pearlib/php/PEAR.php on line 775
Notice
: Use of undefined constant PEAR_Error assumed 'PEAR_Error' in PEAR.php on line 829
Notice
: Use of undefined constant PEAR_Error assumed 'PEAR_Error' in /var/www/www.domain.com/downloader/pearlib/php/PEAR.php on line 829

but don’t mind them - after running above commands everything should be OK and your Magento Connect should be accessible again ...

Doesn’t seem to have worked. I got the following in shell:

-jailshell-3.2$ ./pear mage-setup .
Running initial setup...
config-set succeeded
config
-set succeeded
config
-set succeeded
config
-set succeeded
config
-set succeeded
config
-set succeeded
config
-set succeeded
config
-set succeeded
config
-set succeeded
config
-set succeeded
config
-set succeeded
config
-set succeeded
config
-set succeeded
config
-set succeeded
config
-set succeeded
config
-set succeeded
config
-set succeeded
config
-set succeeded
config
-set succeeded
config
-set succeeded
config
-set succeeded
config
-set succeeded
config
-set succeeded
Channel 
"connect.magentocommerce.com/core" is already initialized
Channel 
"connect.magentocommerce.com/community" is already initialized
-jailshell-3.2$ ./pear install magento-core/Mage_All_Latest
magento
-core/Mage_All_Latest is already installed and is the same as the released version 1.4.0.1
install failed

When I log into the admin and magento connect I still get an error in the logs with the same error showing.... not sure what is going on.

 
Magento Community Magento Community
Magento Community
Magento Community
 
Martin
Guru
 
Avatar
Total Posts:  445
Joined:  2007-08-31
Brno | London | Los Angeles
 

Try to reinstall Magento Downloader:

./pear install -f magento-core/Mage_Downloader
 
Magento Community Magento Community
Magento Community
Magento Community
 
chadhenry
Member
 
Total Posts:  38
Joined:  2009-01-01
 
Martin - 21 February 2010 08:59 AM

Try to reinstall Magento Downloader:

./pear install -f magento-core/Mage_Downloader

No go. Same error :/

 
Magento Community Magento Community
Magento Community
Magento Community
 
Martin
Guru
 
Avatar
Total Posts:  445
Joined:  2007-08-31
Brno | London | Los Angeles
 

Hmm, sorry, but I don’t know what else ... try search the forum ...

 
Magento Community Magento Community
Magento Community
Magento Community
 
chadhenry
Member
 
Total Posts:  38
Joined:  2009-01-01
 
Martin - 21 February 2010 09:51 AM

Hmm, sorry, but I don’t know what else ... try search the forum ...

Thanks for your help. Much appreciated! I’m just going to reinstall magento 1.3.2.4 for the time being… I never had issues with that version so I’m going to go back to it until Varien gets 1.4 actually working correctly. Thanks again!

 
Magento Community Magento Community
Magento Community
Magento Community
 
Martin
Guru
 
Avatar
Total Posts:  445
Joined:  2007-08-31
Brno | London | Los Angeles
 

You’re welcome.

For downgrade back to 1.3.2.4 you have to have DB backup from that version, or your shop could get pretty screwed up ...

Anyway, before every upgrade do not forget backup your DB & the whole Magento directory - downgrading back will be piece of cake wink

 
Magento Community Magento Community
Magento Community
Magento Community
 
chadhenry
Member
 
Total Posts:  38
Joined:  2009-01-01
 
Martin - 21 February 2010 10:40 AM

You’re welcome.

For downgrade back to 1.3.2.4 you have to have DB backup from that version, or your shop could get pretty screwed up ...

Anyway, before every upgrade do not forget backup your DB & the whole Magento directory - downgrading back will be piece of cake wink

Yes, thankfully I backed up everything before I upgraded… I was just hoping to use the new features in 1.4… but I guess it just isn’t ready for prime time :/

Thanks again!

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top
Page 1 of 3