Posting in the Magento forums has been disabled pending the implementation of a new and improved forum solution which should better serve the community.

For new questions please post at magento.stackexchange.com, the community-run support site for the Magento community. We will be providing updates on the new forum solution soon. For questions or concerns please email community@magento.com.

Magento Forum

BIG ERROR :S
 
Fabriprint
Jr. Member
 
Total Posts:  25
Joined:  2010-02-19
 

i have a major problem with magento TT i was trying to make it faster using this link steps:

http://www.opensourcetutor.com/2009/04/07/how-to-speed-up-magento/

but when I did this:

Check Magento Caching is turned on (if not developing still)

1. Login to your Magento Admin
2. go to System -> Cache Management
3. in the dropdown box, choose “enable” and tick all the boxes, then save settings.

i returned with a error that doesn´t let me do anything:

url of error: http://www.fabriprint.pt/report/?id=343243283021&s;=default

SQLSTATE[HY000] [2005] Unknown MySQL server host ‘db.fabriprint.pt’ (1)
Trace:
#0 /chroot/home/fabripri/fabriprint.pt/html/lib/Varien/Db/Adapter/Pdo/Mysql.php(211): Zend_Db_Adapter_Pdo_Abstract->_connect()
#1 /chroot/home/fabripri/fabriprint.pt/html/lib/Zend/Db/Adapter/Abstract.php(441): Varien_Db_Adapter_Pdo_Mysql->_connect()
#2 /chroot/home/fabripri/fabriprint.pt/html/lib/Zend/Db/Adapter/Pdo/Abstract.php(230): Zend_Db_Adapter_Abstract->query(’SET NAMES utf8’, Array)
#3 /chroot/home/fabripri/fabriprint.pt/html/lib/Varien/Db/Adapter/Pdo/Mysql.php(281): Zend_Db_Adapter_Pdo_Abstract->query(’SET NAMES utf8’, Array)
#4 /chroot/home/fabripri/fabriprint.pt/html/app/code/core/Mage/Core/Model/Resource/Type/Db/Pdo/Mysql.php(45): Varien_Db_Adapter_Pdo_Mysql->query(’SET NAMES utf8’)
#5 /chroot/home/fabripri/fabriprint.pt/html/app/code/core/Mage/Core/Model/Resource.php(87): Mage_Core_Model_Resource_Type_Db_Pdo_Mysql->getConnection(Object(Mage_Core_Model_Config_Element))
#6 /chroot/home/fabripri/fabriprint.pt/html/app/code/core/Mage/Core/Model/Mysql4/Abstract.php(255): Mage_Core_Model_Resource->getConnection(’core_read’)
#7 /chroot/home/fabripri/fabriprint.pt/html/app/code/core/Mage/Core/Model/Mysql4/Abstract.php(270): Mage_Core_Model_Mysql4_Abstract->_getConnection(’read’)
#8 /chroot/home/fabripri/fabriprint.pt/html/app/code/core/Mage/Core/Model/Mysql4/Abstract.php(290): Mage_Core_Model_Mysql4_Abstract->_getReadAdapter()
#9 /chroot/home/fabripri/fabriprint.pt/html/app/code/core/Mage/Core/Model/Mysql4/Collection/Abstract.php(68): Mage_Core_Model_Mysql4_Abstract->getReadConnection()
#10 /chroot/home/fabripri/fabriprint.pt/html/app/code/core/Mage/Core/Model/Config.php(1086): Mage_Core_Model_Mysql4_Collection_Abstract->__construct(Object(Mage_Core_Model_Mysql4_Website))
#11 /chroot/home/fabripri/fabriprint.pt/html/app/code/core/Mage/Core/Model/Config.php(1119): Mage_Core_Model_Config->getModelInstance(’core_mysql4/web...’, Object(Mage_Core_Model_Mysql4_Website))
#12 /chroot/home/fabripri/fabriprint.pt/html/app/Mage.php(347): Mage_Core_Model_Config->getResourceModelInstance(’core/website_co...’, Object(Mage_Core_Model_Mysql4_Website))
#13 /chroot/home/fabripri/fabriprint.pt/html/app/code/core/Mage/Core/Model/Abstract.php(200): Mage::getResourceModel(’core/website_co...’, Object(Mage_Core_Model_Mysql4_Website))
#14 /chroot/home/fabripri/fabriprint.pt/html/app/code/core/Mage/Core/Model/Abstract.php(205): Mage_Core_Model_Abstract->getResourceCollection()
#15 /chroot/home/fabripri/fabriprint.pt/html/app/code/core/Mage/Core/Model/App.php(405): Mage_Core_Model_Abstract->getCollection()
#16 /chroot/home/fabripri/fabriprint.pt/html/app/code/core/Mage/Core/Model/App.php(268): Mage_Core_Model_App->_initStores()
#17 /chroot/home/fabripri/fabriprint.pt/html/app/Mage.php(434): Mage_Core_Model_App->init(’’, ‘store’, Array)
#18 /chroot/home/fabripri/fabriprint.pt/html/app/Mage.php(455): Mage::app(’’, ‘store’, Array)
#19 /chroot/home/fabripri/fabriprint.pt/html/index.php(65): Mage::run()
#20 {main}

I NEED HELP QUICKLY TT

 
Magento Community Magento Community
Magento Community
Magento Community
 
Vivekananthan
Member
 
Avatar
Total Posts:  44
Joined:  2009-06-17
 

Which version of magento are you using is it 1.4 ?

 
Magento Community Magento Community
Magento Community
Magento Community
 
Fabriprint
Jr. Member
 
Total Posts:  25
Joined:  2010-02-19
 

Yes i am almost sure is the last one :S unfortunately the mistake was mine but the guy who usually solves this and installed magento is offline. but he assured me is the last update.

 
Magento Community Magento Community
Magento Community
Magento Community
 
Vivekananthan
Member
 
Avatar
Total Posts:  44
Joined:  2009-06-17
 

Ok, Check it on the footer section on admin dashboard and give me the version of it so we can focus on solution

 
Magento Community Magento Community
Magento Community
Magento Community
 
Fabriprint
Jr. Member
 
Total Posts:  25
Joined:  2010-02-19
 

i can´t :S even the dashboard doesn´t enter and gives-me that code. if you have the last version please try it on system / cache management and see the fields, what i made was put cache management enabled and i checked all the boxes then saved.

to enter the dashboard i used this url: http://www.fabriprint.pt/index.php/fabripri_admin/

 
Magento Community Magento Community
Magento Community
Magento Community
 
coolshop
Sr. Member
 
Total Posts:  121
Joined:  2009-08-28
 

OK Fabriprint
The steps described to speedup Magento should work. That is exactly what I am using. So we have to figured out why it is not working for you. Be before that you need to solve your crash pb.

Please check:
/app/etc/local.xml

Make sure your db is configured correctly:

<default_setup>
                <
connection>
                    <
host><![CDATA[localhost]]></host>
                    <
username><![CDATA[your username]]></username>
                    <
password><![CDATA[your password]]></password>
                    <
dbname><![CDATA[your databasename]]></dbname>
                    <
active>1</active>
                </
connection>
            </
default_setup>

We need to delete all your cache files

backup the following file so we can safely delete the original cache file:
Copy /app/etc/use_cache.ser as /app/etc/use_cache1.ser
Delete /app/etc/use_cache.ser

Then reload a fresh magento admin by opening a new browser session
Let me know if is solved the pb.

If not we then need to delete the cache directories under /var/cache/
This is where everything get cache.
To be safe you can move all the directories under /var/cache to another temp directory that you
can create for that purpose.
So we end up with no cache. and the directory /var/cache/ should be empty.

Then reload a fresh magento admin by opening a new browser session
Let me know if is solved the pb.

So all we did here is clear all the cache that Magento attempted to create when you turn the cache option on in Magento Admin.

 
Magento Community Magento Community
Magento Community
Magento Community
 
Vivekananthan
Member
 
Avatar
Total Posts:  44
Joined:  2009-06-17
 

You have installed it wrongly. Are you sure that there is a mysql server host running at db.fabriprint.pt? I guess it has to be localhost or something? It clearly says that your magento installation is wrong.
Did you see your site working correct after installation? I guess not.

 
Magento Community Magento Community
Magento Community
Magento Community
 
Fabriprint
Jr. Member
 
Total Posts:  25
Joined:  2010-02-19
 

Yes, Yesterday was running, today was running, before i did it too :S if you want send me a screenshot of system / cache management and i will show you what i checked :S

 
Magento Community Magento Community
Magento Community
Magento Community
 
Fabriprint
Jr. Member
 
Total Posts:  25
Joined:  2010-02-19
 

Ok but before i start please tell me what are the consequences of deleting the cache files? :S

coolshop - 19 February 2010 05:48 AM

OK Fabriprint
The steps described to speedup Magento should work. That is exactly what I am using. So we have to figured out why it is not working for you. Be before that you need to solve your crash pb.


Please check:
/app/etc/local.xml

Make sure your db is configured correctly:

<default_setup>
                <
connection>
                    <
host><![CDATA[localhost]]></host>
                    <
username><![CDATA[your username]]></username>
                    <
password><![CDATA[your password]]></password>
                    <
dbname><![CDATA[your databasename]]></dbname>
                    <
active>1</active>
                </
connection>
            </
default_setup>

We need to delete all your cache files

backup the following file so we can safely delete the original cache file:
Copy /app/etc/use_cache.ser as /app/etc/use_cache1.ser
Delete /app/etc/use_cache.ser


Then reload a fresh magento admin by opening a new browser session
Let me know if is solved the pb.

If not we then need to delete the cache directories under /var/cache/
This is where everything get cache.
To be safe you can move all the directories under /var/cache to another temp directory that you
can create for that purpose.
So we end up with no cache. and the directory /var/cache/ should be empty.

Then reload a fresh magento admin by opening a new browser session
Let me know if is solved the pb.

So all we did here is clear all the cache that Magento attempted to create when you turn the cache option on in Magento Admin.
 
Magento Community Magento Community
Magento Community
Magento Community
 
Vivekananthan
Member
 
Avatar
Total Posts:  44
Joined:  2009-06-17
 

Ok what did you entered on the host section of database configuration?
Can you PM me the content in app/etc/local.xml file if possible

 
Magento Community Magento Community
Magento Community
Magento Community
 
Fabriprint
Jr. Member
 
Total Posts:  25
Joined:  2010-02-19
 

In the default_setup is everything alright except that i don´t known the username and password as being mine, must be of the offline guy, the rest is fine. i will make the back up of the caches tell me only his importance please i can´t lose nothing of the website :S.

PS: i remembered something on the dashboard there was always this message on the top saying: attention base url[ ] is not .. something like that unfortunately i don´t remember it all. :(

 
Magento Community Magento Community
Magento Community
Magento Community
 
Fabriprint
Jr. Member
 
Total Posts:  25
Joined:  2010-02-19
 

DUDES I DID IT ^^ thanks to you guys, i had a backup of all the website, so i changed the file use_cache.ser for the old one i had and worked ^^ i guess that changed the stupid things i had done thank you both for the supoort you guys were awesome really

 
Magento Community Magento Community
Magento Community
Magento Community
 
Vivekananthan
Member
 
Avatar
Total Posts:  44
Joined:  2009-06-17
 

Glad that @coolshop had really nailed it down smile

Glad that you sorted your site to live.

 
Magento Community Magento Community
Magento Community
Magento Community
 
coolshop
Sr. Member
 
Total Posts:  121
Joined:  2009-08-28
 

OK Caching is a way to keep a replica of data on the server hard drive to allow them to be pulled faster. This is the first step to speed up you Magento app.
As you make changes in development, the cache is not necessarily updated right away. This is why you need to refresh the cash so the new data get replicated in the cache.

By deleting the cache, you are clearing the replica so Magento use the fresh original data. To be safe I always backup something I need to delete so I can always go back to it if needed.

Now you may want to wait for someone who is more comfortable as a developer. Also Before you do anything, create a backup of your entire Magento application and database. This is good practice.

As far as the base url, you needed to setup a base url. I am sure you have done that since you were able to get on the front and back en before. However if the base url is wrong, then that is another issue.

BTW can you access your database from MyPHPAdmin?

 
Magento Community Magento Community
Magento Community
Magento Community
 
coolshop
Sr. Member
 
Total Posts:  121
Joined:  2009-08-28
 

Glad it worked.
I have been in your shoes in the past and I know the feeling when you are screwed and then the joy when you get it working again.

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top