Posting in the Magento forums has been disabled pending the implementation of a new and improved forum solution which should better serve the community.

For new questions please post at magento.stackexchange.com, the community-run support site for the Magento community. We will be providing updates on the new forum solution soon. For questions or concerns please email community@magento.com.

Magento Forum

Fatal error: Maximum execution time of 60 seconds exceeded in C:\wamp\www\magento\lib\Zend\Db\Statement\Pdo.php on line 228
 
thebargaincart
Jr. Member
 
Total Posts:  15
Joined:  2010-02-18
 

Receiving that error whenever I try to install Magento. Using WAMP with PHP version 5.3.0 and Apache version 2.0.63. Have added all php_pdo_ extensions to be on the safe side. I have no idea where to look to increase the execution time if needed. Can anyone help with this error?

Thanks.

 
Magento Community Magento Community
Magento Community
Magento Community
 
thebargaincart
Jr. Member
 
Total Posts:  15
Joined:  2010-02-18
 

fixed! Just had to increase the max_execution_time in php.ini. Set it to 1800.

 
Magento Community Magento Community
Magento Community
Magento Community
 
MSFreitas
Jr. Member
 
Total Posts:  10
Joined:  2009-10-22
 

Hy guy, i did this step, but don’t fixed. How can i do that? Can u explain?

Thanks

 
Magento Community Magento Community
Magento Community
Magento Community
 
danielpku
Jr. Member
 
Total Posts:  2
Joined:  2010-01-24
 
thebargaincart - 18 February 2010 04:37 PM

fixed! Just had to increase the max_execution_time in php.ini. Set it to 1800.

I’ve modified the php.ini file of “C:\wamp\bin\apache\Apache2.2.11\bin\php.ini”, but the problem seems the same as before.
And what’s more, I saw the max_execution_time is set to 30 secs as default, but the problem installation shows that the time limit is 60secs not 30secs.

why? and how can I fix this the very first problem in learning magento.

 
Magento Community Magento Community
Magento Community
Magento Community
 
danielpku
Jr. Member
 
Total Posts:  2
Joined:  2010-01-24
 

I’ve fixed this problem by changing the wamp server to former edition as wamp server 2.0-h.
And I think this problem might caught by wamp server’s related PHP edition, since magento 1.4 is probably unsupport php 5.3.
However the wamp server 2.0-h is using php 5.2.9-2 and wamp server2.0-i is using php 5.3.

 
Magento Community Magento Community
Magento Community
Magento Community
 
logicsound
Jr. Member
 
Total Posts:  3
Joined:  2010-03-01
 

So the newest version does not work with WAMP??  If so where can I get an older version of wamp?  I have googled can not find one.  Or is there another better way to solve this issue?

 
Magento Community Magento Community
Magento Community
Magento Community
 
thebargaincart
Jr. Member
 
Total Posts:  15
Joined:  2010-02-18
 

Ok...so basically what I did was in my php.ini file, doesn’t really matter what version you are running, I have been successful installing magento on both 2.0.63 and 2.2.11. What I did was change both the max_execution_time and max_input_time to 1800. This worked for me. I was able to then get Magento installed. I then switched back the max_input_time to its default of 60 after installation.

 
Magento Community Magento Community
Magento Community
Magento Community
 
thebargaincart
Jr. Member
 
Total Posts:  15
Joined:  2010-02-18
 

Also, just another bit of information. When I was installing Magento on my production server I noticed that the installation seems to “time out” between importing the database and when you go to the create your admin username/password screen. When this occurred all I did was hit the browser back button, and then click continue. This brought me right to the create your admin page. I believe this worked for me because the entire database was actually created (check your database to make sure that it actually was created) just the installation for some reason stalled out.

Which is probably where the max_execution_time comes into play but on my production server I did not change this and the method I described above worked.

 
Magento Community Magento Community
Magento Community
Magento Community
 
camilo sanchez
Jr. Member
 
Total Posts:  13
Joined:  2008-11-21
Dominican Republic
 

Hi, i had the same problem as you. I solve it by installing wampserver 2.0 -h and by setting the “max_execution_time” and “max_input_time” to 1800 in php.ini, I also put the “memory_limit” to 1024M. It worked!

here i drop a link to wampserver 2.0 -h I hope this helps.

http://www.megaupload.com/?d=O4L4UNM0

 
Magento Community Magento Community
Magento Community
Magento Community
 
machinehead
Jr. Member
 
Total Posts:  1
Joined:  2010-06-03
 

I give up!!!

I have installed zencart and joomla/virtuemart before and had no problem.  I wanted to compare magento but it just won\’t go.

First I couldn\’t set language to anything other than American.  Time zone and currency yes, language no.

Following the steps in http://www.magentocommerce.com/wiki/general/installing_on_windows_with_xampp_and_wamp
I can\’t get past step 5.

Tried resetting the timeouts as suggested in this thread.

Now all I get is
\’Apache HTTP Server has encountered a problem and needs to close.  We are sorry for the inconvenience.\’

If it is so hard to get a test version going I can\’t imagine ever trusting it for a live site.

 
Magento Community Magento Community
Magento Community
Magento Community
 
vidyaparab
Jr. Member
 
Total Posts:  2
Joined:  2011-08-16
 

Same here...!!! Even i was struggling with the same issue for 2 days. But just for the sake of testing purpose I installed Magento 1.5 instead of Magento 1.6. And it worked for me… So i think its being very much important to check versions of everything is compatible with each other. My Working Config now is:
1. XAMPP (Basis Package) version 1.7.3
2. Magento 1.5
3.  PHP 5.3.1
4. Apache 2.2.14 (IPV6 enabled)
5. MySQL 5.1.41 (Community Server) with PBXT engine 1.0.09-rc

smilerolleyes  rolleyes

 
Magento Community Magento Community
Magento Community
Magento Community
 
jjain230591
Jr. Member
 
Total Posts:  1
Joined:  2011-12-17
 

I had got the same error..but after changing the execution time to 1800Secs my page isnt getting redirected properly..Firefox shows that
Firefox has detected that the server is redirecting the request for this address in a way that will never complete confused please help

 
Magento Community Magento Community
Magento Community
Magento Community
 
ahillenb
Jr. Member
 
Total Posts:  7
Joined:  2011-06-14
 

had got the same error..but after changing the execution time to 1800Secs my page isnt getting redirected properly..Firefox shows that
Firefox has detected that the server is redirecting the request for this address in a way that will never complete confused please help

The same thing happened to me after I changed my max execution time. I think it had something to do with the timeout initially stopping the transfer, so there is this partial database that doesn\’t work.

I imagine somehow deleting and re-installing should work, I just am not sure what to delete and re-install.

 
Magento Community Magento Community
Magento Community
Magento Community
 
ahillenb
Jr. Member
 
Total Posts:  7
Joined:  2011-06-14
 

To address my above post, I solved it by going to this thread: http://www.magentocommerce.com/boards/v/viewthread/62272/#t189752

and doing what drf55 recommends in a post:

- delete C:\wamp\www\Magento\app\etc\local.xml
- delete the database and reimport the sample data sql file (so I had a clean DB)
- change the wamp php.ini file to allow for a much longer execution time - in all it was processing for about 6 minutes between the configuration and admin screens.

The only hiccup I had was that only changing the max_execution_time didn’t work, there was a mysql timeout in there that was also at 60. To be honest, I just scrolled down the whole php.ini file and added a 0 to anything that said max time on it. rasberry

I’m good to go now.

 
Magento Community Magento Community
Magento Community
Magento Community
 
ramanzeon
Jr. Member
 
Total Posts:  5
Joined:  2012-10-09
 

Go to
D:\wamp\bin\apache\Apache2.2.21\bin
find php.ini

set
max_execution_time = 3600
max_input_time = 3600

Enjoy !!!

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top