Magento Forum

Magento 1.4 e visualizzazione prodotti
 
michele-d
Member
 
Total Posts:  34
Joined:  2010-02-18
 

Ciao a tutti, ho installato magento 1.4, però non riesco a vedere i prodotti che inserisco. Ho abilitato tutto,categorie e prodotto. Ho inserito nella home page questo codice

{{block type="catalog/product_list" category_id="2" template="catalog/product/list.phtml"}}

che con la 1.3 mi faceva visualizzare i prodotti. Ma con questa versione non riesco a visualizzarli. Come posso risolvere?
Ho questo messaggio sia in Home,che nella categoria “There are no products matching the selection.”

Un’altra domanda,i vecchi template danno problemi con la nuova versione?

 
Magento Community Magento Community
Magento Community
Magento Community
 
Black Cat
Moderator
 
Avatar
Total Posts:  3481
Joined:  2008-02-14
Assemini / Cagliari (Italy)
 
michele-d - 18 February 2010 06:15 AM

Ciao a tutti, ho installato magento 1.4, però non riesco a vedere i prodotti che inserisco. Ho abilitato tutto,categorie e prodotto. Ho inserito nella home page questo codice

{{block type="catalog/product_list" category_id="2" template="catalog/product/list.phtml"}}

che con la 1.3 mi faceva visualizzare i prodotti. Ma con questa versione non riesco a visualizzarli. Come posso risolvere?
Ho questo messaggio sia in Home,che nella categoria “There are no products matching the selection.”

Un’altra domanda,i vecchi template danno problemi con la nuova versione?

Uhm crea una nuova installazione con un vecchio 1.3 (senza togliere l’altra e senza usare lo stesso db e percorso) e vedi se a nuova installazione quel codice funziona. Può darsi che hai aggiunto qualche altra porzione di codice che fa funzionare quel blocco ma che nella nuova versione ti sei dimenticato di aggiungere.

riguardo i template, dipende da come sono stati fatti i template.
Solitamente non dovrebbero dare problemi ma dipende dalle modifiche fatte dal webdesigner e dalle modifiche che hanno fatto ai file di Magento la Varien.

 
Magento Community Magento Community
Magento Community
Magento Community
 
michele-d
Member
 
Total Posts:  34
Joined:  2010-02-18
 

Grazie per la risposta, per quanto riguarda la visualizzazione dei prodotti,ora funziona tutto,avevo dimenticato una parentesi e non funzionava.

Per quanto riguarda i template, ho dei problemi con dei template scaricati (free) senza fare alcuna modifica. Lo stesso template che con la 1.3 funziona con la 1.4 da molti problemi,come se non interpretasse bene il CSS

 
Magento Community Magento Community
Magento Community
Magento Community
 
Black Cat
Moderator
 
Avatar
Total Posts:  3481
Joined:  2008-02-14
Assemini / Cagliari (Italy)
 
michele-d - 18 February 2010 11:24 PM

Grazie per la risposta, per quanto riguarda la visualizzazione dei prodotti,ora funziona tutto,avevo dimenticato una parentesi e non funzionava.

Per quanto riguarda i template, ho dei problemi con dei template scaricati (free) senza fare alcuna modifica. Lo stesso template che con la 1.3 funziona con la 1.4 da molti problemi,come se non interpretasse bene il CSS

magari hanno aggiunto blocchi html in più. E da vedere.

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top