Magento Forum

   
Currency Selection, and dropdown selector no longer work
 
joolsr
Sr. Member
 
Total Posts:  99
Joined:  2008-01-16
 

Hi

I’m having some odd issues with my site. The currency selector no longer works correctly. If you select a different currency it just goes back to the default currency when the page has loaded. I’m having similar issues with adding products for comparison in the category view, when you click the page loads but the product doesn’t appear in the Compare Products box. Interestingly, if you go to a Product page itself and select ‘Add to compare’ it does actually add the product to the Product Comparison.

Same issue is also apparent in the back end when I tried to change the view (’select range’) showing the number of orders or amounts on the dashboard, ie if i change from the default, ie 24 hours to YTD or month, then the page loads and it still is at 24 hours. I’m sure there are other areas where the functionality is missing too.

I’m guessing this type of functionality could be tied up with javascript but its only a guess .. I know this all used to work fine for me up to a couple of weeks ago. I hope this might help give some clues ...

I figured that my upgrade from vers 1.0.0 to 1.0.19700 may have gone screwy and not copied over all the files. (I used option 1 of the upgrade instructions, copying over files and pointing the browser at a webapge and let the database get updated). Everything else in the upgrade has worked fine.

But to nail this problem, I tried reinstalling by getting a new clean Magento file structure, then going to this Ip and folder address, then connecting to my previous database of my existing site during the installation options. This worked, as far as I have a clean filesystem, but amazingly, the bugs mentioned above are still there !! So it implies the problems actually in my MySQL database, which I find a bit odd.

I’m using Firefox 3.0 beta, a Debian Linux server running PHP 5, and version 1.0.19700 . So it should be ok.

If anyone can offer any suggestions? I’m supposed to be going live with this site next week.

 
Magento Community Magento Community
Magento Community
Magento Community
 
joolsr
Sr. Member
 
Total Posts:  99
Joined:  2008-01-16
 

I’m making some headway. I’ve found I can get the dropdown selectors to work my changing the Base URL settings in the Web section of the main Configuration screen.

Now the only problem I have is still with the compare products where it now directs me to a page taht doesnt exist when I try to add thsi product to the Compare Products lie above..

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
    Back to top