Magento Forum

Programming error when logging in to Admin CP
 
telder4336
Jr. Member
 
Total Posts:  21
Joined:  2008-05-03
 

I get the following error when logging in to the Admin CP. I had 2 orders come through and then it gave me this error. Both orders have since been deleted so they should not be causing this.

Warning: Cannot use a scalar value as an array in /nfs/c01/h04/mnt/37678/domains/shop.tactical-customs.com/html/app/code/core/Mage/Adminhtml/Block/Dashboard/Graph.php on line 322
Trace:
#0 /nfs/c01/h04/mnt/37678/domains/shop.tactical-customs.com/html/app/code/core/Mage/Adminhtml/Block/Dashboard/Graph.php(322): mageCoreErrorHandler(2, ‘Cannot use a sc...’, ‘/nfs/c01/h04/mn...’, 322, Array)
#1 /nfs/c01/h04/mnt/37678/domains/shop.tactical-customs.com/html/app/design/adminhtml/default/default/template/dashboard/graph.phtml(52): Mage_Adminhtml_Block_Dashboard_Graph->getChartUrl()
#2 /nfs/c01/h04/mnt/37678/domains/shop.tactical-customs.com/html/app/code/core/Mage/Core/Block/Template.php(131): include(’/nfs/c01/h04/mn...’)
#3 /nfs/c01/h04/mnt/37678/domains/shop.tactical-customs.com/html/app/code/core/Mage/Core/Block/Template.php(163): Mage_Core_Block_Template->fetchView(’adminhtml/defau...’)
#4 /nfs/c01/h04/mnt/37678/domains/shop.tactical-customs.com/html/app/code/core/Mage/Core/Block/Template.php(180): Mage_Core_Block_Template->renderView()
#5 /nfs/c01/h04/mnt/37678/domains/shop.tactical-customs.com/html/app/code/core/Mage/Core/Block/Abstract.php(554): Mage_Core_Block_Template->_toHtml()
#6 /nfs/c01/h04/mnt/37678/domains/shop.tactical-customs.com/html/app/code/core/Mage/Adminhtml/Block/Dashboard/Diagrams.php(49): Mage_Core_Block_Abstract->toHtml()
#7 /nfs/c01/h04/mnt/37678/domains/shop.tactical-customs.com/html/app/code/core/Mage/Core/Block/Abstract.php(193): Mage_Adminhtml_Block_Dashboard_Diagrams->_prepareLayout()
#8 /nfs/c01/h04/mnt/37678/domains/shop.tactical-customs.com/html/app/code/core/Mage/Core/Model/Layout.php(402): Mage_Core_Block_Abstract->setLayout(Object(Mage_Core_Model_Layout))
#9 /nfs/c01/h04/mnt/37678/domains/shop.tactical-customs.com/html/app/code/core/Mage/Adminhtml/Block/Dashboard.php(62): Mage_Core_Model_Layout->createBlock(’adminhtml/dashb...’)
#10 /nfs/c01/h04/mnt/37678/domains/shop.tactical-customs.com/html/app/code/core/Mage/Core/Block/Abstract.php(193): Mage_Adminhtml_Block_Dashboard->_prepareLayout()
#11 /nfs/c01/h04/mnt/37678/domains/shop.tactical-customs.com/html/app/code/core/Mage/Core/Model/Layout.php(402): Mage_Core_Block_Abstract->setLayout(Object(Mage_Core_Model_Layout))
#12 /nfs/c01/h04/mnt/37678/domains/shop.tactical-customs.com/html/app/code/core/Mage/Adminhtml/controllers/DashboardController.php(35): Mage_Core_Model_Layout->createBlock(’adminhtml/dashb...’, ‘dashboard’)
#13 /nfs/c01/h04/mnt/37678/domains/shop.tactical-customs.com/html/app/code/core/Mage/Core/Controller/Varien/Action.php(342): Mage_Adminhtml_DashboardController->indexAction()
#14 /nfs/c01/h04/mnt/37678/domains/shop.tactical-customs.com/html/app/code/core/Mage/Core/Controller/Varien/Router/Admin.php(148): Mage_Core_Controller_Varien_Action->dispatch(’index’)
#15 /nfs/c01/h04/mnt/37678/domains/shop.tactical-customs.com/html/app/code/core/Mage/Core/Controller/Varien/Front.php(146): Mage_Core_Controller_Varien_Router_Admin->match(Object(Mage_Core_Controller_Request_Http))
#16 /nfs/c01/h04/mnt/37678/domains/shop.tactical-customs.com/html/app/Mage.php(427): Mage_Core_Controller_Varien_Front->dispatch()
#17 /nfs/c01/h04/mnt/37678/domains/shop.tactical-customs.com/html/index.php(40): Mage::run(’default’)
#18 {main}

Any insight in where to correct this and what needs to be done would be helpful

 
Magento Community Magento Community
Magento Community
Magento Community
 
telder4336
Jr. Member
 
Total Posts:  21
Joined:  2008-05-03
 

Found out this is a bug in the system from a variable that isn’t declared properly. This has been fixed for the time being.

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top